Bug 434582 - Kmail segmentation fault
Summary: Kmail segmentation fault
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.16.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-18 14:31 UTC by Sławek
Modified: 2021-04-18 04:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sławek 2021-03-18 14:31:15 UTC
SUMMARY

I just got seg fault in Kmail:

Application: KMail (kmail), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f2e940019e0 in KCalendarCore::IncidenceBase::uid() const () at /usr/lib/libKF5CalendarCore.so.5
#5  0x00007f2e58482503 in  () at /usr/lib/libKF5AkonadiCalendar.so.5
#6  0x00007f2e5848b89e in  () at /usr/lib/libKF5AkonadiCalendar.so.5
#7  0x00007f2e5848c577 in  () at /usr/lib/libKF5AkonadiCalendar.so.5
#8  0x00007f2e9ac8ed86 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007f2e9abf0f86 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) () at /usr/lib/libQt5Core.so.5
#10 0x00007f2e9ac2d608 in  () at /usr/lib/libQt5Core.so.5
#11 0x00007f2e9ac8edc0 in  () at /usr/lib/libQt5Core.so.5
#12 0x00007f2e9abf0f86 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) () at /usr/lib/libQt5Core.so.5
#13 0x00007f2e9ac2d608 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007f2e9ac8edc0 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007f2e9abf0f86 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) () at /usr/lib/libQt5Core.so.5
#16 0x00007f2e9ac2d608 in  () at /usr/lib/libQt5Core.so.5
#17 0x00007f2e9ac8edc0 in  () at /usr/lib/libQt5Core.so.5
#18 0x00007f2e9abf0f86 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) () at /usr/lib/libQt5Core.so.5
#19 0x00007f2e98995c7a in  () at /usr/lib/libKF5ItemModels.so.5
#20 0x00007f2e9ac8edc0 in  () at /usr/lib/libQt5Core.so.5
#21 0x00007f2e9abf0f86 in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) () at /usr/lib/libQt5Core.so.5
#22 0x00007f2e98c4a74c in  () at /usr/lib/libKF5AkonadiCore.so.5
#23 0x00007f2e98c52c69 in  () at /usr/lib/libKF5AkonadiCore.so.5
#24 0x00007f2e9ac8edc0 in  () at /usr/lib/libQt5Core.so.5
#25 0x00007f2e98bb5f88 in Akonadi::Monitor::itemChanged(Akonadi::Item const&, QSet<QByteArray> const&) () at /usr/lib/libKF5AkonadiCore.so.5
#26 0x00007f2e98bc6f34 in Akonadi::MonitorPrivate::emitItemsNotification(Akonadi::Protocol::ItemChangeNotification const&, QVector<Akonadi::Item> const&, Akonadi::Collection const&, Akonadi::Collection const&) () at /usr/lib/libKF5AkonadiCore.so.5
#27 0x00007f2e98bc830b in Akonadi::MonitorPrivate::emitNotification(QSharedPointer<Akonadi::Protocol::ChangeNotification> const&) () at /usr/lib/libKF5AkonadiCore.so.5
#28 0x00007f2e98bc53dc in Akonadi::MonitorPrivate::dispatchNotifications() () at /usr/lib/libKF5AkonadiCore.so.5
#29 0x00007f2e98bc56c4 in Akonadi::MonitorPrivate::slotNotify(QSharedPointer<Akonadi::Protocol::ChangeNotification> const&) () at /usr/lib/libKF5AkonadiCore.so.5
#30 0x00007f2e98bc8827 in Akonadi::MonitorPrivate::handleCommands() () at /usr/lib/libKF5AkonadiCore.so.5
#31 0x00007f2e9ac84532 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#32 0x00007f2e9b71f752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#33 0x00007f2e9ac57a2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#34 0x00007f2e9ac5a523 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#35 0x00007f2e9acb1054 in  () at /usr/lib/libQt5Core.so.5
#36 0x00007f2e9507fb84 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#37 0x00007f2e950d3c21 in  () at /usr/lib/libglib-2.0.so.0
#38 0x00007f2e9507e3b1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#39 0x00007f2e9acb0691 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#40 0x00007f2e9ac563ac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#41 0x00007f2e9ac5e844 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#42 0x00005633397b3181 in  ()
#43 0x00007f2e9a61db25 in __libc_start_main () at /usr/lib/libc.so.6
#44 0x00005633397b337e in  ()
[Inferior 1 (process 105041) detached]


STEPS TO REPRODUCE
Just run Kmail in the background. I wasn't doing anything special when it happened.


OBSERVED RESULT
Seg fault

EXPECTED RESULT
It should run properly

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.7-arch1-1
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz
Memory: 62,6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
(available in About System)

ADDITIONAL INFORMATION
KMail
Version 5.16.3 (20.12.3)
Comment 1 Alois Wohlschlager 2021-03-19 06:51:16 UTC
The backtrace is missing debug information. Please build the packages providing the libraries appearing in the backtrace with debug symbols. Then, try to reproduce the bug and supply a backtrace again.
Comment 2 Sławek 2021-03-19 07:40:15 UTC
Hi,

I'm working on Arch Linux and AFAIK it doesn't provides packages with debug symbols.
This is my main laptop used for work and I'm not going to remove software installed with packages to replace it with compiled from source. So probably You can close that bug as I will not be able to provide any more information about it :/
Comment 3 Bug Janitor Service 2021-04-03 04:33:31 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2021-04-18 04:33:17 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!