Bug 434515 - Changing a sensor color in a chart with multiple sensors wrongly applies it to every sensor in that chart
Summary: Changing a sensor color in a chart with multiple sensors wrongly applies it t...
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.21.3
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 434859 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-16 22:24 UTC by MScattolin
Modified: 2021-03-24 08:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21.4


Attachments
gif illustrating the situation (3.25 MB, image/gif)
2021-03-17 16:52 UTC, MScattolin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MScattolin 2021-03-16 22:24:43 UTC
SUMMARY
When customizing the overview page, you can't assign different colors to each sensor other than the defaults.

STEPS TO REPRODUCE
1. Start systemmonitor for the first time (I've erased ~/.local/share/plasma-systemmonitor/overview.page)
2. Click on "Edit Page"
3. Add a new column to the top row
4. Add 2 sensors to that column
5. Pick a new color to one of them by clicking on the color square beside the name
6. Pick another color by clicking on the square on the other sensor

OBSERVED RESULT
Both sensors are assigned the color chosen on step 6.

EXPECTED RESULT
When picking a color on step 6, the color chosen during the step 5 should remain.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 5.11.6
(available in About System)
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 David Redondo 2021-03-17 14:18:49 UTC
When I edit colors, the colors in the chart change but not in the legend, do you see the same?
Comment 2 MScattolin 2021-03-17 16:52:58 UTC
Created attachment 136794 [details]
gif illustrating the situation

Not really, I've attached a gif showing what happens.
Comment 3 David Redondo 2021-03-18 08:17:10 UTC
Ah yes, I can reproduce it
Comment 4 Bug Janitor Service 2021-03-18 11:00:07 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/libksysguard/-/merge_requests/140
Comment 5 David Redondo 2021-03-18 11:18:34 UTC
Git commit ed89bbf919c0e2cf4b3a5a0c32978314e9e10e20 by David Redondo.
Committed on 18/03/2021 at 10:57.
Pushed by davidre into branch 'master'.

Assign a new color when configuring sensor colors

For some weird reason what we did had the effect of getting a reference
to the color of the ColorDialog. So when changing a sensor color it
would change the colors of all sensor colors that where configured
before.
FIXED-IN:5.21.4

M  +1    -1    faces/ConfigSensors.qml

https://invent.kde.org/plasma/libksysguard/commit/ed89bbf919c0e2cf4b3a5a0c32978314e9e10e20
Comment 6 David Redondo 2021-03-18 11:18:57 UTC
Git commit 265337b6901f9170e8151412a5033c71fc79d00e by David Redondo.
Committed on 18/03/2021 at 11:18.
Pushed by davidre into branch 'Plasma/5.21'.

Assign a new color when configuring sensor colors

For some weird reason what we did had the effect of getting a reference
to the color of the ColorDialog. So when changing a sensor color it
would change the colors of all sensor colors that where configured
before.
FIXED-IN:5.21.4


(cherry picked from commit ed89bbf919c0e2cf4b3a5a0c32978314e9e10e20)

M  +1    -1    faces/ConfigSensors.qml

https://invent.kde.org/plasma/libksysguard/commit/265337b6901f9170e8151412a5033c71fc79d00e
Comment 7 David Redondo 2021-03-24 08:06:00 UTC
*** Bug 434859 has been marked as a duplicate of this bug. ***