Bug 434344 - Crash in events?
Summary: Crash in events?
Status: RESOLVED DUPLICATE of bug 443978
Alias: None
Product: krita
Classification: Unclassified
Component: * Unknown (show other bugs)
Version: git master (please specify the git hash!)
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-12 22:47 UTC by Tiar
Modified: 2021-12-16 12:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash log for all threads (12.63 KB, text/plain)
2021-03-12 22:47 UTC, Tiar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tiar 2021-03-12 22:47:01 UTC
Created attachment 136632 [details]
Crash log for all threads

SUMMARY
I was coloring an animation. I've got this weird event bug where my palm triggers the start of the stroke, then my pen is above the surface but still paints, and I have to touch the surface and undo. However it happens every now and then and usually doesn't lead to a crash.

STEPS TO REPRODUCE
:(

OBSERVED RESULT
Crash

EXPECTED RESULT
No crash

SOFTWARE/OS VERSIONS
Krita

 Version: 5.0.0-prealpha (git 4cb4711)
 Languages: pl_PL, pl, pl_PL, pl
 Hidpi: true

Qt

  Version (compiled): 5.11.1
  Version (loaded): 5.11.1

ADDITIONAL INFORMATION
QLayout: Attempting to add QLayout "" to KisShortcutsDialog "", which already has a layout
Failed to fetch display info: "current platform doesn't support fetching display information"
Pasted time range KisTimeSpan(0, 4)

Thread 1 "krita" received signal SIGSEGV, Segmentation fault.
0x00007fffad57c1c0 in ?? ()
(gdb) bt
#0  0x00007fffad57c1c0 in  ()
#1  0x00007ffff4722739 in QMetaObject::cast(QObject const*) const () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007ffff5233770 in QMdiArea::eventFilter(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#3  0x00007ffff471907b in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007ffff50d84d8 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#5  0x00007ffff50dfae0 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#6  0x00007ffff6ff78a7 in KisApplication::notify(QObject*, QEvent*) (this=<optimized out>, receiver=0x55555d738260, event=0x7fffad2e73c0) at /home/tymon/kritadev/krita/libs/ui/KisApplication.cpp:710
#7  0x00007ffff4719499 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007ffff471c48b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007ffff476bb23 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007ffff0637d5e in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007ffff0637ff8 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007ffff063808c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007ffff476b143 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fffea76de51 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#15 0x00007ffff471816b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007ffff47202e2 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x0000555555e2a21b in main (argc=<optimized out>, argv=0x7fffffffde28) at /home/tymon/kritadev/krita/krita/main.cc:663
#18 0x00007ffff3d48b6b in __libc_start_main (main=0x555555e28890 <main>, argc=1, argv=0x7fffffffde28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffde18) at ../csu/libc-start.c:308
#19 0x0000555555e2b2da in _start () at /home/tymon/kritadev/krita/krita/main.cc:468
Comment 1 Lynx3d 2021-03-16 07:18:36 UTC
I just had a crash with the same backtrace too, the build was based on f2a09b1264f6d751030b61efe0e04c797cd69741
All libs from Ubuntu 20.04 except LCMS and libheif, but that doesn't seem involved here.

Came totally out of the blue, I was only doing some simple sketch strokes and using a bit of selection and transform tools, like I did the day before for many hours without issue.

There is only one thing I didn't do the days before, I used "resize canvas" to slightly move all layers in the image down before starting to paint, but that was a few minutes before it crashed. So no idea how to reproduce it...
Comment 2 Dmitry Kazakov 2021-12-16 12:23:27 UTC
Looks like a duplicate of the memory corruption crash David reported later and I fixed in Krita 5.0 Beta 3.

*** This bug has been marked as a duplicate of bug 443978 ***