Bug 434160 - Screenshot from keyboard shortcut doesn't obey in-GUI settings
Summary: Screenshot from keyboard shortcut doesn't obey in-GUI settings
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 20.12.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-08 20:31 UTC by groot
Modified: 2021-03-08 20:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description groot 2021-03-08 20:31:25 UTC
SUMMARY

(Vaguely like #414910) If I configure a shortcut for "capture active window", and then trigger it, the screenshot also includes the window decorations. This happens even if if the option / checkbox is **off** in the GUI of spectacle (also even if spectacle is currently running)

STEPS TO REPRODUCE
1. Start spectacle
2. Configure alt-^ to capture current window (*Configure* -> *Shortcuts* pane). Ok the shortcuts dialog.
3. In the GUI of spectacle, uncheck the box "include window titlebar and borders"
4. Activate another window
5. Hit alt-^ (i.e. use the shortcut)

OBSERVED RESULT

Screenshot of active window with window titlebar and borders.

EXPECTED RESULT

Screenshot without window titlebar or borders.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: neon user edition 5.20
Comment 1 Nate Graham 2021-03-08 20:37:26 UTC

*** This bug has been marked as a duplicate of bug 392057 ***