Bug 433953 - plasma systemmonitor desktop widget: network device specific sensors are not remembered
Summary: plasma systemmonitor desktop widget: network device specific sensors are not ...
Status: NEEDSINFO WAITINGFORINFO
Alias: None
Product: plasmashell
Classification: Plasma
Component: System Monitor (show other bugs)
Version: 5.24.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-04 12:37 UTC by Till Schäfer
Modified: 2024-02-23 03:46 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2021-03-04 12:37:19 UTC
When configuring the network device sensors (e.g., download speed) of a certain device (as widget), the sensor settings are lost on re-login, i.e., no sensors are configured at all.

This might be related to Bug 433951 "plasma systemmonitor network device sensors should actually show the device and not the network", since the actual networks do not exist on login in my case (Networkmanager needs to establish them after providing the credentials via kwallet unlocking). 

Operating System: Gentoo Linux
KDE Plasma Version: 5.21.2
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.10.18-gentoo
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 1 Till Schäfer 2021-10-28 14:28:22 UTC
This is always reproducible when rebooting with disconnected devices. (which is always true for a wifi that needs to wait for a password)
Comment 2 Till Schäfer 2021-10-28 14:31:01 UTC
To be more precise, the widget has no more sensors configured. 
Furthermore, the widget is in broken state and re-adding the lost sensors to the sensors list does not have any effect. Only removing and re-adding the whole widget solves the issue until the next logout.
Comment 3 Nate Graham 2024-02-08 20:07:07 UTC
Thank you for the bug report. Unfortunately we were not able to get to it yet. Can we ask you to please check if this is still an issue in Plasma 5.27?
Comment 4 Bug Janitor Service 2024-02-23 03:46:15 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!