Bug 433793 - Widget Explorer moves windows on secondary screen away on Wayland
Summary: Widget Explorer moves windows on secondary screen away on Wayland
Status: RESOLVED DUPLICATE of bug 426969
Alias: None
Product: plasmashell
Classification: Plasma
Component: Widget Explorer (show other bugs)
Version: 5.21.0
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-01 14:08 UTC by kde
Modified: 2022-01-12 18:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2021-03-01 14:08:41 UTC
SUMMARY
Opening the Widget Explorer moves windows that are opened on a secondary screen away when running under Wayland.

STEPS TO REPRODUCE
0. Have multiple monitors attached
1. Start wayland session (wayland or full-wayland)
2. Put a random window (e.g. Dolphin) on the secondary screen, not maximized
3. Open Widget Explorer on secondary screen
4. Window is moved away.

OBSERVED RESULT
Window should stay in place, Widget Explorer should overlay it.

EXPECTED RESULT
Window position is messed with.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210223
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.10.16-1-default
OS Type: 64-bit
Graphics Platform: Wayland
Processors: 24 × AMD Ryzen 9 3900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: Radeon RX 570 Series

ADDITIONAL INFORMATION
The Widget Explorer doesn't move windows away on single-screen setups.
Comment 1 Nate Graham 2022-01-12 18:25:03 UTC

*** This bug has been marked as a duplicate of bug 426969 ***