Bug 433671 - can not resize the list of the sessions to open
Summary: can not resize the list of the sessions to open
Status: RESOLVED DUPLICATE of bug 332512
Alias: None
Product: kate
Classification: Applications
Component: sessions (show other bugs)
Version: 20.12.2
Platform: Slackware Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-26 18:28 UTC by Dmitri Koulikoff
Modified: 2022-01-16 17:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Not possible to resize (217.71 KB, video/x-matroska)
2022-01-16 15:25 UTC, Dmitri Koulikoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Koulikoff 2021-02-26 18:28:03 UTC
SUMMARY

When I open the kate sessions popup it can not be resized any more in kde4 in contrast with kde4

STEPS TO REPRODUCE
1. Click on the Kate Session Launcher
2. Try to resize the opened list of the existing sessions

OBSERVED RESULT

It is not resizable any more.


EXPECTED RESULT

I should be able to change the height fo the widget.


SOFTWARE/OS VERSIONS
Operating System: Slackware-current
KDE Plasma Version: 5.21.1
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.10.18
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630.

ADDITIONAL INFORMATION
Probably, this problem is connected with the inability of the plasma widgets to be resized.
Then the height must be enough to show all existing sessions or reach the top of the window with the scroll bar.
The width must be enough to show the names of all the session names.
Then it is worth to add a setting for that also.
Comment 1 Dmitri Koulikoff 2022-01-16 13:33:41 UTC
If the resize is not possible, make it 80% of the screen height
Comment 2 Waqar Ahmed 2022-01-16 13:55:30 UTC
resizing the sessions dialog seems to working here. Please try with 21.12
Comment 3 Dmitri Koulikoff 2022-01-16 15:25:14 UTC
Created attachment 145549 [details]
Not possible to resize
Comment 4 Dmitri Koulikoff 2022-01-16 15:26:27 UTC
(In reply to Waqar Ahmed from comment #2)
> resizing the sessions dialog seems to working here. Please try with 21.12

I have sent what is happening with 21.12.1
Comment 5 Nate Graham 2022-01-16 16:13:35 UTC

*** This bug has been marked as a duplicate of bug 430332 ***
Comment 6 Nate Graham 2022-01-16 16:14:37 UTC

*** This bug has been marked as a duplicate of bug 332512 ***
Comment 7 Dmitri Koulikoff 2022-01-16 17:04:57 UTC
(In reply to Nate Graham from comment #6)
> 
> *** This bug has been marked as a duplicate of bug 332512 ***

in the bug 332512 they speak the the new size it not being saved, but in my case I can not even resize it.
Comment 8 Nate Graham 2022-01-16 17:07:21 UTC
It's the same thing. The people resizing it are using hacks to do so that are not supported. In all cases, the resolution is the same: properly support resizing panel popups.

*** This bug has been marked as a duplicate of bug 332512 ***