Bug 433520 - ksplashqml crashes and blocks plasmashell
Summary: ksplashqml crashes and blocks plasmashell
Status: RESOLVED DUPLICATE of bug 419492
Alias: None
Product: ksplash
Classification: Plasma
Component: general (show other bugs)
Version: 5.21.1
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-24 05:45 UTC by physkets
Modified: 2021-02-25 03:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Filtered stacktrace of ksplashqml (5.69 KB, text/plain)
2021-02-24 05:45 UTC, physkets
Details
Filtered stacktrace of ksplashqml (full) (20.02 KB, text/plain)
2021-02-24 11:55 UTC, physkets
Details

Note You need to log in before you can comment on or make changes to this bug.
Description physkets 2021-02-24 05:45:45 UTC
Created attachment 136105 [details]
Filtered stacktrace of ksplashqml

SUMMARY

Upon login, after the splash screen is displayed, I am taken to a black screen, so I assume plasma shell is not loaded.

Is this related to bug #432364 : ?
https://bugs.kde.org/show_bug.cgi?id=432364


Operating System: Arch Linux
KDE Plasma Version: 5.21.1
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Kernel Version: 5.11.1-arch1-1
OS Type: 64-bit
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 PRO 4750U with Radeon Graphics
Memory: 14.9 GiB of RAM
Graphics Processor: AMD RENOIR

ADDITIONAL INFORMATION

I am attaching a filtered stacktrace of the crash as obtained from `coredumpctl info`.
Comment 1 physkets 2021-02-24 06:06:01 UTC
Also, as before (i.e., v5.21.0), when I add the environment variable "KDE_DEBUG=1" to the [Serivce] section of the plasma-plasmashell unit file, it does not give me a blank screen, and actually starts plasmashell.
Comment 2 argonel 2021-02-24 07:01:19 UTC
Pasting stacktrace from file:

           PID: 1059 (ksplashqml)
           UID: 1000 (username)
           GID: 1000 (username)
        Signal: 11 (SEGV)
     Timestamp: Wed 2021-02-24 11:01:40 IST (3min 54s ago)
  Command Line: /usr/bin/ksplashqml Breeze
    Executable: /usr/bin/ksplashqml
 Control Group: /user.slice/user-1000.slice/session-4.scope
          Unit: session-4.scope
         Slice: user-1000.slice
       Session: 4
     Owner UID: 1000 (username)
       Boot ID: 84917da69c5046ec914b024b2fccff37
    Machine ID: 89025bd2327742a98f1b9c991e2606e4
      Hostname: hostname
       Storage: /var/lib/systemd/coredump/core.ksplashqml.1000.84917da69c5046ec914b024b2fccff37.1059.1614144700000000.zst
       Message: Process 1059 (ksplashqml) of user 1000 dumped core.
                
                Stack trace of thread 1059:
                #0  0x00007f562715eef5 raise (libc.so.6 + 0x3cef5)
                #1  0x00007f5622a21157 KCrash::defaultCrashHandler(int) (libKF5Crash.so.5 + 0x4157)
                #2  0x00007f562715ef80 __restore_rt (libc.so.6 + 0x3cf80)
                #3  0x00007f5627b3e60c QPlatformScreen::screen() const (libQt5Gui.so.5 + 0x11d60c)
                #4  0x00007f56228c9687 QtWaylandClient::QWaylandWindow::handleScreensChanged() (libQt5WaylandClient.so.5 + 0x75687)
                #5  0x00007f56277b8d86 n/a (libQt5Core.so.5 + 0x2ecd86)
                #6  0x00007f5625524acd n/a (libffi.so.7 + 0x6acd)
                #7  0x00007f562552403a n/a (libffi.so.7 + 0x603a)
                #8  0x00007f5627117fe4 n/a (libwayland-client.so.0 + 0x9fe4)
                #9  0x00007f5627114563 n/a (libwayland-client.so.0 + 0x6563)
                #10 0x00007f5627115cac wl_display_dispatch_queue_pending (libwayland-client.so.0 + 0x7cac)
                #11 0x00007f56228c527d QtWaylandClient::QWaylandDisplay::flushRequests() (libQt5WaylandClient.so.5 + 0x7127d)
                #12 0x00007f56277b8dc0 n/a (libQt5Core.so.5 + 0x2ecdc0)
                #13 0x00007f56277da6ce QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x30e6ce)
                #14 0x00007f56277803ac QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x2b43ac)
                #15 0x00007f5627788844 QCoreApplication::exec() (libQt5Core.so.5 + 0x2bc844)
                #16 0x000055655813b09b n/a (ksplashqml + 0x509b)
                #17 0x00007f5627149b25 __libc_start_main (libc.so.6 + 0x27b25)
                #18 0x000055655813b0fe n/a (ksplashqml + 0x50fe)
                
                Stack trace of thread 1101:
                #0  0x00007f56267f59ba __futex_abstimed_wait_common64 (libpthread.so.0 + 0x159ba)
                #1  0x00007f56267ef260 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf260)
                #2  0x00007f5620286cec n/a (radeonsi_dri.so + 0x4edcec)
                #3  0x00007f56202854c8 n/a (radeonsi_dri.so + 0x4ec4c8)
                #4  0x00007f56267e9299 start_thread (libpthread.so.0 + 0x9299)
                #5  0x00007f5627221053 __clone (libc.so.6 + 0xff053)
                
                Stack trace of thread 1112:
                #0  0x00007f56267f59ba __futex_abstimed_wait_common64 (libpthread.so.0 + 0x159ba)
                #1  0x00007f56267ef260 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf260)
                #2  0x00007f56275a00c4 QWaitCondition::wait(QMutex*, QDeadlineTimer) (libQt5Core.so.5 + 0xd40c4)
                #3  0x00007f562844233b n/a (libQt5Quick.so.5 + 0x1f633b)
                #4  0x00007f56284448db n/a (libQt5Quick.so.5 + 0x1f88db)
                #5  0x00007f5627599eff n/a (libQt5Core.so.5 + 0xcdeff)
                #6  0x00007f56267e9299 start_thread (libpthread.so.0 + 0x9299)
                #7  0x00007f5627221053 __clone (libc.so.6 + 0xff053)
                
                Stack trace of thread 1095:
                #0  0x00007f56267f59ba __futex_abstimed_wait_common64 (libpthread.so.0 + 0x159ba)
                #1  0x00007f56267ef260 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf260)
                #2  0x00007f5620286cec n/a (radeonsi_dri.so + 0x4edcec)
                #3  0x00007f56202854c8 n/a (radeonsi_dri.so + 0x4ec4c8)
                #4  0x00007f56267e9299 start_thread (libpthread.so.0 + 0x9299)
                #5  0x00007f5627221053 __clone (libc.so.6 + 0xff053)
                
                Stack trace of thread 1079:
                #0  0x00007f56267f59ba __futex_abstimed_wait_common64 (libpthread.so.0 + 0x159ba)
                #1  0x00007f56267ef260 pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0 + 0xf260)
                #2  0x00007f5620286cec n/a (radeonsi_dri.so + 0x4edcec)
                #3  0x00007f56202854c8 n/a (radeonsi_dri.so + 0x4ec4c8)
                #4  0x00007f56267e9299 start_thread (libpthread.so.0 + 0x9299)
                #5  0x00007f5627221053 __clone (libc.so.6 + 0xff053)
                
                Stack trace of thread 1102:
                #0  0x00007ffc12beaacd __vdso_clock_gettime (linux-vdso.so.1 + 0xacd)
                #1  0x00007f56271e9015 __clock_gettime (libc.so.6 + 0xc7015)
                #2  0x00007f562557d7ac g_main_context_prepare (libglib-2.0.so.0 + 0x537ac)
                #3  0x00007f56255d1a26 n/a (libglib-2.0.so.0 + 0xa7a26)
                #4  0x00007f562557c3b1 g_main_context_iteration (libglib-2.0.so.0 + 0x523b1)
                #5  0x00007f56277da6ac QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x30e6ac)
                #6  0x00007f56277803ac QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x2b43ac)
                #7  0x00007f5627598d12 QThread::exec() (libQt5Core.so.5 + 0xccd12)
                #8  0x00007f5628154098 n/a (libQt5DBus.so.5 + 0x17098)
                #9  0x00007f5
Comment 3 physkets 2021-02-24 11:55:14 UTC
Created attachment 136109 [details]
Filtered stacktrace of ksplashqml (full)

The earlier attachment did not have the full trace because the `coredumpctl info` command truncates it. This is from `coredumpctl dump`.
Comment 4 Nate Graham 2021-02-25 03:22:59 UTC
Relevant bit:

Stack trace of thread 1059:
                #0  0x00007f562715eef5 raise (libc.so.6 + 0x3cef5)
                #1  0x00007f5622a21157 KCrash::defaultCrashHandler(int) (libKF5Crash.so.5 + 0x4157)
                #2  0x00007f562715ef80 __restore_rt (libc.so.6 + 0x3cf80)
                #3  0x00007f5627b3e60c QPlatformScreen::screen() const (libQt5Gui.so.5 + 0x11d60c)
                #4  0x00007f56228c9687 QtWaylandClient::QWaylandWindow::handleScreensChanged() (libQt5WaylandClient.so.5 + 0x75687)
                #5  0x00007f56277b8d86 n/a (libQt5Core.so.5 + 0x2ecd86)
                #6  0x00007f5625524acd n/a (libffi.so.7 + 0x6acd)
                #7  0x00007f562552403a n/a (libffi.so.7 + 0x603a)
                #8  0x00007f5627117fe4 n/a (libwayland-client.so.0 + 0x9fe4)
                #9  0x00007f5627114563 n/a (libwayland-client.so.0 + 0x6563)
                #10 0x00007f5627115cac wl_display_dispatch_queue_pending (libwayland-client.so.0 + 0x7cac)
                #11 0x00007f56228c527d QtWaylandClient::QWaylandDisplay::flushRequests() (libQt5WaylandClient.so.5 + 0x7127d)
                #12 0x00007f56277b8dc0 n/a (libQt5Core.so.5 + 0x2ecdc0)
                #13 0x00007f56277da6ce QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x30e6ce)
                #14 0x00007f56277803ac QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (libQt5Core.so.5 + 0x2b43ac)
                #15 0x00007f5627788844 QCoreApplication::exec() (libQt5Core.so.5 + 0x2bc844)
                #16 0x000055655813b09b n/a (ksplashqml + 0x509b)
                #17 0x00007f5627149b25 __libc_start_main (libc.so.6 + 0x27b25)
                #18 0x000055655813b0fe n/a (ksplashqml + 0x50fe)

*** This bug has been marked as a duplicate of bug 419492 ***