Bug 433302 - crash when attempting to remove mount on unfinished disk
Summary: crash when attempting to remove mount on unfinished disk
Status: RESOLVED DUPLICATE of bug 432103
Alias: None
Product: partitionmanager
Classification: Applications
Component: general (show other bugs)
Version: 20.12.2
Platform: Manjaro Linux
: NOR normal
Target Milestone: ---
Assignee: Andrius Štikonas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-20 08:49 UTC by Thibault Molleman
Modified: 2021-02-20 10:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thibault Molleman 2021-02-20 08:49:28 UTC
SUMMARY
I stumbled upon this when I was modifying a disk's partitions. When you create a new partition, assign it a mount point. But then don't actually click 'apply', next time you try to change that mount point, it crashes

STEPS TO REPRODUCE
(disclaimer: it might be that these steps don't need to be as exact, I'm just describing my exact scenario)
1. Take a disk with an existing partition.
2. Shrink that partition. (ntfs in my case)
3. Create a new partition in that freed up space (xfs in my case)
4. Right click the new partition and set a mount point (/Steam850EVO2TB for me, and enable 'users can mount or unmount')
5. (might have exited and reopened kde part manager here, not sure)
6. right click that partition again and remove the mount point using the 'remove' button.

OBSERVED RESULT
Terminal output: 

EXPECTED RESULT
Couldn't figure out how to verbose kde part manager, all it says in terminal is
zsh: segmentation fault (core dumped)  partitionmanager
The program just crashes the moment I click that delete button in the mount options

SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.15-1-MANJARO
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: GeForce GTX 1080/PCIe/SSE2

Full: https://gist.github.com/thibaultmol/b845e46387db60129b02df77c08a36e5 

ADDITIONAL INFORMATION
Comment 1 Andrius Štikonas 2021-02-20 10:13:03 UTC
And it doesn't show any backtrace after the crash?
Comment 2 Andrius Štikonas 2021-02-20 10:13:45 UTC
I suspect duplicate of https://bugs.kde.org/show_bug.cgi?id=432103
Comment 3 Andrius Štikonas 2021-02-20 10:14:05 UTC

*** This bug has been marked as a duplicate of bug 432103 ***