Bug 433266 - [Regression] Advanced keyboard options broken on Wayland
Summary: [Regression] Advanced keyboard options broken on Wayland
Status: RESOLVED DUPLICATE of bug 433265
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_keyboard (show other bugs)
Version: 5.21.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-19 18:45 UTC by Thiago Sueto
Modified: 2021-12-17 14:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Sueto 2021-02-19 18:45:47 UTC
SUMMARY
For me, the option "Both shift keys enable Caps Lock, one shift disables it" and "Caps Lock as Ctrl" have broken after recent updates. It seems to be a general bug in the advanced keyboard options, as a user on reddit mentions "Swap Caps Lock and Ctrl" got broken as well on 5.21.
https://www.reddit.com/r/kde/comments/lnmurg/swap_caps_lock_and_esc_not_working_on_wayland_but/?utm_source=share&utm_medium=web2x&context=3

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210217 (Krypton)
KDE Plasma Version: 5.21.80
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 1 Thiago Sueto 2021-02-20 19:25:25 UTC

*** This bug has been marked as a duplicate of bug 433265 ***
Comment 2 Nate Graham 2021-03-31 19:49:48 UTC

*** This bug has been marked as a duplicate of bug 433576 ***
Comment 3 Nate Graham 2021-12-17 14:11:35 UTC

*** This bug has been marked as a duplicate of bug 433265 ***