Bug 433215 - Regression: can no longer delete or disable unwanted fonts
Summary: Regression: can no longer delete or disable unwanted fonts
Status: VERIFIED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_fontinst (show other bugs)
Version: 5.21.0
Platform: Other Linux
: VHI normal with 1 vote (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-02-19 02:25 UTC by Dan Dascalescu
Modified: 2021-02-25 03:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21.1


Attachments
Screencast (1.03 MB, video/webm)
2021-02-19 02:25 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2021-02-19 02:25:15 UTC
Created attachment 135878 [details]
Screencast

KDE neon 5.21 ships with a ridiculous number of completely irrelevant Noto fonts (hieroglyphic, cuneiform etc.). In KDE 5.18 I was able to remove them. In 5.21, I get an error that every single one of them does not actually exist.

The problem is that this list of exotic fonts clutters the font selector in applications (LibreOffice etc.), and makes it a pain in the ass to select the font I want.

Why are fonts in all sorts of non-Latin alphabets installed to begin with, when I selected US English in the installer? Are they some variants of Noto that can't be separated from the useful ones? Bundling them together seems like a patch for a very corner case in which a user needs Egyptian Hieroglyphs and Mayan Numerals, rather than a solution, but I guess that's an issue for a different component.

The issue here is that I *was* able to delete these fonts in 5.18, and now I'm not. Trying to disable them results in the same error. I'm stuck with that long list of crap on a daily basis, in all applications that have a font selector :-/

Combined with bug 433166, this makes it a net worse experience to have upgraded from 5.18.5.
Comment 1 Nate Graham 2021-02-19 18:18:51 UTC
Eek. Can confirm.
Comment 2 David Edmundson 2021-02-21 14:01:31 UTC
Findings so far:

It does work in 5.20

It fails FontInst::findFontReal
Even though the initial list comes from FontInst
Comment 3 David Edmundson 2021-02-21 21:50:17 UTC
After a lot of bisecting, it seems this was caused by 567d49f55c2cd4a7dab5e5c70c688b3f3ff42203
Comment 5 Nate Graham 2021-02-22 18:23:55 UTC
Fixed by David Edmundson with https://invent.kde.org/plasma/plasma-workspace/-/commit/c8395e7afad7c63ee5cceee72faa57399c0f7704 in Plasma 5.21.1!
Comment 6 Dan Dascalescu 2021-02-25 03:46:14 UTC
Confirming fixed in 5.21.1. Thank you!