Bug 433140 - Global clear button in notification applet is hidden in a hamburger menu
Summary: Global clear button in notification applet is hidden in a hamburger menu
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Notifications (show other bugs)
Version: 5.21.0
Platform: OpenSUSE Linux
: HI normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords: regression
: 435659 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-18 07:38 UTC by Philippe ROUBACH
Modified: 2021-05-05 21:50 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2021-02-18 07:38:21 UTC
SUMMARY


since update to kde frameworks 5.79.0 and plasma 5.21.0

OBSERVED RESULT

there is no more a button to cancel all notifications

EXPECTED RESULT

there is still a button to cancel all notifications

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

kde apps 20.12.2
Comment 1 Nate Graham 2021-02-18 15:12:23 UTC
It's there, it's just hidden behind a hamburger menu in the header area now. This isn't ideal, I agree.
Comment 2 Sefa Eyeoglu 2021-03-18 12:07:56 UTC
Android has a good way of handling this.

Show first element of overflow menu, collapse rest into menu.
If there is no space to show first element, collapse that one too.
Comment 3 Nate Graham 2021-04-13 14:25:33 UTC
*** Bug 435659 has been marked as a duplicate of this bug. ***
Comment 4 Bug Janitor Service 2021-05-04 04:28:31 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/837
Comment 5 Nate Graham 2021-05-04 18:42:06 UTC
Git commit 5893574163840cf02a7be29dc7fc11837cfa7724 by Nate Graham.
Committed on 04/05/2021 at 18:41.
Pushed by ngraham into branch 'master'.

[applets/notifications] Move "Clear History" action out of burger menu

The fact that the commonly-used "Clear History" action appears in a
hamburger menu has been a common user complaint about Plasma 5.21.

This happens because it's defined as an action, and the applet has two
actions ("clear history" and "open KCM") and when there is more than
one action, they all go into a hamburger menu. This makes the
commonly-used clear action more difficult to find that necessary.

A reasonable long-term solution would be to refactor the action
visibility code in plasma-framework to allow the display of more than
one action in the header without always putting them all in a hamburger
menu, or allowing the developer more control over this. However since
that would require frameworks changes, it can't be done in Plasma 5.22
because 5.22 requires Frameworks 5.82 which has already been tagged. So
let's do this simpler fix for now to fix the UX regression.
FIXED-IN: 5.22

M  +10   -7    applets/notifications/package/contents/ui/FullRepresentation.qml
M  +0    -12   applets/notifications/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/5893574163840cf02a7be29dc7fc11837cfa7724
Comment 6 Nate Graham 2021-05-05 21:50:29 UTC
Git commit 4172720357684b952ded4b8420374e301589ad1f by Nate Graham.
Committed on 05/05/2021 at 21:46.
Pushed by ngraham into branch 'master'.

[applets/notifications] Make configure button open the KCM

The notification applet's config window is blank, and only shows the
auto-generated Shortcuts and About pages. This makes it not very useful,
as typically the user will want to get to the KCM instead. Other
applets with blank config windows (such as the Bluetooth and Networks
applets) make the configure button open the KCM instead and nobody has
complained about it, so let's do the same for the Notifications applet.
This has two advantages:

1. Greater consistency among applets
2. The "Clear all" action always appears visibly in the header without
   getting pushed into a hamburger menu
3. A cleaner UI than the one merged in
   https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/837
FIXED-IN: 5.22

M  +6    -3    applets/notifications/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/4172720357684b952ded4b8420374e301589ad1f