Bug 433104 - Applying a boot splash screen theme doesn't work
Summary: Applying a boot splash screen theme doesn't work
Status: RESOLVED DUPLICATE of bug 400641
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_plymouth (show other bugs)
Version: 5.21.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-17 18:40 UTC by Lua
Modified: 2022-03-22 15:11 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
boot splash screen settings (19.90 KB, image/png)
2021-02-17 18:40 UTC, Lua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lua 2021-02-17 18:40:15 UTC
Created attachment 135782 [details]
boot splash screen settings

SUMMARY


STEPS TO REPRODUCE
1. Go to System Settings > Startup and shutdown > Boot Splash Screen
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.21
KDE Plasma Version: 5.21.0
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Also, the progress bar keeps running for a really long time. I ran systemsettings5 in terminal, but I think that there's no related message for this problem:

file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:157:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/SubCategoryPage.qml:147:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/introPage.qml:109:27: QML IntroIcon (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "minimumHeight"
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/introPage.qml:109:27: QML IntroIcon (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "minimumHeight"
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/introPage.qml:109:27: QML IntroIcon (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "minimumHeight"
kf.coreaddons: Two plugins with the same interface( QObject ) were registered. Use keywords to identify the plugins.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
kf.i18n: "0 instead of 3 arguments to message {%1, by %2 (%3)} supplied before conversion."
kf.i18n: "0 instead of 2 arguments to message {%1 (%2)} supplied before conversion."
QCoreApplication::postEvent: Unexpected null receiver
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/private/ErrorDisplayer.qml:14:35: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/QuestionAsker.qml:91:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/QuestionAsker.qml:91:5: QML Connections: Cannot assign to non-existent property "onClosing"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/QuestionAsker.qml:50:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:94: TypeError: Cannot read property 'position' of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:93: TypeError: Cannot read property 'background' of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/Page.qml:130: TypeError: Cannot read property 'useLabel' of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:94: TypeError: Cannot read property 'position' of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/AbstractApplicationItem.qml:93: TypeError: Cannot read property 'background' of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/newstuff/qml/Page.qml:130: TypeError: Cannot read property 'useLabel' of null
file:///usr/share/kpackage/kcms/kcm_sddm/contents/ui/main.qml:34:13: QML InlineMessage: Cannot anchor to an item that isn't a parent or sibling.
kf.i18n: "0 instead of 2 arguments to message {%1 (%2)} supplied before conversion."
kf.i18n: "0 instead of 3 arguments to message {%1, by %2 (%3)} supplied before conversion."
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/templates/InlineMessage.qml:221:9: QML MouseArea: Binding loop detected for property "height"
file:///usr/share/kpackage/kcms/kcm_smserver/contents/ui/main.qml:165:13: Unable to assign [undefined] to bool
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/share/kpackage/kcms/kcm_plymouth/contents/ui/main.qml:86:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/share/kpackage/kcms/kcm5_kded/contents/ui/main.qml:49:13: QML ColumnLayout: Cannot anchor to an item that isn't a parent or sibling.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
file:///usr/share/kpackage/kcms/kcm_plymouth/contents/ui/main.qml:86:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
file:///usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/kirigami.2/private/globaltoolbar/PageRowGlobalToolBarUI.qml:65:9: QML RowLayout (parent or ancestor of QQuickLayoutAttached): Binding loop detected for property "maximumWidth"
Debug message from helper: Running update-initramfs -u  now
Comment 1 Lua 2021-02-19 17:26:06 UTC
Whoops, I forgot to add the other steps ><

STEPS TO REPRODUCE
1. Go to System Settings > Startup and shutdown > Boot Splash Screen
2. Select any theme
3. Apply it and reboot. Nothing will happen and the progress bar shows for a long time too, don't know if this is normal.
Comment 2 Nate Graham 2021-02-19 19:24:38 UTC
Thanks.
Comment 3 strangequark 2021-09-15 06:43:55 UTC
I've noticed something like this too - when I've applied any other boot splash theme that was there by default other than Breeze (except Details, that one just doesn't work at all for me (https://bugs.kde.org/show_bug.cgi?id=442462) ), about half of them just don't work and just display the exact same boot splash as the default Breeze.
Comment 4 MK 2021-10-18 09:42:22 UTC
(In reply to strangequark from comment #3)
> I've noticed something like this too - when I've applied any other boot
> splash theme that was there by default other than Breeze (except Details,
> that one just doesn't work at all for me
> (https://bugs.kde.org/show_bug.cgi?id=442462) ), about half of them just
> don't work and just display the exact same boot splash as the default Breeze.

I completely lost the plymouth animation since at least two versions and couldn't manage to have it back no matter what (I reinstalled all the plymouth pakages, reinstalled the kernel, looked into the settings of both etc...). 

At first I thought it was my fault (I recently removed a bunch of old kernels manually) but after doing some research I realised that shouldn't break plymouth in any way, so this must be some kind of bug?
Comment 5 MK 2021-10-18 09:42:47 UTC
(In reply to MK from comment #4)
> (In reply to strangequark from comment #3)
> > I've noticed something like this too - when I've applied any other boot
> > splash theme that was there by default other than Breeze (except Details,
> > that one just doesn't work at all for me
> > (https://bugs.kde.org/show_bug.cgi?id=442462) ), about half of them just
> > don't work and just display the exact same boot splash as the default Breeze.
> 
> I completely lost the plymouth animation since at least two versions and
> couldn't manage to have it back no matter what (I reinstalled all the
> plymouth pakages, reinstalled the kernel, looked into the settings of both
> etc...). 
> 
> At first I thought it was my fault (I recently removed a bunch of old
> kernels manually) but after doing some research I realised that shouldn't
> break plymouth in any way, so this must be some kind of bug?

Oh I forgot to mention I'm on 5.23 now
Comment 6 Nate Graham 2022-03-22 15:11:26 UTC
Looks like this will be fixed with the fix for Bug 400641.

*** This bug has been marked as a duplicate of bug 400641 ***