Bug 432703 - Make CPU label use empty space more efficient
Summary: Make CPU label use empty space more efficient
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Other Other
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 434727 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-09 20:21 UTC by Andy Great
Modified: 2021-04-21 14:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments
screenshot showing CPU label 8 x 1 stacking (19.36 KB, image/png)
2021-02-09 20:21 UTC, Andy Great
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Great 2021-02-09 20:21:47 UTC
Created attachment 135539 [details]
screenshot showing CPU label 8 x 1 stacking

I install system-monitor 5.20.90 on openSUSE Tumbleweed KDE.

The CPU percentage label at the bottom does not arrange it self that maximize CPU graph space.
For example, as shown in the attached image, when the windows size is too narrow, the label becomes 8 x 1 stacking and when it have enough space it become 1 x 8 stacking. There should be in between to maximize the graph size.

Operating System: openSUSE Tumbleweed 20210203
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.12-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-3770 CPU @ 3.40GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000
Comment 1 Nate Graham 2021-02-09 21:26:59 UTC
I believe the layout changes to be horizontal when there's enough room to show all of them in one row. In essence it changes in a column layout  to a row layout. Perhaps what would be better is a flow layout, so it always uses as much vertical and also horizontal space as is available.
Comment 2 Arjen Hiemstra 2021-02-09 22:25:05 UTC
That is in fact what I have been working on. Unfortunately it didn't make it for Plasma 5.21 but 5.22 should feature a redesigned legend that can do more than one column.
Comment 3 Nate Graham 2021-03-22 03:35:11 UTC
*** Bug 434727 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-04-21 14:36:43 UTC
Fixed in Plasma 5.22 with the new legend! Much better now.