Bug 432575 - Browsing folder mounted in NTFS partition
Summary: Browsing folder mounted in NTFS partition
Status: RESOLVED DUPLICATE of bug 422282
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 20.12.1
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-02-06 15:32 UTC by Surej Prabhu
Modified: 2021-02-06 21:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Surej Prabhu 2021-02-06 15:32:36 UTC
Application: dolphin (20.12.1)

Qt Version: 5.15.2
Frameworks Version: 5.78.0
Operating System: Linux 5.4.0-58-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.20

-- Information about the crash:
- What I was doing when the application crashed:

I was browing folder from a mounted NTFS parition when Dolphin crashed

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted

[New LWP 6000]
[New LWP 6001]
[New LWP 6006]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f603b319aff in __GI___poll (fds=0x7ffe2570d7e8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7f60343bb8c0 (LWP 5998))]

Thread 4 (Thread 0x7f6017fff700 (LWP 6006)):
#0  0x00007f603b319aff in __GI___poll (fds=0x7f600c005240, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f6036dbf18e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6036dbf2c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6039051fbb in QEventDispatcherGlib::processEvents (this=0x7f600c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f6038ff61ab in QEventLoop::exec (this=this@entry=0x7f6017ffece0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f6038e10a12 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f6038e11bac in QThreadPrivate::start (arg=0x556e86051a20) at thread/qthread_unix.cpp:329
#7  0x00007f603778e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f603b326293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f6032a28700 (LWP 6001)):
#0  0x00007f6036e0c24d in g_mutex_lock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6036dbf174 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6036dbf2c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6039051fbb in QEventDispatcherGlib::processEvents (this=0x7f6024000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f6038ff61ab in QEventLoop::exec (this=this@entry=0x7f6032a27cb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f6038e10a12 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f603a0a7f4b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f6038e11bac in QThreadPrivate::start (arg=0x7f603a12bd80) at thread/qthread_unix.cpp:329
#8  0x00007f603778e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f603b326293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f60337f7700 (LWP 6000)):
#0  0x00007f603b319aff in __GI___poll (fds=0x7f60337f6be8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f60377c4c1a in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f60377c690a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6033d23d58 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f6038e11bac in QThreadPrivate::start (arg=0x556e85a53000) at thread/qthread_unix.cpp:329
#5  0x00007f603778e609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f603b326293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f60343bb8c0 (LWP 5998)):
[KCrash Handler]
#4  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#5  0x00007f603b229859 in __GI_abort () at abort.c:79
#6  0x00007f603b2943ee in __libc_message (action=action@entry=do_abort, fmt=fmt@entry=0x7f603b3be285 "%s\n") at ../sysdeps/posix/libc_fatal.c:155
#7  0x00007f603b29c47c in malloc_printerr (str=str@entry=0x7f603b3c01e0 "munmap_chunk(): invalid pointer") at malloc.c:5347
#8  0x00007f603b29c6cc in munmap_chunk (p=<optimized out>) at malloc.c:2830
#9  0x00007f6038e4cfc7 in QHashData::free_helper (this=0x556e864ecf60, node_delete=0x7f603b132970 <QHash<QByteArray, QVariant>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:573
#10 0x00007f603b137345 in QHash<QByteArray, QVariant>::freeData (this=0x556e8651cfe8, x=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qhash.h:617
#11 QHash<QByteArray, QVariant>::~QHash (this=0x556e8651cfe8, __in_chrg=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qhash.h:250
#12 KFileItemModel::ItemData::~ItemData (this=0x556e8651cfe0, __in_chrg=<optimized out>) at ./src/kitemviews/kfileitemmodel.h:285
#13 KFileItemModel::removeItems (behavior=KFileItemModel::DeleteItemData, itemRanges=..., this=0x556e85bd1460) at ./src/kitemviews/kfileitemmodel.cpp:1288
#14 KFileItemModel::removeItems (this=0x556e85bd1460, itemRanges=..., behavior=KFileItemModel::DeleteItemData) at ./src/kitemviews/kfileitemmodel.cpp:1273
#15 0x00007f603b143d54 in KFileItemModel::setExpanded (this=0x556e85bd1460, index=0, expanded=<optimized out>) at ./src/kitemviews/kitemrange.h:48
#16 0x00007f603b158d61 in KItemListController::onRelease (this=this@entry=0x556e85fd43c0, pos=..., modifiers=modifiers@entry=..., buttons=buttons@entry=..., touch=touch@entry=false) at ./src/kitemviews/kitemlistcontroller.cpp:1581
#17 0x00007f603b158f09 in KItemListController::mouseReleaseEvent (transform=..., event=0x7ffe2570eed0, this=0x556e85fd43c0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qflags.h:121
#18 KItemListController::mouseReleaseEvent (this=0x556e85fd43c0, event=0x7ffe2570eed0, transform=...) at ./src/kitemviews/kitemlistcontroller.cpp:627
#19 0x00007f603b15ab69 in KItemListController::processEvent (this=this@entry=0x556e85fd43c0, event=event@entry=0x7ffe2570eed0, transform=...) at ./src/kitemviews/kitemlistcontroller.cpp:1112
#20 0x00007f603b16a0b6 in KItemListView::event (this=0x556e86028d70, event=0x7ffe2570eed0) at ./src/kitemviews/kitemlistview.cpp:933
#21 0x00007f6039acedc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x556e86028d70, e=0x7ffe2570eed0) at kernel/qapplication.cpp:3632
#22 0x00007f6039ad7bb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#23 0x00007f6038ff769a in QCoreApplication::notifyInternal2 (receiver=0x556e86028d70, event=0x7ffe2570eed0) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#24 0x00007f6039e03f73 in QGraphicsScenePrivate::sendEvent (this=<optimized out>, event=0x7ffe2570eed0, item=0x556e86028d80) at graphicsview/qgraphicsscene.cpp:1254
#25 QGraphicsScenePrivate::sendEvent (this=<optimized out>, item=0x556e86028d80, event=0x7ffe2570eed0) at graphicsview/qgraphicsscene.cpp:1234
#26 0x00007f6039e043b7 in QGraphicsScenePrivate::sendMouseEvent (this=this@entry=0x556e860577b0, mouseEvent=mouseEvent@entry=0x7ffe2570eed0) at graphicsview/qgraphicsscene.cpp:1335
#27 0x00007f6039e09500 in QGraphicsScene::mouseReleaseEvent (this=<optimized out>, mouseEvent=0x7ffe2570eed0) at graphicsview/qgraphicsscene.cpp:4123
#28 0x00007f6039e166e9 in QGraphicsScene::event (this=0x556e86050710, event=0x7ffe2570eed0) at graphicsview/qgraphicsscene.cpp:3436
#29 0x00007f6039acedc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x556e86050710, e=0x7ffe2570eed0) at kernel/qapplication.cpp:3632
#30 0x00007f6039ad7bb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#31 0x00007f6038ff769a in QCoreApplication::notifyInternal2 (receiver=0x556e86050710, event=0x7ffe2570eed0) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#32 0x00007f6039e33c5a in QGraphicsView::mouseReleaseEvent (this=0x556e8604ffa0, event=0x7ffe2570f4e0) at /usr/include/c++/9/bits/atomic_base.h:413
#33 0x00007f6039b11c06 in QWidget::event (this=this@entry=0x556e8604ffa0, event=event@entry=0x7ffe2570f4e0) at kernel/qwidget.cpp:8663
#34 0x00007f6039bc1f82 in QFrame::event (this=0x556e8604ffa0, e=0x7ffe2570f4e0) at widgets/qframe.cpp:550
#35 0x00007f6039e34aa1 in QGraphicsView::viewportEvent (this=0x556e8604ffa0, event=0x7ffe2570f4e0) at graphicsview/qgraphicsview.cpp:3014
#36 0x00007f6038ff7403 in QCoreApplicationPrivate::sendThroughObjectEventFilters (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.cpp:1189
#37 QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=receiver@entry=0x556e86053720, event=event@entry=0x7ffe2570f4e0) at kernel/qcoreapplication.cpp:1178
#38 0x00007f6039acedb2 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x556e86053720, e=0x7ffe2570f4e0) at kernel/qapplication.cpp:3626
#39 0x00007f6039ad7e77 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3076
#40 0x00007f6038ff769a in QCoreApplication::notifyInternal2 (receiver=0x556e86053720, event=0x7ffe2570f4e0) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#41 0x00007f6039ad70a7 in QApplicationPrivate::sendMouseEvent (receiver=0x556e86053720, event=0x7ffe2570f4e0, alienWidget=0x556e86053720, nativeWidget=0x556e85aee330, buttonDown=<optimized out>, lastMouseReceiver=..., spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2614
#42 0x00007f6039b2ce54 in QWidgetWindow::handleMouseEvent(QMouseEvent*) () at /usr/include/c++/9/bits/atomic_base.h:413
#43 0x00007f6039b30174 in QWidgetWindow::event (this=0x556e85eca000, event=0x7ffe2570f960) at kernel/qwidgetwindow.cpp:300
#44 0x00007f6039acedc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x556e85eca000, e=0x7ffe2570f960) at kernel/qapplication.cpp:3632
#45 0x00007f6039ad7bb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#46 0x00007f6038ff769a in QCoreApplication::notifyInternal2 (receiver=0x556e85eca000, event=0x7ffe2570f960) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#47 0x00007f60393d94e8 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#48 0x00007f60393dab55 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#49 0x00007f60393b27ac in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#50 0x00007f6033d24d7e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#51 0x00007f6036dbef9d in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#52 0x00007f6036dbf220 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#53 0x00007f6036dbf2c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007f6039051fa2 in QEventDispatcherGlib::processEvents (this=0x556e85b07110, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#55 0x00007f6038ff61ab in QEventLoop::exec (this=this@entry=0x7ffe2570fd00, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#56 0x00007f6038ffe354 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#57 0x00007f603b449f82 in kdemain (argc=<optimized out>, argv=<optimized out>) at ./src/main.cpp:222
#58 0x00007f603b22b0b3 in __libc_start_main (main=0x556e84749060 <main>, argc=1, argv=0x7ffe2570ffd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe2570ffc8) at ../csu/libc-start.c:308
#59 0x0000556e8474909e in _start ()
[Inferior 1 (process 5998) detached]

Possible duplicates by query: bug 432483, bug 431804, bug 431519, bug 431303, bug 430998.

Reported using DrKonqi
Comment 1 Nate Graham 2021-02-06 21:40:23 UTC

*** This bug has been marked as a duplicate of bug 422282 ***