Bug 432380 - Appimage unable to print reports
Summary: Appimage unable to print reports
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: reports (show other bugs)
Version: 5.1.1
Platform: Mint (Debian based) Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 423721 432071 439731 441012 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-02-01 13:54 UTC by Mark Medoff
Modified: 2022-03-13 14:45 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.3


Attachments
attachment-11723-0.html (1.55 KB, text/html)
2021-02-01 14:13 UTC, Mark Medoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Medoff 2021-02-01 13:54:00 UTC
SUMMARY
Unable to print reports using appimage

STEPS TO REPRODUCE
1. Select print for report
2. 
3. 

OBSERVED RESULT
Blank page sent to printer

EXPECTED RESULT
Report data should be sent to printer

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: KDE Frameworks 5.51.0
Qt Version: Qt 5.11.3 (built against 5.11.3)

ADDITIONAL INFORMATION
Print works properly when I load a non-appimage installed version of program
Comment 1 jesse 2021-02-01 14:07:47 UTC
I think this is related to the bug I submitted a few days back. 

Bug 432071 

I was trying to print the Reconciliation reports. Is that what you were trying to do as well? Or were you trying to print just a regular report?
Comment 2 Mark Medoff 2021-02-01 14:13:00 UTC
Created attachment 135352 [details]
attachment-11723-0.html

Trying to print any regular report and got blank pages for any of them.
Going to an older installed Debian version, had no issues printing same
reports.

On Mon, Feb 1, 2021, 9:07 AM jesse <bugzilla_noreply@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=432380
>
> jesse <jvapr27@yahoo.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |jvapr27@yahoo.com
>
> --- Comment #1 from jesse <jvapr27@yahoo.com> ---
> I think this is related to the bug I submitted a few days back.
>
> Bug 432071
>
> I was trying to print the Reconciliation reports. Is that what you were
> trying
> to do as well? Or were you trying to print just a regular report?
>
> --
> You are receiving this mail because:
> You reported the bug.
Comment 3 Thomas Baumgart 2021-02-01 15:28:05 UTC
*** Bug 432071 has been marked as a duplicate of this bug. ***
Comment 4 Dawid Wróbel 2021-06-30 06:38:17 UTC
*** Bug 423721 has been marked as a duplicate of this bug. ***
Comment 5 Dawid Wróbel 2021-07-10 20:12:04 UTC
*** Bug 439731 has been marked as a duplicate of this bug. ***
Comment 6 Dawid Wróbel 2021-08-15 19:42:59 UTC
*** Bug 441012 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Baumgart 2022-03-13 06:33:20 UTC
Can you please check using the latest stable AppImage available on https://binary-factory.kde.org/job/KMyMoney_Release_appimage-centos7/ ? I was unable to reproduce the problem with it but like to have your confirmation.
Comment 8 Thomas Baumgart 2022-03-13 14:45:55 UTC
Mark reported that the printing problem was resolved recently. So I close that here.