Bug 432291 - Hide mouse cursor after some timout on the lock and login screens
Summary: Hide mouse cursor after some timout on the lock and login screens
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Theme - Breeze (show other bugs)
Version: master
Platform: Other Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: visual-design
URL:
Keywords:
: 439761 441650 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-29 22:18 UTC by Christoph Cullmann
Modified: 2024-05-04 15:06 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Cullmann 2021-01-29 22:18:01 UTC
SUMMARY

Hide mouse cursor after some timout on the lock screen :=)

This is a pure wish, but I am always sad I need to move the cursor manually to some place not visible to not have it pollute the lock screen (until screens turn off for power saving)

STEPS TO REPRODUCE

1. Lock your screen

OBSERVED RESULT

Mouse cursor stays visible.

EXPECTED RESULT

Mouse cursor will get invisible after some timeout, that way, you can just stare on your nice lock screen background without any ugly cursor somewhere ;)

Should be shown again on movement.
Comment 1 Nate Graham 2021-02-01 17:11:55 UTC
Would be nice, yes. :)
Comment 2 Nate Graham 2021-08-03 04:15:09 UTC
*** Bug 439761 has been marked as a duplicate of this bug. ***
Comment 3 Emre 2023-10-22 08:09:17 UTC
+1 for this. I'm on an OLED panel and I want everything to dissapear from the screen after some time. Current KDE lockscreen elements dissapear (I have pure black background), but only the mouse remains. Appreciate if it can also disssapear together with rest of the elements and come back when a key is pressed or mouse is moved.
Comment 4 fanzhuyifan 2024-01-31 08:06:15 UTC
*** Bug 441650 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Cullmann 2024-05-01 19:15:08 UTC
:) Still would like to have that. But if nobody has time for it in the close future, feel free to close it.
Comment 6 Samuel Gilbert 2024-05-03 18:54:17 UTC
It looks like it's fixed in kscreenlocker 6.0.4 (I'm testing with Arch Linux with Wayland).
Comment 7 Nate Graham 2024-05-03 23:47:05 UTC
That's good news. Are you seeing the same thing, Christoph?
Comment 8 Christoph Cullmann 2024-05-04 14:55:50 UTC
LOL, it does and I just didn't notice it. Thanks a lot that this is fixed!