Bug 432179 - Can't set per-monitor scaling
Summary: Can't set per-monitor scaling
Status: RESOLVED DUPLICATE of bug 414866
Alias: None
Product: KScreen
Classification: Unclassified
Component: common (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR major
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-26 22:35 UTC by titan-shade
Modified: 2021-01-27 13:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description titan-shade 2021-01-26 22:35:51 UTC
SUMMARY
Unable to set different display scaling for second monitor resulting in second monitor being basically not usable. 

STEPS TO REPRODUCE
1. Have first monitor with HiDPI such as a 4k monitor, and a second monitor around 1080 resolution. 
2. Open system settings, navigate to Display and Monitor -> Display Configuration -> Global scale. 
3. Note that this setting applies to all monitors and does not allow you to set per monitor scaling (i.e. if you want to set 4k monitor at 200% scaling to make it usable and the second 1080 monitor at 100% scaling to make it usable). 

OBSERVED RESULT
Either one display is too zoomed in to be functional, or one display is too small to read anything and therefore is not useful. 

EXPECTED RESULT
Different scaling can be set for each monitor as you can do in MacOS or Windows. 

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Kernel Version: 5.8.0-40-generic
OS Type: 64-bit

ADDITIONAL INFORMATION
None.
Comment 1 2wxsy58236r3 2021-01-27 13:04:20 UTC

*** This bug has been marked as a duplicate of bug 414866 ***