Bug 432014 - Unable to remove widgets from Panel
Summary: Unable to remove widgets from Panel
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.20.90
Platform: Archlinux Linux
: VHI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-01-23 23:18 UTC by magiblot
Modified: 2021-02-06 17:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21


Attachments
Screen recording of the issue (2.12 MB, video/x-matroska)
2021-01-23 23:18 UTC, magiblot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description magiblot 2021-01-23 23:18:51 UTC
Created attachment 135119 [details]
Screen recording of the issue

SUMMARY

When editing the Panel, selecting "Remove" in a Widget does nothing.

STEPS TO REPRODUCE / OBSERVED RESULT

See the attached video.

EXPECTED RESULT

I should be able to remove a widget from the Panel by clicking on the "Remove" button.

SOFTWARE/OS VERSIONS

Operating System: Arch Linux
KDE Plasma Version: 5.20.90
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.9-arch1-1
OS Type: 64-bit

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-01-26 16:20:48 UTC
Can reproduce. Console spew says:

file:///home/nate/kde/usr/share/plasma/plasmoids/org.kde.panel/contents/ui/ConfigOverlay.qml:400: TypeError: Cannot read property 'applet' of null
Comment 2 Nate Graham 2021-01-26 16:31:33 UTC
...And now, while debugging it, I can't reproduce the issue anymore. :(

I was definitely experiencing it earlier though.
Comment 3 magiblot 2021-01-26 17:38:28 UTC
(In reply to Nate Graham from comment #2)
> ...And now, while debugging it, I can't reproduce the issue anymore. :(
> 
> I was definitely experiencing it earlier though.

Oh, I'm sorry. I know that feeling.

If it may help, here is what happens if we check for currentApplet not being falsy. You can see the Remove button of the Task Manager has no issues, but it does in the other widgets. Only the Remove button has such issues.

https://drive.google.com/file/d/1AsMoFQ6n46C9ZJ3-HhLeFU9dzZMGSqf5/view?usp=sharing
Comment 4 magiblot 2021-01-26 18:20:41 UTC
The button works if you move the cursor over a context menu:

https://drive.google.com/file/d/1cWO-EDeXR87LviCFu9mJxK_zegjVr88A/view?usp=sharing

Note that this capture also has the changes in ConfigOverlay.qml I showed in the previous video.
Comment 5 veggero 2021-01-28 10:09:29 UTC
Ok, found the problem.
Problem A: the timeout for the widget actions dialog is way too long, which means that it stays open even though there's actually no widget selected anymore.
Problem B: my patch that broke fitts law also un-selected the current widget when the mouse was near the top edge of the panel, moving towards the dialog.
Hopefully the fitts law one is fixed, whilst I will make a patch now to make the dialog timeout saner.
Comment 6 Bug Janitor Service 2021-01-28 10:12:56 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/329
Comment 7 Nate Graham 2021-02-06 17:18:29 UTC
Fixed by Niccolò Venerandi with https://invent.kde.org/plasma/plasma-desktop/-/commit/c540181a80a8a23659fdb43ed75f8d391cda47d3 in Plasma 5.21!