Bug 431932 - Context menu closes immediately if a tooltip was shown before
Summary: Context menu closes immediately if a tooltip was shown before
Status: RESOLVED DUPLICATE of bug 417939
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.21.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-01-22 13:07 UTC by Matej Mrenica
Modified: 2021-03-04 20:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Mrenica 2021-01-22 13:07:39 UTC
STEPS TO REPRODUCE
1. Hover over something in system tray to show a tooltip (clock, sound, networks, ...)
2. While the tooltip is still visible right click to open a context menu

OBSERVED RESULT
All in a fraction of a second:
 Context menu is shown, tooltip disappears and context menu disappears.
Second right click does nothing.
Third right click does nothing.
Forth click finally shows the context menu and everything works fine from now on.

SOFTWARE/OS VERSIONS
KDE Frameworks Version: 5.78
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Tested on Wayland, every item in the panel is affected (app launcher, pinned apps, task manager, ...)
Comment 1 Thiago Sueto 2021-02-20 21:11:08 UTC

*** This bug has been marked as a duplicate of bug 416869 ***
Comment 2 Nate Graham 2021-03-04 20:25:32 UTC

*** This bug has been marked as a duplicate of bug 417939 ***