Bug 431924 - Compositor crashes frequently
Summary: Compositor crashes frequently
Status: REOPENED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-22 09:40 UTC by Jazz
Modified: 2021-02-15 14:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Compositor crash log (11.28 KB, text/x-log)
2021-01-22 09:40 UTC, Jazz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jazz 2021-01-22 09:40:23 UTC
Created attachment 135058 [details]
Compositor crash log

SUMMARY
After the most recent update of Manjaro, my compositor crashed way more frequently than it used to. Just yesterday it crashed twice:
https://pastebin.com/gtc3pbMC

STEPS TO REPRODUCE
I can't reproduce the steps, but I had my Krusader open and starting some media slideshow and when it opened a mp4 file in my qimgv (qt), I closed the app by using my Active Window Control (Plasma) widget from the panel.

OBSERVED RESULT
Compositor has crashed and I needed to re-enable Compositor and restart my system.

EXPECTED RESULT
Compositor should now crash.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.4.89-1-MANJARO
(available in About System)
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Vlad Zahorodnii 2021-01-22 10:04:54 UTC
Without a backtrace, we can't do that much about this bug report. Could you please post a backtrace when kwin crashes the next time? Also, please make sure that kwin is compiled with debug symbols.
Comment 2 Jazz 2021-01-22 18:31:28 UTC
Ok, I'll try to backtrace next time it happens. Meanwhile I did my research a bit and it could be related to this bug, so I applied the following changes in my /etc/X11/mhwd.d/nvidia.conf (except the GLPlatformInterface setting which is obsolete now) and so far compositor doesn't seem to crash again:

https://archived.forum.manjaro.org/t/kde-compositor-keeps-breaking/27874/5
Comment 3 Jazz 2021-01-23 20:10:46 UTC
I could confirm the changes in my comment above were not very helpful, since my Compositor just crashed again, a few minutes ago. Here's the output of coredumpctl gdb:

https://pastebin.com/raw/4LMWhHxB
Comment 4 Jazz 2021-01-25 15:00:57 UTC
It keeps crashing every day now. Vlad, can I provide you with some more detailed input to debug this properly? Please let me know how could I help you more.
Comment 5 Vlad Zahorodnii 2021-01-25 15:08:22 UTC
It's most likely an nvidia driver bug. You could try downgrading the nvidia driver. But without a backtrace, it's a wild guess. Note that another way to get the backtrace of the crash is to use drkonqi. When kwin crashes, you should see a sad face in the system tray. Click that icon and you should see the backtrace in the developer information tab.
Comment 6 Jazz 2021-01-25 15:12:15 UTC
Yes, it feels like an nvidia thing. It worked just fine before the last nvidia driver update. Since I'm on a rolling distro, I don't feel comfortable downgrading the driver. Thanks for the drkonqi tip. :)
Comment 7 Bug Janitor Service 2021-02-09 04:33:14 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Jazz 2021-02-10 16:14:23 UTC
With the most recent KDE 5.20.5 and since Nvidia driver got updated to 460.39, I can't reproduce this issue again. I assume it was due to the previous version of the nvidia driver.
Comment 9 Vlad Zahorodnii 2021-02-11 14:07:52 UTC
Thanks for the update.
Comment 10 Jazz 2021-02-14 13:51:53 UTC
Unfortunately it just crashed again: https://invent.kde.org/-/snippets/1509

Theoretically, could it possible because I didn't check the "Allow applications to block compositing" in System Settings > Compositor?

I just installed DrKonqi and will keep my eye on this.
Comment 11 Jazz 2021-02-14 20:24:45 UTC
Here's one backtrace created by DrKonqi:
https://invent.kde.org/-/snippets/1511

It just crashed multiple times within the last 2h. Once when I logged in to Manjaro, second time when I was typing a message in telegram-desktop and the third time when I was just trying to close my Chromium window.
Comment 12 Jazz 2021-02-15 14:58:11 UTC
It happened again: https://invent.kde.org/-/snippets/1516