Bug 431613 - When calling Rectangular Region screenshot via a global shortcut, the mouse pointer will freeze and may appear in screenshot unintentionally
Summary: When calling Rectangular Region screenshot via a global shortcut, the mouse p...
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 20.12.0
Platform: Manjaro Linux
: NOR minor
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-14 22:18 UTC by Jens Lallensack
Modified: 2021-12-01 17:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Lallensack 2021-01-14 22:18:00 UTC
SUMMARY


STEPS TO REPRODUCE
1. Open the settings of Spectacle and define a global shortcut for "Capture Rectangular Region". In my case, the shortcut is Meta+R
2. Turn off the option "Include mouse pointer"
3. Quit Spectacle. You may see the desktop or another window.
4. Make sure the mouse pointer is visible on the screen, and hit the shortcut (in my case Meta+R). Now the mouse pointer immediately freezes at its current position, and a new (second) "grabby hand" mouse pointer appears to adjust the rectangular region for the screenshot.
5. Make sure the rectangular region includes the frozen mouse pointer. Hit "Enter" to do the screenshot.

OBSERVED RESULT
The frozen mouse pointer appears in the screenshot, although the "include mouse pointer" option is still unchecked.


EXPECTED RESULT
Once the "grabby hand" mouse pointer of Spectacle appears, the original mouse pointer should disappear rather than freeze in place. No mouse pointer should be visible in the screenshot.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION

However, when I repeat above steps with the "Include mouse pointer" option checked, the mouse pointer still freezes, and I only see the frozen one but not the actual active mouse pointer. The option "Include mouse pointer" has no effect in this situation.
Comment 1 Justin Zobel 2021-01-15 06:50:03 UTC
Confirmed on 20.12.0. The cursor is not disappearing, it is frozen at the point you hit the shortcut key.
Comment 2 Nate Graham 2021-12-01 17:30:29 UTC

*** This bug has been marked as a duplicate of bug 392057 ***