Bug 431573 - "Offer shutdown options" setting is confusing and unused nowadays
Summary: "Offer shutdown options" setting is confusing and unused nowadays
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_smserver (show other bugs)
Version: 5.23.90
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-01-13 23:43 UTC by Patrick Silva
Modified: 2022-12-13 23:28 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-01-13 23:43:37 UTC
STEPS TO REPRODUCE
1. open system settings > startup and shutdown > desktop session
2. uncheck "Offer shutdown options" and apply the change
3. trigger the logout screen by pressing ctrl+alt+del

OBSERVED RESULT
logout screen offers shutdown options

EXPECTED RESULT
logout screen should not offer shutdown options

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Comment 1 Justin Zobel 2021-01-14 03:02:06 UTC
I'm unable to replicate this with 5.20.80. Are you definitely applying the change?
Comment 2 Patrick Silva 2021-01-14 03:16:44 UTC
Yes. Even reboot does not help.
Comment 3 Nate Graham 2021-01-14 22:47:15 UTC
I believe you have to uncheck "Confirm shutdown" to make the logout screen disappear.

Yes, this is not the best UI. The concept of "shutdown options" has mostly disappeared in recent years as we have removed the idea of a "default leave option." I think the best thing to do is to rip out what's left of it and remove these options from the KCM.
Comment 4 David Edmundson 2021-01-14 23:32:59 UTC
>I think the best thing to do is to rip out what's left of it and remove these options from the KCM.

AFAIK what's left is now just the context menu on the desktop
Comment 5 Justin Zobel 2021-01-14 23:41:18 UTC
Which is honestly a weird thing to have in the desktop context menu if I 
might say.

On 15/1/21 10:02 am, David Edmundson wrote:
> https://bugs.kde.org/show_bug.cgi?id=431573
>
> David Edmundson <kde@davidedmundson.co.uk> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |kde@davidedmundson.co.uk
>
> --- Comment #4 from David Edmundson <kde@davidedmundson.co.uk> ---
>> I think the best thing to do is to rip out what's left of it and remove these options from the KCM.
> AFAIK what's left is now just the context menu on the desktop
>
Comment 6 Nate Graham 2021-01-14 23:50:34 UTC
Yeah, fair point.
Comment 7 Nate Graham 2021-01-14 23:52:26 UTC
Perhaps the idea was to have an emergency UI to shut down or restart if you remove kickoff, remove the desktop toolbox (as we did a few releases ago), and don't know about krunner, but do know how to right-click.
Comment 8 Justin Zobel 2021-01-15 00:01:59 UTC
That seems to me to be a hack fix to a problem where a user can easily 
remove something that is core to operating their machine. Perhaps a 
warning when removing kickoff noting that this is the way to shut down.

On 15/1/21 10:22 am, Nate Graham wrote:
> https://bugs.kde.org/show_bug.cgi?id=431573
>
> --- Comment #7 from Nate Graham <nate@kde.org> ---
> Perhaps the idea was to have an emergency UI to shut down or restart if you
> remove kickoff, remove the desktop toolbox (as we did a few releases ago), and
> don't know about krunner, but do know how to right-click.
>
Comment 9 Nate Graham 2021-01-15 20:59:20 UTC
Yeah, it's the price we pay for flexibility. :) I agree that as escape valves go, it's not the greatest one. And notably, you can customize the desktop context menu to remove the "Leave..." entry too!
Comment 10 Thiago Sueto 2022-03-05 20:33:30 UTC
I can reproduce this issue on Krypton with Plasma from git (5.24.80 build from 02/03/2022).

Even the right click thing on the desktop isn't affected by it. The Leave... option is always there and it always shows shutdown options.

FWIW, assuming my experience isn't a bug but rather the current behavior, this setting could be removed since it does effectively nothing.
Comment 11 Thiago Sueto 2022-03-05 20:38:27 UTC
To be clearer, in "The Leave... option is always there and it always shows shutdown options.", "it" is the ksmserver popup. There are no shutdown options in the context menu. And AFAIK there are no user facing settings elsewhere to hide the shutdown options in ksmserver.
Comment 12 Xavier Brochard 2022-08-13 18:31:51 UTC
In multiseat systems, an option to disable  "shutdown options" is useful... if it works. Otherwise, sysadmin manually check each launchers config and Krunner to disable shutdown.
Comment 13 Justin Zobel 2022-08-14 03:34:09 UTC
I imagine any sysadmin would disallow reboot/shutdown at a lower level 
than Plasma itself.

On 14/8/22 04:01, Xavier Brochard wrote:
> https://bugs.kde.org/show_bug.cgi?id=431573
>
> Xavier Brochard <xavier@alternatif.org> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |xavier@alternatif.org
>
> --- Comment #12 from Xavier Brochard <xavier@alternatif.org> ---
> In multiseat systems, an option to disable  "shutdown options" is useful... if
> it works. Otherwise, sysadmin manually check each launchers config and Krunner
> to disable shutdown.
>
Comment 14 Bug Janitor Service 2022-12-06 22:23:51 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1280
Comment 15 Bug Janitor Service 2022-12-06 22:24:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2413
Comment 16 Nate Graham 2022-12-13 21:43:32 UTC
Git commit a2192107bf847752aa9d945c44f770770ce91448 by Nate Graham.
Committed on 13/12/2022 at 21:12.
Pushed by ngraham into branch 'master'.

kcms/ksmserver: remove "Offer shutdown options" setting

This setting's text implies that it disables the logout screen or
removes all the other options from it, but it does not. In fact it
appears to do nothing. No session-related UI that I or anyone else can
find respects the value set here, making it a setting that seems from
the user's perspective to be completely useless.

Let's remove it.
FIXED-IN: 5.27

M  +0    -9    kcms/ksmserver/package/contents/ui/main.qml
M  +0    -4    kcms/ksmserver/smserversettings.kcfg

https://invent.kde.org/plasma/plasma-desktop/commit/a2192107bf847752aa9d945c44f770770ce91448
Comment 17 Nate Graham 2022-12-13 22:00:20 UTC
Git commit 6d23f2780502ca2f398d98f7dec0713b5e6ed59e by Nate Graham.
Committed on 13/12/2022 at 21:12.
Pushed by ngraham into branch 'master'.

ksmserver: remove last traces of "offerShutdown" setting

Its UI is being removed in
https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1280.

M  +1    -5    ksmserver/logout.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/6d23f2780502ca2f398d98f7dec0713b5e6ed59e