Bug 431472 - System Settings crashes on switch from Screen Locking to Virtual Desktops
Summary: System Settings crashes on switch from Screen Locking to Virtual Desktops
Status: RESOLVED DUPLICATE of bug 431419
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_workspace (show other bugs)
Version: 5.20.5
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-12 03:23 UTC by fa09d8sf94rdaf
Modified: 2021-01-14 00:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fa09d8sf94rdaf 2021-01-12 03:23:09 UTC
SUMMARY
System Settings crashes on switch from Screen Locking to Virtual Desktops

STEPS TO REPRODUCE
1. Go to 'System Settings' -> 'Workspace Behavior' -> 'Screen Locking'
3. Click 'Appearance: Configure' button
4. Select any other image
5. Click 'Apply' button
6. Click 'Vitual Desktops'

OBSERVED RESULT
System Settings crashed

EXPECTED RESULT
System Settings displays Virtual Desktops settings

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Linux 5.10.6-arch1-1 x86_64
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Just installed fresh Arch and KDE and was clicking through all settings starting from the top. Changed the Lock Screen image and moved to Virtual Desktops when it crashed. If I reopen the Settings and go straight to Virtual Desktops it doesn't crash.
Comment 1 David Redondo 2021-01-12 08:40:27 UTC
Please include backtrace when reporting crashed
https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports

But I suspect it may be duplicate of #428461
Comment 2 fa09d8sf94rdaf 2021-01-12 18:30:16 UTC
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f812f38d73a in QV4::QObjectWrapper::getQmlProperty(QV4::ExecutionEngine*, QQmlContextData*, QObject*, QV4::String*, QV4::QObjectWrapper::RevisionMode, bool*, QQmlPropertyData**) () from /usr/lib/libQt5Qml.so.5
#5  0x00007f812f36ca6c in QV4::QQmlContextWrapper::getPropertyAndBase(QV4::QQmlContextWrapper const*, QV4::PropertyKey, QV4::Value const*, bool*, QV4::Value*, QV4::Lookup*) () from /usr/lib/libQt5Qml.so.5
#6  0x00007f812f36d364 in QV4::QQmlContextWrapper::resolveQmlContextPropertyLookupGetter(QV4::Lookup*, QV4::ExecutionEngine*, QV4::Value*) () from /usr/lib/libQt5Qml.so.5
#7  0x00007f812f3aa6fb in ?? () from /usr/lib/libQt5Qml.so.5
#8  0x00007f812f3af68f in ?? () from /usr/lib/libQt5Qml.so.5
#9  0x00007f812f349d2e in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /usr/lib/libQt5Qml.so.5
#10 0x00007f812f4c5916 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /usr/lib/libQt5Qml.so.5
#11 0x00007f812f47862d in QQmlBoundSignalExpression::evaluate(void**) () from /usr/lib/libQt5Qml.so.5
#12 0x00007f812f478b11 in ?? () from /usr/lib/libQt5Qml.so.5
#13 0x00007f812f4a900d in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /usr/lib/libQt5Qml.so.5
#14 0x00007f813046b955 in ?? () from /usr/lib/libQt5Core.so.5
#15 0x00007f812f473f4a in QQmlContextData::emitDestruction() () from /usr/lib/libQt5Qml.so.5
#16 0x00007f812f473f71 in QQmlContextData::emitDestruction() () from /usr/lib/libQt5Qml.so.5
#17 0x00007f812f473f71 in QQmlContextData::emitDestruction() () from /usr/lib/libQt5Qml.so.5
#18 0x00007f812f473f71 in QQmlContextData::emitDestruction() () from /usr/lib/libQt5Qml.so.5
#19 0x00007f812f473f71 in QQmlContextData::emitDestruction() () from /usr/lib/libQt5Qml.so.5
#20 0x00007f812f4741aa in QQmlContextData::invalidate() () from /usr/lib/libQt5Qml.so.5
#21 0x00007f812f473cd8 in QQmlContextData::destroy() () from /usr/lib/libQt5Qml.so.5
#22 0x00007f812f473eae in QQmlContext::~QQmlContext() () from /usr/lib/libQt5Qml.so.5
#23 0x00007f812f473eca in QQmlContext::~QQmlContext() () from /usr/lib/libQt5Qml.so.5
#24 0x00007f813045f10e in QObjectPrivate::deleteChildren() () from /usr/lib/libQt5Core.so.5
#25 0x00007f8130469f75 in QObject::~QObject() () from /usr/lib/libQt5Core.so.5
#26 0x00007f812fbca13a in KDeclarative::QmlObjectSharedEngine::~QmlObjectSharedEngine() () from /usr/lib/libKF5Declarative.so.5
#27 0x00007f813190477c in KQuickAddons::ConfigModule::~ConfigModule() () from /usr/lib/libKF5QuickAddons.so.5
#28 0x00007f81280c9876 in ?? () from /usr/lib/qt/plugins/kcms/kcm_screenlocker.so
#29 0x00007f81319f6273 in ?? () from /usr/lib/libKF5KCMUtils.so.5
#30 0x00007f81319f6299 in ?? () from /usr/lib/libKF5KCMUtils.so.5
#31 0x00007f81319fc7b4 in KCModuleProxy::deleteClient() () from /usr/lib/libKF5KCMUtils.so.5
#32 0x00007f81319fc929 in KCModuleProxy::~KCModuleProxy() () from /usr/lib/libKF5KCMUtils.so.5
#33 0x00007f81319fc9ea in KCModuleProxy::~KCModuleProxy() () from /usr/lib/libKF5KCMUtils.so.5
#34 0x00007f813045f10e in QObjectPrivate::deleteChildren() () from /usr/lib/libQt5Core.so.5
#35 0x00007f813103104e in QWidget::~QWidget() () from /usr/lib/libQt5Widgets.so.5
#36 0x00007f81310313ca in QWidget::~QWidget() () from /usr/lib/libQt5Widgets.so.5
#37 0x00007f813045f10e in QObjectPrivate::deleteChildren() () from /usr/lib/libQt5Core.so.5
#38 0x00007f813103104e in QWidget::~QWidget() () from /usr/lib/libQt5Widgets.so.5
#39 0x00007f813118ea5a in QScrollArea::~QScrollArea() () from /usr/lib/libQt5Widgets.so.5
#40 0x00007f8131761a98 in KPageWidgetItem::~KPageWidgetItem() () from /usr/lib/libKF5WidgetsAddons.so.5
#41 0x00007f8131761b96 in ?? () from /usr/lib/libKF5WidgetsAddons.so.5
#42 0x00007f8131761d72 in KPageWidgetModel::removePage(KPageWidgetItem*) () from /usr/lib/libKF5WidgetsAddons.so.5
#43 0x00007f8131a36f46 in ModuleView::closeModules() () from /usr/lib/libsystemsettingsview.so.3
#44 0x00007f8128029142 in ?? () from /usr/lib/qt/plugins/systemsettings_sidebar_mode.so
#45 0x00007f81280278ce in ?? () from /usr/lib/qt/plugins/systemsettings_sidebar_mode.so
#46 0x00007f8128027e23 in ?? () from /usr/lib/qt/plugins/systemsettings_sidebar_mode.so
#47 0x00007f812f4a956e in ?? () from /usr/lib/libQt5Qml.so.5
#48 0x00007f812f38f09f in ?? () from /usr/lib/libQt5Qml.so.5
#49 0x00007f812f390f3a in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () from /usr/lib/libQt5Qml.so.5
#50 0x00007f812f3acb37 in ?? () from /usr/lib/libQt5Qml.so.5
#51 0x00007f812f3af68f in ?? () from /usr/lib/libQt5Qml.so.5
#52 0x00007f812f349d2e in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /usr/lib/libQt5Qml.so.5
#53 0x00007f812f4c5916 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /usr/lib/libQt5Qml.so.5
#54 0x00007f812f47862d in QQmlBoundSignalExpression::evaluate(void**) () from /usr/lib/libQt5Qml.so.5
#55 0x00007f812f478b11 in ?? () from /usr/lib/libQt5Qml.so.5
#56 0x00007f812f4a900d in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /usr/lib/libQt5Qml.so.5
#57 0x00007f813046b955 in ?? () from /usr/lib/libQt5Core.so.5
#58 0x00007f812a67b732 in QQuickAbstractButtonPrivate::handleRelease(QPointF const&) () from /usr/lib/libQt5QuickTemplates2.so.5
#59 0x00007f812a699011 in QQuickControl::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5QuickTemplates2.so.5
#60 0x00007f812f89d058 in QQuickItem::event(QEvent*) () from /usr/lib/libQt5Quick.so.5
#61 0x00007f8130ff4752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#62 0x00007f8130434a7a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#63 0x00007f812f8b9898 in QQuickWindowPrivate::deliverMouseEvent(QQuickPointerMouseEvent*) () from /usr/lib/libQt5Quick.so.5
#64 0x00007f812f8bac4c in QQuickWindowPrivate::deliverPointerEvent(QQuickPointerEvent*) () from /usr/lib/libQt5Quick.so.5
#65 0x00007f8130912b95 in QWindow::event(QEvent*) () from /usr/lib/libQt5Gui.so.5
#66 0x00007f8130ff4752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#67 0x00007f8130434a7a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#68 0x00007f812fbdf35a in QQuickWidget::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQt5QuickWidgets.so.5
#69 0x00007f8131035b0e in QWidget::event(QEvent*) () from /usr/lib/libQt5Widgets.so.5
#70 0x00007f8130ff4752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#71 0x00007f8130ffb87b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#72 0x00007f8130434a7a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#73 0x00007f8130ffa87e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib/libQt5Widgets.so.5
#74 0x00007f813104e249 in ?? () from /usr/lib/libQt5Widgets.so.5
#75 0x00007f813105163f in ?? () from /usr/lib/libQt5Widgets.so.5
#76 0x00007f8130ff4752 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#77 0x00007f8130434a7a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#78 0x00007f8130906594 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/libQt5Gui.so.5
#79 0x00007f81308dbbb5 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Gui.so.5
#80 0x00007f812b35516c in ?? () from /usr/lib/libQt5XcbQpa.so.5
#81 0x00007f812e0aba84 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#82 0x00007f812e0ff9b1 in ?? () from /usr/lib/libglib-2.0.so.0
#83 0x00007f812e0aa2b1 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#84 0x00007f813048d6e1 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#85 0x00007f81304333fc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#86 0x00007f813043b894 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#87 0x000055ea272a3960 in ?? ()
#88 0x00007f812fe01152 in __libc_start_main () from /usr/lib/libc.so.6
#89 0x000055ea272a433e in _start ()
[Inferior 1 (process 8340) detached]
Comment 3 Nate Graham 2021-01-13 01:47:29 UTC
Actually looks more like a dupe of Bug 426047 since there's no QQmlData::wasDeleted() in it. Thanks!

*** This bug has been marked as a duplicate of bug 426047 ***
Comment 4 Nate Graham 2021-01-14 00:19:46 UTC

*** This bug has been marked as a duplicate of bug 431419 ***