Bug 431446 - Blinking panels and window contents not refreshing
Summary: Blinking panels and window contents not refreshing
Status: RESOLVED DUPLICATE of bug 429211
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 5.25.5
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-11 16:19 UTC by Eduardo
Modified: 2022-11-22 21:28 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen flashing 1 (2.34 MB, video/x-matroska)
2021-01-11 16:19 UTC, Eduardo
Details
Screen flashing 2 (3.47 MB, video/x-matroska)
2021-01-11 16:20 UTC, Eduardo
Details
Firefox contents freeze and flickering (330.24 KB, video/mp4)
2021-01-12 09:02 UTC, Eduardo
Details
KWin support information (6.23 KB, text/plain)
2021-01-12 09:02 UTC, Eduardo
Details
Bug also affects the mouse cursor (1.18 MB, video/mp4)
2022-08-11 12:54 UTC, Ben
Details
FF won't update its contents Plasma 5.25.5 (2.98 MB, video/x-matroska)
2022-09-07 21:02 UTC, Eduardo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo 2021-01-11 16:19:31 UTC
Created attachment 134741 [details]
Screen flashing 1

SUMMARY
Desktop contents, namely panels and their widgets, start to blink. For example clock widget does not update the time anymore, it just blinks or stays at some value.
The same happens with task "Task Manager", icons blink, contents are not updated.
This can be fixed by restarting plasmashell, the fix is temporal as this starts to happen again after some time.

The same weird behaviour happens to window contents, they just freeze (and sometimes blink), this can be fixed by restarting the application.
If I move the window, it gets refreshed briefly.

I think I can disable + enable compositing too and these are fixed for some time.

If this matters, I have 7 activities and a lot of applications open in total.

STEPS TO REPRODUCE
1. log in and use the system, maybe 3-8 hours, sometimes even 1 hour is enough

OBSERVED RESULT
Stuff starts to blink and windows do not refresh the contents.

EXPECTED RESULT
Stuff does not blink and windows do refresh their content.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
This started to happen like half a year ago, just very seldom, now it happens multiple times a day.

I have built-in "Mesa Intel(R) HD Graphics 530 (SKL GT2)".

I have tried so many things, that I don't remember them all, but I'll try:
setting options and their combinations:
KWIN_TRIPLE_BUFFER=1
KWIN_USE_BUFFER_AGE=1
KWIN_USE_INTEL_SWAP_EVENT=1

try opengl2/3 rendering 
using different kernels
multiple options for i915
using "intel" and "modesetting" drivers
not using some applets
trying to use different tearing prevention mechanisms
even wiping out my home dir kde settings

But I can not pinpoint what triggers this.
Comment 1 Eduardo 2021-01-11 16:20:04 UTC
Created attachment 134742 [details]
Screen flashing 2
Comment 2 Eduardo 2021-01-11 16:32:51 UTC
More info.
I usually have 2 more displays attached, laptop screen is disabled sometimes. One display is 144Hz capable, but set to 60Hz, other is 60Hz.
Using Xorg session.
Comment 3 Eduardo 2021-01-12 09:02:09 UTC
Created attachment 134761 [details]
Firefox contents freeze and flickering

Here's the firefox content freeze and flicker video.
I have more tabs opened, not just the ones I'm showing.
Comment 4 Eduardo 2021-01-12 09:02:31 UTC
Created attachment 134762 [details]
KWin support information
Comment 5 Vlad Zahorodnii 2021-01-12 10:43:41 UTC
Odd. At quick glance, it looks as a driver issue. Can you check whether screen flashes when kwin runs with KWIN_USE_BUFFER_AGE=0?
Comment 6 Eduardo 2021-01-13 07:27:41 UTC
Will try and post the results back.
I'll just update my system to very latest.
Comment 7 Eduardo 2021-01-13 19:37:30 UTC
Ok, that didn't help, terminals and Dolphin froze and I just had to restart.

Maybe you're right, that's the driver. The thing is that I have this computer for long time and I didn't have this issue prior to switch from Ubuntu Unity to KDE (~ 1 year ago), but maybe issue was introduced in later kernels / xorg or something else.

While checking for i915 errors in system log, I have found this:
[drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size.

Not sure whether that is related to the issue or not, but I'll check for the message when something freezes again.

Now I have enabled FBC for i915 and set GRUB_GFXMODE to 1024x768x8 and set it to keep (I'm really not sure whether that helps at all).
Let's see whether that influence anything.
Comment 8 Eduardo 2021-01-14 16:58:52 UTC
That does not seem to help, freeze happened again for firefox and clock applet, but at least there was no warning about "compressed framebuffer".
Comment 9 Eduardo 2021-02-09 10:02:26 UTC
I have started using Plasma/5.21 branch for kwin, but that does not help much.

The thing that is that it affects some random windows, probably those who are active at some unfortunate moment, but not everything.
So, maybe, just maybe it's not the driver...

Sometimes it's a panel, sometimes it's a window, last couple of times the content froze in Dolphin.
I have a suspicion that it flickers sometimes because it "remembers" couple of frames and then shows them on screen.
I have not got a flickering in Dolphin or other unfortunate apps which do not change content often.

The good thing is that disabling / enabling composition gets rid of the issue until next time.

The issue is not reproducible promptly, how to debug this?
Comment 10 vindicator 2021-02-23 16:09:38 UTC
I think I have this issue as well, but I'm on 5.21.0.
I don't think I've experienced this "level" of an issue before and this is the first time it's happened since I updated this past weekend.

My "normal" rendering issue comes from when I have "OpenGL" set as the compositor.
Not immediately, but over time, I'll encounter rendering issues with video playback that stutters/jitters/skips.
My "workaround" is simply to use "XRender" which is what I had done previously (and it is still using xrender).
I'll also put out that that simply switching between OpenGL versions in the compositor list sets things back on track... for awhile.

I am using X11. (I've learned my lesson with Wayland)

You stated that "restarting plasmashell" ("--replace"?) fixed it for you, but not for me.
I also did a "replace" for kwin, but still no success.
While konsole rendered keystrokes just fine, no such luck with typing in Chrome address bar.
One abnormal oddity that was probably leading up to the breakage (or letting me know something was amiss before it all broke down) was while watching recorded tv in kodi, there was some small/minor skippage (even though I was still using xrender).

The only action I could take was CTRL-ALT-DEL my way to "logout".

Xorg:
"[ 68637.069] (EE) intel(0): Failed to submit rendering commands (Bad address), disabling acceleration."
I don't know what time that was in relation to uptime.

Journalctl: (time which the clock stopped rendering was 09:07:##)
*****
Feb 23 09:08:46 computerName plasmashell[1441]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:464: TypeError: Cannot read property 'length' of undefined
Feb 23 09:07:57 computerName kwin_x11[1404]: qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 63014, resource id: 15333177, major code: 14 (GetGeometry), minor code: 0
Feb 23 09:07:57 computerName kwin_x11[1404]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 63013, resource id: 15333177, major code: 3 (GetWindowAttributes), minor code: 0
Feb 23 09:07:55 computerName kwin_x11[1404]: qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 62514, resource id: 15333173, major code: 14 (GetGeometry), minor code: 0
Feb 23 09:07:55 computerName kwin_x11[1404]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 62513, resource id: 15333173, major code: 3 (GetWindowAttributes), minor code: 0
Feb 23 09:05:06 computerName plasmashell[1441]: file:///usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationPopup.qml:116:15: QML QQuickItem: Binding loop detected for property "height"
*****

If it happens again, THEN I'll give "KWIN_USE_BUFFER_AGE=0" a try. This may just be a one-off for me.
I don't know if you'll still see this, but it just happened while I went to another tab to look at other bugs. I'm going to try to save this.
Comment 11 vindicator 2021-02-23 16:17:10 UTC
Nope. KWIN_USE_BUFFER_AGE=0 didn't make any difference.
I'm still in a flickering environment and can only see any updates in this browser tab if I max/restore this window.

*****
$ KWIN_USE_BUFFER_AGE=0 kwin_x11 --replace &
[1] 141797
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5079:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5081:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5083:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5087:47: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5089:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5097:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5101:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5103:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5107:45: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5110:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: Couldn't process include statement for 'us(\0)'
kwin_xkbcommon: XKB: Abandoning symbols file "(unnamed)"
kwin_xkbcommon: XKB: Failed to compile xkb_symbols
kwin_xkbcommon: XKB: Failed to compile keymap
kwin_core: XCB error: 10 (BadAccess), sequence: 2833, resource id: 308, major code: 142 (Composite), minor code: 2 (RedirectSubwindows)
*****

*****
[ 69857.600] (II) intel(0): Modeline "1400x1050"x0.0  101.00  1400 1448 1480 1560  1050 1053 1057 1080 +hsync -vsync (64.7 kHz e)
[ 70761.139] (EE) event3  - AT Translated Set 2 keyboard: client bug: event processing lagging behind by 23ms, your system is too slow
[ 72240.460] (EE) intel(0): Failed to submit rendering commands (Bad address), disabling acceleration.
[ 72385.800] (EE) event4  - Logitech M510: client bug: event processing lagging behind by 22ms, your system is too slow
[ 72389.905] (EE) event4  - Logitech M510: client bug: event processing lagging behind by 15ms, your system is too slow
[ 72566.569] (EE) event4  - Logitech M510: client bug: event processing lagging behind by 24ms, your system is too slow
*****
With that "intel" error again, something is most definitely up with the driver I think.
Comment 12 Gabor 2021-03-09 22:47:38 UTC
I have the same issue (chrome hw accel suspicious)
I dont know if it is related, but I almost always have to switch fromo tty1 and back to tty1 because the whole screen freezes when laptop locked.

intel i5 4210U
Comment 13 vindicator 2021-03-09 22:56:53 UTC
I can say that after I removed the xf86-video-intel at the end of last month, things have been "ok" for me so far.

I won't say it's "great", since I'll get some stuttering rendering issues sometimes when I hover over Kodi just so I can watch video in a small thumbnail view (whatever you'd want to call it), rather than a large window when I'm working on things. It only happens for that small video thumbnail though. But at least the rendering issue I had before hasn't happened since.

I also stuck with xrender compositing rather than opengl solely because the cpu usage is higher, even when idle for opengl.
Comment 14 Eduardo 2021-12-20 15:47:00 UTC
I think things improved since I registered the bug, I don't know the precise reason tho. I did disable PSR (i915.enable_psr=0), changed Content Process settings in Firefox and multiple KDE Plasma versions have changed, X11 versions changed, etc., i.e. no way to determine why.

Currently if I have this issue, it happens once in a week or even more rarely, so I will not be able to help with any diagnosis, if such need arises.
I guess for me it kinda solved itself to the level which does not bother me anymore :)
Comment 15 Oswald Buddenhagen 2022-01-06 15:33:04 UTC
i think i have the same issue, with intel sandy bridge desktop graphics on x11.
i consistently observe it for the panel (clock and task bar are obviously affected).
i haven't observed this for app windows so far, though now that i read it here: occasionally one of my chromium windows also goes haywire in a way that could be plausibly related; closing and re-opening the window from history fixes the issue.
like eduardo, i think that the buffers simply get mixed up - it alternates between two old states rather than showing the new contents. activity in app windows (e.g., a blinking cursor) causes "more correct" buffers to be used, though there continue to be glitches.
Comment 16 Nate Graham 2022-01-06 23:10:21 UTC
I wonder if you are suffering from https://gitlab.freedesktop.org/mesa/mesa/-/issues/5731, or a variant of it.
Comment 17 Oswald Buddenhagen 2022-01-07 02:04:32 UTC
as for my issue, that seems unlikely - that appears to be a recent regression, while i've been seeing this issue for ... well, i guess one should count it in years.
Comment 18 Nate Graham 2022-01-07 02:05:15 UTC
OK, probably not then.
Comment 19 Eduardo 2022-01-31 22:49:40 UTC
I have a bit more plausible explanation for this.
It look like when mesa defaulted from "i965" to "iris" driver for intel graphics (Intel Corporation HD Graphics 530 for me), my issue is not really showing up anymore, so it is quite plausible that this somewhat mitigated the issue for me.
Comment 20 Petr N. 2022-07-18 09:33:20 UTC
I have same Plasma and qt version as OP and also having this issue.
On Debian 11 5.10.0.16-amd64 (stable latest) with Plasma 5.20.5, framework 5.78.0, qt 5.15.2 (stable latest)
a few times a day the web browsers (i have tried two) stop being updated when scrolling the website etc. i need to click the whisker menu (where are programs list, search...) in order to update current view in web browser. Then i scroll down the web page and then again have to click menu to update view. Have to restart browser to temporarily fix it until it happen again (a few times a day).
Also the task bar (tray area) where i have clock, System monitor sensor it stops being updated or flickering and fixes itself temporarily by clicking whisker menu.
GPU, mesa, opengl detail is here https://pastebin.com/raw/Lrd4hYiX
So what are the steps to do so it can be fixed? Thank you
Comment 21 Colin Griffith 2022-07-21 22:03:35 UTC
I have this exact same issue (on an AMD card though; see bottom for details), and have to press Alt+Shift+F12 twice (toggle compositing; once to turn off, once to turn on) every few hours. It seems to sometimes happen around the time I get a notification, and I know for a fact that this correlates because I'll be playing a game with the game's window in the top left corner of my monitor and everything will be fine, but then a notification appears and instantly causes the game to freeze as the Plasma notification popup slides into view.

As it slides into view it leaves a 'trail' of itself across the window behind it, usually some other program like Firefox that I have running behind the game's window. The window the trail appears on is otherwise frozen, I believe, but I have not explicitly tested for that. I just know that the game does appear frozen, and the freezing occurs exactly at the same instant that the plasma popup for the notification starts sliding into view.

Audio in the game still runs, and I can pause and hear the game pause, and see the game's current state once I've toggled compositing. I could leave compositing off and that probably fixes it, but then Firefox has a weird black box around the autoscroll marker when I middle-click auto scroll in it, and other weird little graphical bugs that annoy me.

Sometimes the first indication that something like this has happened is that I'll go to switch windows, but I'll notice that hovering over taskbar entries doesn't change the color or lightness of the taskbar entry in question, and then things start to flicker when the preview popup tries to materialize.

The big difference, however, is that I am NOT on an Intel GPU. I have an AMD R9 290X, and use the AMDGPU driver (rather than the radeonsi driver). It's still a Mesa driver, but it'd be more similar to Intel's Iris driver as both it and AMDGPU use the Gallium framework.

If it matters, I have two monitors and have both calibrated using a colorimeter, with KDE loading the calibration at start. I also use X11 (since display calibration doesn't work under Wayland yet).

I'm using KDE Neon and have all packages fully up-to-date. Issues like this have been happening for a long time, though; at first it only happened around semitransparent windows (usually plasma widgets that pop over other windows, like the various application launcher menus and notifications), but then started happening more often and with more and more window types.

There are various key differences though, and I'm actually thinking it's more likely that these earlier occurrences around semi-transparent windows is a separate bug that was fixed, and coincidentally a more severe but similar-appearing bug appeared after the fix for the other one.
Comment 22 Colin Griffith 2022-07-21 22:07:35 UTC
Oh, important other note I can give about this. There was one scenario where I could have it trigger 100% of the time almost no matter what, but it's unlikely I can reproduce it quite so readily anymore. One time I had updated a LOT of KDE packages all at once, but didn't reboot or log out and back in because I had a bunch of programs open and wanted to finish what I was doing first.

I found that in that precarious state, I could ALWAYS cause all other programs to freeze and flicker by using certain specific programs. One of them was FontForge, specifically opening a glyph vector editing window in it.

I know that FontForge is infamous for implementing its own 'pure X11' widgets instead of using a widget toolkit, and that makes me wonder if KWin is interfering with some X11 draw call that other applications are attempting to use?
Comment 23 Diana 2022-07-22 13:57:12 UTC
I have an AMD 6900 XT and have also suddenly started getting this recently. I dont know when exactly it happened, just after some update. I use Arch Linux. Toggling compositing temporarily fixes it, until it comes back again.
Comment 24 Yuriy Vidineev 2022-07-28 21:58:56 UTC
I have something similar.

KDE Neon 5.25 User Edition
Linux 5.15.0-41-generic
I've tried on Intel and NVidia graphics - same effect.
It pretty often (a couple of times a day) happens in Firefox and Thunderbolt. Google Chrome also behaves weirdly. App restart helps till the next freeze. A window resizes also refreshes the content.

Maybe a duplicate:
https://bugs.kde.org/show_bug.cgi?id=456511
Comment 25 Ben 2022-08-04 20:19:04 UTC
Just wanted to add that I have this problem, too. As others said, it's usually an hour or several before it happens. 

It has been indiscriminate as to which windows are affected, sometimes latte, sometimes firefox, or the kde system monitor, etc. Closing and reopening the affected app fixes it.

I'm using the legacy nvidia drivers (470x) with a GTX 770, and I'm running Arch Linux.

Plasma version 5.25.3
Frameworks version 5.96.0
X11

First witnessed this problem several months ago.
Comment 26 Yuriy Vidineev 2022-08-04 20:30:03 UTC
(In reply to Ben from comment #25)
> Just wanted to add that I have this problem, too. As others said, it's
> usually an hour or several before it happens. 
> 
> It has been indiscriminate as to which windows are affected, sometimes
> latte, sometimes firefox, or the kde system monitor, etc. Closing and
> reopening the affected app fixes it.
> 
> I'm using the legacy nvidia drivers (470x) with a GTX 770, and I'm running
> Arch Linux.
> 
> Plasma version 5.25.3
> Frameworks version 5.96.0
> X11
> 
> First witnessed this problem several months ago.

@Ben Alt+Shift+f12 should fix it as well (for me, at least) - much more useful than the app restart
Comment 27 Colin Griffith 2022-08-09 02:48:21 UTC
Odd. I had thought that my whole desktop froze up rather than individual applications, but now that I've actually tested this myself, it's true.. Some programs are affected, some aren't. It seems to be programs that Can play (but not necessarily ones that Are playing) video, perhaps? Telegram and Firefox are both affected, but Kate isn't.

Firefox uses GTK and its own widget rendering, and Telegram uses a modified version of Qt, so it's not a widget toolkit issue (as they use wildly different widget toolkits). Kate uses Qt but is unaffected, so I'm not so quick to claim it's a Qt issue.. Or at least, not a QWidgets issue. Maybe a bug with however QML/QtQuick render things, that's also shared with how Firefox renders things?

There are definitely times I get notifications and it Doesn't happen, and it also sometimes happens Without getting a notification, but there have been numerous times now where I get a notification and it starts happening in all affected applications simultaneously.
Comment 28 Colin Griffith 2022-08-09 02:50:41 UTC
Oh, and in my initial post I had mentioned it happening to games; in particular, it happens with RetroArch. So perhaps it happens to any window that's using hardware acceleration.
Comment 29 Donovan Zimmerman 2022-08-10 16:02:37 UTC
It is worth pointing out that using desktop effects that in any way manipulates affected windows (e.g. zoom) also seems to temporarily end the issue, but resumes once the effect is stopped again. At least this was my observation back when I was using X11 which was a good major release cycle or two back.

Issue might also either be specific to kwin_x11, or maybe VRR/FreeSync is helping in some way to mitigate this. Either way, I've yet to experience it under Wayland. X11 also has some form of VRR, but last I knew it is heavily limited.
Comment 30 Oswald Buddenhagen 2022-08-10 18:24:29 UTC
this suggests that this might have something to do with partial repaints. maybe it's picking the wrong buffer for updating.
this is consistent with my observation that for me this usually affects only the panel when the clock is ticking away.
Comment 31 Ben 2022-08-11 12:45:59 UTC
If this changes anything, I today noticed that it also has an effect on the mouse cursor-- so long as it is within the borders of an affected window. This surprises me as I wouldn't have expected the cursor to be part of the same paint.

When I moused over VS code during an instance of this bug, the cursor was flicking between 2 cursor types, in 2 adjacent locations. I tried to record this but the mouse appeared normal in the recording.
Comment 32 Ben 2022-08-11 12:54:01 UTC
Created attachment 151248 [details]
Bug also affects the mouse cursor
Comment 33 Oswald Buddenhagen 2022-08-11 19:40:07 UTC
i don't think the cursor problem is related. as you note yourself, the cursor is a separate entity, and the fact that it's not in the captured framebuffer is further evidence of this.
Comment 34 Colin Griffith 2022-08-13 02:08:31 UTC
(In reply to Ben from comment #31)
> If this changes anything, I today noticed that it also has an effect on the
> mouse cursor-- so long as it is within the borders of an affected window.
> This surprises me as I wouldn't have expected the cursor to be part of the
> same paint.
> 
> When I moused over VS code during an instance of this bug, the cursor was
> flicking between 2 cursor types, in 2 adjacent locations. I tried to record
> this but the mouse appeared normal in the recording.

I don't see this in any of the programs I use. In the video you posted, it looks almost like it's unsure where the mouse is supposed to be, as it jitters back and forth a lot (doesn't just change cursors).

Perhaps VS Code is literally painting its own mouse cursor, like some games do? Alternatively, it might just be an nVidia driver bug, as you said you're using an nVidia card earlier.

Also, I would have posted this sooner, but today I've been oddly lucky and have had fewer instances of this bug. Had to wait all day to confirm for sure that this doesn't happen to me.
Comment 35 rsvensson.malmo 2022-09-06 08:55:36 UTC
I often have the problem with window contents not updating when I use Parsec to connect to my work PC at the office from my Linux desktop at home, as well as the Slack client running locally. Parsec is set up to use hardware acceleration for the video stream. I see that others are mentioning hardware acceleration as well so that is a likely cause here I would think. I have also noticed this occasionally with Firefox, and a few times the KDE Panel has also been glitchy as described in the initial report. But it is mostly Parsec and Slack not updating their contents.

Toggling desktop effects on and off with Shift+Alt+F12 seems to fix it for a while.

Software:
KDE Plasma 5.25.4
KDE Frameworks 5.97.0
Qt: 5.15.5
Kernel: Linux 5.19.4-xanmod1
Graphics Platform: X11

Hardware:
CPU: AMD Ryzen 9 5900X
GPU: Nvidia Geforce GTX 1660 Ti (with proprietary driver 515.65.01)
OS: Arch Linux
Comment 36 Petr N. 2022-09-06 15:56:14 UTC
I have mentioned at https://bugs.kde.org/show_bug.cgi?id=431446#c20 that i am having the issue on:
Debian 11 5.10.0.16-amd64 (stable latest) with Plasma 5.20.5, framework 5.78.0, qt 5.15.2 (stable latest)
but now for a few weeks I NO LONGER SEE THE ISSUE. Only SW version from above mentioned that changed is kernel moving from *.0.16 to *.0.17 in case you want to know my current kwin packages versions, here: https://pastebin.com/raw/GRTU4DzG
Comment 37 Eduardo 2022-09-07 21:02:16 UTC
Created attachment 151905 [details]
FF won't update its contents Plasma 5.25.5

For a long time I did not encounter this bug, but now it's back again... Here is my situation.

Since the bug was so annoying and prevented my work to be done, I had reset all plasma to defaults and somehow I did not encounter the bug for some time.
In addition to this, for some time MESA changed the driver from i965 to iris, at first I thought that this is what helped to get rid of the bug for the most part, but now I'm not sure anymore...

And I'm not sure about this, because after I updated to plasma 5.25.5, I enabled a nice feature I liked - Translucency, specifically the defaults, i.e. when moving windows, they become transparent. Soon after that I got the bug reappear, Firefox won't update its contents...
The weird part is that disabling and enabling composition does NOT get the contents back as it was before! I have to restart the application...
Is this really related to transparency things... I'll disable the effect will report back whether the issue reappears.

The attachment shows that:
1. contents are not updated
2. even new windows of the same application (FF) inherits the same buggy behaviour
3. disabling / enabling composite won't get rid of the bug
Comment 38 Nate Graham 2022-09-09 17:37:53 UTC
Seems like this is just Bug 456511.

*** This bug has been marked as a duplicate of bug 456511 ***
Comment 39 Eduardo 2022-09-12 07:54:37 UTC
This issue is almost 2 years old for Plasma 5.20.x, it was present even before that, now it's flagged as duplicate for issue regarding Plasma 5.25.x, which does not look exactly the right way.
I hope the decision was not taken because I updated the affected version from 5.20.x to 5.25.5. If this is my mistake, I'll change it back to 5.20.
Comment 40 Oswald Buddenhagen 2022-11-22 21:28:41 UTC
i guess bug 429211 is a more appropriate reference.

fwiw, i identified another situation which might or might not be related: when i restore a chromium session with tens of windows (and hundreds of tabs), (some of) the chromium windows flicker like crazy between "screenshots" of the windows' rectangles until the session restoration is complete. however, in this case disabling the compositor actually kinda helps - the windows then simply stay blank.

*** This bug has been marked as a duplicate of bug 429211 ***