Bug 431318 - Newly created keyboard shortcuts for apps with user-edited desktop files do not work
Summary: Newly created keyboard shortcuts for apps with user-edited desktop files do n...
Alias: None
Product: kmenuedit
Classification: Applications
Component: general (show other bugs)
Version: 5.20.5
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
Depends on:
Reported: 2021-01-08 16:02 UTC by Jason Straight
Modified: 2021-01-27 22:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Jason Straight 2021-01-08 16:02:14 UTC
Newly created keyboard shortcuts do not work. I am able to create them, and set them, but they do not work.


I added a menu entry for atop to run in a terminal. The menu entry works fine. I try to set any shortcut key combo for it. It accepts my settings, but will not launch.

For apps that have been there for a long time, I can set those.

I set all shortcuts to defaults. Breaking my previous shortcuts. I had one to launch speedcrunch with meta-C. I reset that to meta-c and it works fine.

I changed the ones for yakuake, and terminal, and they work fine.

The problem seems limited to newly added apps.

Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

Comment 1 David Edmundson 2021-01-08 16:07:13 UTC
How are you creating these shortcuts?
Comment 2 Jason Straight 2021-01-08 16:13:22 UTC
(In reply to David Edmundson from comment #1)
> How are you creating these shortcuts?

lol. Was just adding that when you asked and had a collision as we both submitted at the same time.

This can only be done from the shortcuts system settings, trying to set a shortcut from within kmenuedit does nothing. The button elicits no response.

system settings -> shortcuts -> add application -> select application -> add custom shortcut
Comment 3 Duncan 2021-01-15 00:52:53 UTC
(In reply to Jason Straight from comment #2)
> (In reply to David Edmundson from comment #1)
> > How are you creating these shortcuts?
> lol. Was just adding that when you asked and had a collision as we both
> submitted at the same time.

Hi Jason, just another user here.  I don't see this bug here and just happened across it looking for something else, but hopefully someone would similarly help if I'd overlooked it on a bug I'd filed...

When Dave asked the question he set the bug to NEEDSINFO so it could be easily filtered out until the info was available.  You provided the asked-for info but didn't set the status back to REPORTED, so it's still being filtered out as inactive.

Meanwhile, a couple more questions you might answer when you set it back to reported, to avoid further question/answer round-trips:  Bug on X or Wayland sessions (both?)? Also, I do see the kwin/plasma version set to 5.20.5 in the drop-down, on Linux, but the versions boilerplate info in the initial comment still isn't available: Version of Qt?  Frameworks?  Which distro/version and their build, yours, or from what third party?
Comment 4 Jason Straight 2021-01-20 03:01:05 UTC
kmenuedit now allows me to set the shortcuts, but they still don't actually open the applications.

Steps to reproduce:

create a new application in kmenuedit:

I created "konsole2", which runs "konsole"

set shortcut key: tried win-k, and ctrl-alt-esc

tested opening via kmenu - works

try using shortcut: nothing happens

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.8-1-MANJARO
Comment 5 Jason Straight 2021-01-20 03:10:07 UTC
After logging out/in. I tried the shortcut again. Didn't work.

Went into kmenuedit and the shortcut was not set. When I tried to set it, it complained that it was already set for the same app.

After resetting it, it works.
Comment 6 Nate Graham 2021-01-26 19:17:13 UTC
Reminds me of Bug 430388, but that's supposed to be fixed in Frameworks 5.78, which you have.

Works for me, FWIW. I can set shortcuts from kmenuedit and they launch the app.
Comment 7 Jason Straight 2021-01-27 19:47:33 UTC
Well, if anyone has any ideas, I'd be glad to try.

I tried to set firefox to open with win-W and I can't make it work for the life of me. It takes the shortcut and sets it. It shows as being set to win-w, I log out/in to verify it's still set - it is.

Still doesn't launch firefox.
Comment 8 Jason Straight 2021-01-27 20:01:49 UTC
Turns out I have edited firefox's menu entry to get it to use KDE. So that's certainly a theme here. Anything that I've edited/added with kmenuedit (so these apps have .desktop entries in $HOME), then hotkeys won't work right for them.

I set Vivaldi to open with win-w and it works fine. Set win-w back to firefox and it won't work.
Comment 9 Jason Straight 2021-01-27 22:31:08 UTC
I just re-created on KDE Neon User edition that I just downloaded, from the live environment.

- Start neon
- apt update
- apt install atop
- right click k menu, edit applications
- add an entry for atop, set to run with konsole/terminal
- set keyboard shortcut (ctrl-shift-esc)

Shortcut doesn't work. Launching from menu does.

There were other oddities in setting shortcuts from kmenu as well. I also added one for konsole called konsole2, and one for speedcrunch. While those worked, I noticed that after adding them both in succession, that the 2nd one I added already had the keyboard shortcut filled out as the last app I added.

In other words, I added konsole2 set a shortcut, then added speedcr app, and the shortcut widget was populated with the shortcut I had set for konsole2.
Comment 10 Jason Straight 2021-01-27 22:56:42 UTC
There's something peculiar about firefox itself. I can't get FF to open with a hotkey at all. However, I can add my own firefox menu entry and launch that from a hotkey. One difference is that the default menu entry for firefox on my system (Manjaro), is /usr/lib/firefox/firefox, and the one I added that works is just /usr/bin/firefox.

As for atop, I can set my atop execute command to 'konsole -e atop', and then the hotkey launching works.

Both of them open from the menu just fine. Just hotkeys fail, if done normally.