Bug 430561 - Konversation Does Not Appear on Top when Called from Plasma System Tray
Summary: Konversation Does Not Appear on Top when Called from Plasma System Tray
Status: RESOLVED FIXED
Alias: None
Product: konversation
Classification: Applications
Component: general (show other bugs)
Version: 1.8.201180
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-19 01:03 UTC by Noah Li
Modified: 2021-12-23 00:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 1.8.21121


Attachments
When Konversation does not appear on top. (756.58 KB, image/png)
2020-12-19 01:03 UTC, Noah Li
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noah Li 2020-12-19 01:03:30 UTC
Created attachment 134196 [details]
When Konversation does not appear on top.

SUMMARY
Sometimes Konversation does not appear on top when called from Plasma system tray. I experimented a bit but cannot confirm what conditions make the window appear on top and what do not. None of the other windows is forced on top by KWin rules.

STEPS TO REPRODUCE
1. Open Konversation and minimize it to Plasma system tray;
2. Click the tray icon to resume Konversation.

OBSERVED RESULT
Konversation appears above other windows.

EXPECTED RESULT
Sometimes Konversation appears beneath other windows. When this happens it will be shown highlighted in the taskbar.

SOFTWARE/OS VERSIONS
Linux: Arch Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Comment 1 Noah Li 2020-12-19 01:11:30 UTC
*Sorry I messed up the observed and expected results in bug description but you get the idea.
Comment 2 Nate Graham 2020-12-19 16:53:28 UTC

*** This bug has been marked as a duplicate of bug 423857 ***
Comment 3 Nate Graham 2021-01-04 16:26:28 UTC
Un-duping since Konversation will need an app-specific fix for this; see https://invent.kde.org/frameworks/kdbusaddons/-/merge_requests/5.
Comment 4 Nate Graham 2021-01-05 03:33:39 UTC
This needs a fix like the one in https://invent.kde.org/plasma/discover/commit/57dc3b725d1bfed713dffbc13543f79300503d61.
Comment 5 Bug Janitor Service 2021-12-21 19:25:10 UTC
A possibly relevant merge request was started @ https://invent.kde.org/network/konversation/-/merge_requests/69
Comment 6 Friedrich W. H. Kossebau 2021-12-23 00:32:31 UTC
Git commit 82cf2e1fb59daf71c0d577f5a296b8b2fb2b24a1 by Friedrich W. H. Kossebau.
Committed on 22/12/2021 at 20:26.
Pushed by kossebau into branch 'release/21.12'.

On activation by KDBusService set proper startupId/activation token
FIXED-IN: 1.8.21121

M  +10   -0    CMakeLists.txt
M  +1    -0    config-konversation.h.cmake
M  +4    -0    src/CMakeLists.txt
M  +17   -1    src/application.cpp

https://invent.kde.org/network/konversation/commit/82cf2e1fb59daf71c0d577f5a296b8b2fb2b24a1