Bug 430560 - Poor Touchscreen Support in Wayland
Summary: Poor Touchscreen Support in Wayland
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.20.4
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-19 00:21 UTC by Temp
Modified: 2021-07-06 17:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Temp 2020-12-19 00:21:00 UTC
MAIN ISSUE
- The touchscreen to interact with Latte and KDE Plasma works, but windows that become maximized has a likely chance to not register touchscreen inputs. Now for any windows that begins maximized, I can use the touchscreen. But for any window that began as normal and become maximized, the window doesn't register touch inputs.
- Other times, it simply does not read the inputs, regardless if it's maximized or not.

WAYS TO REPRODUCE (These are NOT steps, these are METHODS)
1. Maximize any window for touchscreen support for a window to be gone.
2. If a window is currently maximized, unmaximize it then maximize it again.

OBSERVED RESULT
- Any of these steps will result in the window to not register touchscreen inputs.

OTHER ISSUES
- Dragging GTK applications like Lutris has some... effects. Resizing it makes the window flickers different window sizes and releasing your finger after dragging the window causes it to misplace. In addition, there is some flicker of the window misplacing while dragging the window.
- Touchscreen edges work, but there is no support for touchscreens when using the desktop grid.
- I can still interact with the window's titlebars and other aspects of Plasma, such as Latte and the Desktop.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSUSE Tumbleweed
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Comment 1 personalizedrefrigerator 2021-01-12 12:01:36 UTC
I can't reproduce the main issue (touch input in maximized windows works fine for me, even after un-maximizing and re-maximizing). I can, however, the issue dragging GTK applications (window flies offscreen, depending on the mouse cursor's location).
I am on KDE Neon, Plasma version 5.20.5, Qt version 5.15.2, KDE Frameworks version 5.78.0.
Comment 2 Zamundaaa 2021-07-01 13:11:58 UTC
Git commit a4dcfbfb313bde5c6f747d7e59f2cf725f1946b2 by Xaver Hugl.
Committed on 01/07/2021 at 13:11.
Pushed by zamundaaa into branch 'master'.

input: fix touch input getting borked on quick tile

The decorationPressId never gets reset as the decoration isn't below the
touch point anymore after the quick tile, so if we have no decoration
under the touch point reset the decorationPressId to -1.

M  +6    -0    src/input.cpp

https://invent.kde.org/plasma/kwin/commit/a4dcfbfb313bde5c6f747d7e59f2cf725f1946b2
Comment 3 Zamundaaa 2021-07-01 13:12:52 UTC
Git commit cc3e89972800e13f42120140fc6232f5b0597531 by Xaver Hugl.
Committed on 01/07/2021 at 13:12.
Pushed by zamundaaa into branch 'Plasma/5.22'.

input: fix touch input getting borked on quick tile

The decorationPressId never gets reset as the decoration isn't below the
touch point anymore after the quick tile, so if we have no decoration
under the touch point reset the decorationPressId to -1.


(cherry picked from commit a4dcfbfb313bde5c6f747d7e59f2cf725f1946b2)

M  +6    -0    src/input.cpp

https://invent.kde.org/plasma/kwin/commit/cc3e89972800e13f42120140fc6232f5b0597531
Comment 4 Nate Graham 2021-07-03 02:02:41 UTC
Anything left to do here?
Comment 5 David Edmundson 2021-07-06 17:17:43 UTC
Anything else can get it's own more focused bug report