Bug 430434 - Crashes when opening a new tab while there's text in the search field
Summary: Crashes when opening a new tab while there's text in the search field
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: bars: location (show other bugs)
Version: 20.12.0
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-15 16:53 UTC by Nate Graham
Modified: 2020-12-15 21:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2020-12-15 16:53:32 UTC
Dolphin and all other KDE software from git master, built today.


STEPS TO REPRODUCE
1. Open a new window
2. Hit Ctrl+F to bring up the find panel
3. Type anything in the search field
4. Hit Ctrl+T to open a new tab

OBSERVED RESULT
Crash in KUrlNavigator::locationUrl():


#0  0x00007ffff7d52e6e in KUrlNavigator::locationUrl (this=0x0, historyIndex=historyIndex@entry=-1)
    at /home/nate/kde/src/kio/src/filewidgets/kurlnavigator.cpp:910
#1  0x00007ffff7f34116 in DolphinViewContainer::setSearchModeEnabled (this=0xfc16f0, 
    enabled=<optimized out>) at /home/nate/kde/src/dolphin/src/dolphinviewcontainer.cpp:393
#2  0x00007ffff7f358d4 in DolphinViewContainer::DolphinViewContainer (this=0xfc16f0, url=..., 
    parent=<optimized out>) at /home/nate/kde/src/dolphin/src/dolphinviewcontainer.cpp:188
#3  0x00007ffff7f3c031 in DolphinTabPage::createViewContainer (this=this@entry=0x10fbdc0, url=...)
    at /home/nate/kde/src/dolphin/src/dolphintabpage.cpp:432
#4  0x00007ffff7f3d00b in DolphinTabPage::DolphinTabPage (this=0x10fbdc0, primaryUrl=..., 
    secondaryUrl=..., parent=<optimized out>)
    at /home/nate/kde/src/dolphin/src/dolphintabpage.cpp:34
#5  0x00007ffff7f3e2c0 in DolphinTabWidget::openNewTab (this=this@entry=0x7e5e30, primaryUrl=..., 
    secondaryUrl=..., tabPlacement=tabPlacement@entry=DolphinTabWidget::AfterLastTab)
    at /home/nate/kde/src/dolphin/src/dolphintabwidget.cpp:162
#6  0x00007ffff7f3e624 in DolphinTabWidget::openNewActivatedTab (secondaryUrl=..., primaryUrl=..., 
    this=0x7e5e30) at /home/nate/kde/src/dolphin/src/dolphintabwidget.cpp:154
#7  DolphinTabWidget::openNewActivatedTab (this=0x7e5e30)
    at /home/nate/kde/src/dolphin/src/dolphintabwidget.cpp:139
#8  0x00007ffff5cf1866 in QtPrivate::QSlotObjectBase::call (a=0x7fffffffcb30, r=0x51df20, 
    this=0x915650) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#9  doActivate<false> (sender=0x7cec80, signal_index=4, argv=argv@entry=0x7fffffffcb30)
    at kernel/qobject.cpp:3886
#10 0x00007ffff5ceabc0 in QMetaObject::activate (sender=sender@entry=0x7cec80, 
    m=m@entry=0x7ffff6df90a0 <QAction::staticMetaObject>, 
    local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fffffffcb30)
    at kernel/qobject.cpp:3946
#11 0x00007ffff68fbf12 in QAction::triggered (this=this@entry=0x7cec80, _t1=<optimized out>)
    at .moc/moc_qaction.cpp:376
#12 0x00007ffff68fe751 in QAction::activate (this=0x7cec80, event=event@entry=QAction::Trigger)
    at kernel/qaction.cpp:1161
#13 0x00007ffff68ff317 in QAction::event (e=<optimized out>, this=<optimized out>)
    at kernel/qaction.cpp:1086
#14 QAction::event (this=<optimized out>, e=<optimized out>) at kernel/qaction.cpp:1075
#15 0x00007ffff690250f in QApplicationPrivate::notify_helper (this=<optimized out>, 
    receiver=0x7cec80, e=0x7fffffffcd10) at kernel/qapplication.cpp:3632
#16 0x00007ffff5cbb28a in QCoreApplication::notifyInternal2 (receiver=0x7cec80, 
    event=0x7fffffffcd10) at kernel/qcoreapplication.cpp:1063
#17 0x00007ffff61ee30b in QShortcutMap::dispatchEvent (this=this@entry=0x453c18, 
    e=e@entry=0x7fffffffcdd0) at kernel/qshortcutmap.cpp:675
#18 0x00007ffff61eeccb in QShortcutMap::tryShortcut (this=this@entry=0x453c18, 
    e=e@entry=0x7fffffffcdd0) at kernel/qshortcutmap.cpp:343
#19 0x00007ffff61982be in QWindowSystemInterface::handleShortcutEvent (window=0x7fffffffcdd0, 
    timestamp=7817276, keyCode=84, modifiers=..., nativeScanCode=28, nativeVirtualKey=116, 
    nativeModifiers=4, text=..., autorepeat=false, count=1)
    at kernel/qwindowsysteminterface.cpp:477
#20 0x00007ffff61baabb in QGuiApplicationPrivate::processKeyEvent (e=0x7fffffffcf70)
    at kernel/qguiapplication.cpp:2395
#21 0x00007ffff0df06b8 in QIBusPlatformInputContext::filterEventFinished (this=<optimized out>, 
    call=0xfff420) at qibusplatforminputcontext.cpp:517
#22 0x00007ffff5cf1866 in QtPrivate::QSlotObjectBase::call (a=0x7fffffffd110, r=0x533040, 
--Type <RET> for more, q to quit, c to continue without paging--
    this=0xde4530) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#23 doActivate<false> (sender=0xfff420, signal_index=3, argv=argv@entry=0x7fffffffd110)
    at kernel/qobject.cpp:3886
#24 0x00007ffff5ceabc0 in QMetaObject::activate (sender=<optimized out>, 
    m=m@entry=0x7ffff6f4d5c0 <QDBusPendingCallWatcher::staticMetaObject>, 
    local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffffffd110)
    at kernel/qobject.cpp:3946
#25 0x00007ffff6f2d92f in QDBusPendingCallWatcher::finished (this=<optimized out>, 
    _t1=<optimized out>) at .moc/moc_qdbuspendingcall.cpp:158
#26 0x00007ffff5ce72b1 in QObject::event (this=0xfff420, e=0x14f75d0) at kernel/qobject.cpp:1314
#27 0x00007ffff690250f in QApplicationPrivate::notify_helper (this=<optimized out>, 
    receiver=0xfff420, e=0x14f75d0) at kernel/qapplication.cpp:3632
#28 0x00007ffff5cbb28a in QCoreApplication::notifyInternal2 (receiver=0xfff420, event=0x14f75d0)
    at kernel/qcoreapplication.cpp:1063
#29 0x00007ffff5cbdcc1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, 
    data=0x439e20) at kernel/qcoreapplication.cpp:1817
#30 0x00007ffff5d13153 in postEventSourceDispatch (s=s@entry=0x51adc0)
    at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007ffff3c55cf7 in g_main_dispatch (context=0x7fffec005000) at ../glib/gmain.c:3325
#32 g_main_context_dispatch (context=0x7fffec005000) at ../glib/gmain.c:4043
#33 0x00007ffff3c56078 in g_main_context_iterate (context=context@entry=0x7fffec005000, 
    block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4119
#34 0x00007ffff3c5612f in g_main_context_iteration (context=0x7fffec005000, 
    may_block=may_block@entry=1) at ../glib/gmain.c:4184
#35 0x00007ffff5d127df in QEventDispatcherGlib::processEvents (this=0x532b80, flags=...)
    at kernel/qeventdispatcher_glib.cpp:423
#36 0x00007ffff5cb9c4b in QEventLoop::exec (this=this@entry=0x7fffffffd4e0, flags=..., 
    flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#37 0x00007ffff5cc1ec0 in QCoreApplication::exec ()
    at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#38 0x00007ffff61b21bc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#39 0x00007ffff6902485 in QApplication::exec () at kernel/qapplication.cpp:2824
#40 0x00007ffff7f20918 in kdemain (argc=<optimized out>, argv=<optimized out>)
    at /home/nate/kde/src/dolphin/src/main.cpp:222
#41 0x00007ffff54fd152 in __libc_start_main (main=0x401040 <main>, argc=1, argv=0x7fffffffd798, 
    init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, 
    stack_end=0x7fffffffd788) at ../csu/libc-start.c:314
#42 0x000000000040107e in _start () at ../sysdeps/x86_64/start.S:120
Comment 1 Elvis Angelaccio 2020-12-15 21:44:04 UTC

*** This bug has been marked as a duplicate of bug 429628 ***
Comment 2 Elvis Angelaccio 2020-12-15 21:44:30 UTC
Git commit c95d7fae79a309ed7f2df393fa20257cb20d54a8 by Elvis Angelaccio, on behalf of Anthony Fieroni.
Committed on 15/12/2020 at 21:44.
Pushed by elvisangelaccio into branch 'release/20.12'.

Fix access url navigator while creating new tab in filename search view
Related: bug 429628

Signed-off-by: Anthony Fieroni <bvbfan@abv.bg>

M  +1    -1    src/dolphinviewcontainer.cpp

https://invent.kde.org/system/dolphin/commit/c95d7fae79a309ed7f2df393fa20257cb20d54a8