Bug 430432 - System settings app crashed when attempting to install macOS Big Sur cursor icon set
Summary: System settings app crashed when attempting to install macOS Big Sur cursor i...
Status: RESOLVED DUPLICATE of bug 429442
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.20.4
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-12-15 16:34 UTC by josh.phelps2011
Modified: 2020-12-16 21:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josh.phelps2011 2020-12-15 16:34:24 UTC
Application: systemsettings5 (5.20.4)

Qt Version: 5.15.2
Frameworks Version: 5.76.0
Operating System: Linux 5.9.14-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: I was trying to install a new cursor theme thru the get cursors feature in the KDE applet. When I attempted to install a macOS Big Sur cursor icon set, the application simply crashed.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  std::__atomic_base<QThread*>::load (__m=std::memory_order_acquire, this=0xc9) at /usr/include/c++/10/bits/atomic_base.h:741
#5  std::atomic<QThread*>::load (__m=std::memory_order_acquire, this=0xc9) at /usr/include/c++/10/atomic:523
#6  QAtomicOps<QThread*>::loadAcquire<QThread*> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:251
#7  QBasicAtomicPointer<QThread>::loadAcquire (this=0xc9) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:255
#8  QObject::thread (this=this@entry=0x55f29b2ea8b0) at kernel/qobject.cpp:1487
#9  0x00007fe11f693feb in QObject::killTimer (this=this@entry=0x55f29b2ea8b0, id=0) at kernel/qobject.cpp:1795
#10 0x00007fe11f69e9f9 in QTimer::stop (this=this@entry=0x55f29b2ea8b0) at kernel/qtimer.cpp:243
#11 0x00007fe11f69ea6f in QTimer::start (this=0x55f29b2ea8b0) at kernel/qtimer.cpp:211
#12 0x00007fe11f69a866 in QtPrivate::QSlotObjectBase::call (a=0x7ffdb09af970, r=0x55f29b76d250, this=0x55f29ab76e40) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#13 doActivate<false> (sender=0x7fe11400d280, signal_index=9, argv=argv@entry=0x7ffdb09af970) at kernel/qobject.cpp:3886
#14 0x00007fe11f693bc0 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7fe0c713f2a0 <KNSCore::Engine::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffdb09af970) at kernel/qobject.cpp:3946
#15 0x00007fe0c70e3d95 in KNSCore::Engine::signalEntryChanged (this=<optimized out>, _t1=...) at /usr/src/debug/knewstuff-5.76.0-1.1.x86_64/build/src/core/KF5NewStuffCore_autogen/EWIEGA46WW/moc_engine.cpp:578
#16 0x00007fe0c70f5384 in KNSCore::Engine::install (this=0x7fe11400d280, entry=..., linkId=2) at /usr/src/debug/knewstuff-5.76.0-1.1.x86_64/src/core/engine.cpp:553
#17 0x00007fe0c7153e82 in ItemsModel::installItem (this=this@entry=0x55f29a5356b0, index=<optimized out>, linkId=<optimized out>) at /usr/src/debug/knewstuff-5.76.0-1.1.x86_64/src/qtquick/quickitemsmodel.cpp:412
#18 0x00007fe0c715619b in ItemsModel::updateItem (index=<optimized out>, this=<optimized out>) at /usr/src/debug/knewstuff-5.76.0-1.1.x86_64/src/qtquick/quickitemsmodel.cpp:419
#19 0x00007fe0c7159663 in ItemsModel::qt_metacall (this=0x55f29a5356b0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7ffdb09afca0) at /usr/src/debug/knewstuff-5.76.0-1.1.x86_64/build/src/qtquick/newstuffqmlplugin_autogen/EWIEGA46WW/moc_quickitemsmodel.cpp:301
#20 0x00007fe11e688dad in QQmlObjectOrGadget::metacall (this=this@entry=0x7ffdb09aff30, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=58, argv=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlobjectorgadget.cpp:51
#21 0x00007fe11e5721ce in CallMethod (callType=<optimized out>, callArgs=0x7ffdb09aff30, engine=<optimized out>, argTypes=<optimized out>, argCount=<optimized out>, returnType=<optimized out>, index=<optimized out>, object=...) at /usr/include/qt5/QtCore/qvarlengtharray.h:201
#22 CallPrecise (object=..., data=..., engine=engine@entry=0x55f29b7e2390, callArgs=callArgs@entry=0x7fe0df2c06f0, callType=callType@entry=QMetaObject::InvokeMetaMethod) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:1569
#23 0x00007fe11e57401a in CallOverloaded (callType=<optimized out>, propertyCache=<optimized out>, callArgs=<optimized out>, engine=<optimized out>, data=..., object=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:1645
#24 QV4::QObjectMethod::callInternal (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:2133
#25 0x00007fe11e58f80f in QV4::FunctionObject::call (argc=<optimized out>, argv=<optimized out>, thisObject=<optimized out>, this=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4functionobject_p.h:172
#26 QV4::Moth::VME::interpret (frame=0x7ffdb09b01f0, engine=0x55f29b7e2390, code=0x7fe0df2c0698 "\200\265(\307\340\177") at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:754
#27 0x00007fe11e592337 in QV4::Moth::VME::exec (frame=frame@entry=0x7ffdb09b01f0, engine=engine@entry=0x55f29b7e2390) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:463
#28 0x00007fe11e52db8d in QV4::Function::call (this=this@entry=0x55f29a6621c0, thisObject=<optimized out>, argv=argv@entry=0x7fe0df2c0630, argc=<optimized out>, context=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4function.cpp:69
#29 0x00007fe11e6a4a75 in QQmlJavaScriptExpression::evaluate (this=this@entry=0x55f29b7bbf50, callData=callData@entry=0x7fe0df2c0600, isUndefined=isUndefined@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:212
#30 0x00007fe11e658c3b in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#31 0x00007fe11e659120 in QQmlBoundSignal_callback (e=0x55f29a5ed670, a=0x7ffdb09b20a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#32 0x00007fe11e68885d in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=0x7ffdb09b20a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:104
#33 0x00007fe11f69a3f5 in doActivate<false> (sender=0x55f29d439cc0, signal_index=21, argv=argv@entry=0x7ffdb09b20a0) at kernel/qobject.cpp:3778
#34 0x00007fe11f693ddd in QMetaObject::activate (sender=<optimized out>, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=argv@entry=0x7ffdb09b20a0) at kernel/qobject.cpp:3959
#35 0x00007fe11e634f85 in QQmlVMEMetaObject::activate (this=this@entry=0x55f29a5690f0, object=<optimized out>, index=index@entry=25, args=args@entry=0x7ffdb09b20a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:1312
#36 0x00007fe11e63770f in QQmlVMEMetaObject::metaCall (this=0x55f29a5690f0, o=<optimized out>, c=QMetaObject::InvokeMetaMethod, _id=25, a=0x7ffdb09b20a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:969
#37 0x00007fe11e688dad in QQmlObjectOrGadget::metacall (this=this@entry=0x7ffdb09b2330, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=25, argv=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlobjectorgadget.cpp:51
#38 0x00007fe11e5721ce in CallMethod (callType=<optimized out>, callArgs=0x7ffdb09b2330, engine=<optimized out>, argTypes=<optimized out>, argCount=<optimized out>, returnType=<optimized out>, index=<optimized out>, object=...) at /usr/include/qt5/QtCore/qvarlengtharray.h:201
#39 CallPrecise (object=..., data=..., engine=engine@entry=0x55f29b7e2390, callArgs=callArgs@entry=0x7fe0df2c0598, callType=callType@entry=QMetaObject::InvokeMetaMethod) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:1569
#40 0x00007fe11e57401a in CallOverloaded (callType=<optimized out>, propertyCache=<optimized out>, callArgs=<optimized out>, engine=<optimized out>, data=..., object=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:1645
#41 QV4::QObjectMethod::callInternal (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:2133
#42 0x00007fe11e58f80f in QV4::FunctionObject::call (argc=<optimized out>, argv=<optimized out>, thisObject=<optimized out>, this=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4functionobject_p.h:172
#43 QV4::Moth::VME::interpret (frame=0x7ffdb09b25f0, engine=0x55f29b7e2390, code=0x7fe0df2c0538 " v(\307\340\177") at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:754
#44 0x00007fe11e592337 in QV4::Moth::VME::exec (frame=frame@entry=0x7ffdb09b25f0, engine=engine@entry=0x55f29b7e2390) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:463
#45 0x00007fe11e52db8d in QV4::Function::call (this=this@entry=0x55f29a3bf290, thisObject=<optimized out>, argv=argv@entry=0x7fe0df2c0500, argc=<optimized out>, context=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/jsruntime/qv4function.cpp:69
#46 0x00007fe11e6a4a75 in QQmlJavaScriptExpression::evaluate (this=this@entry=0x55f29d0522d0, callData=callData@entry=0x7fe0df2c04d0, isUndefined=isUndefined@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:212
#47 0x00007fe11e658c3b in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#48 0x00007fe11e659120 in QQmlBoundSignal_callback (e=0x55f29d051ac0, a=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#49 0x00007fe11e68885d in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:104
#50 0x00007fe11f69a3f5 in doActivate<false> (sender=0x55f29c9ce6a0, signal_index=64, argv=0x0) at kernel/qobject.cpp:3778
#51 0x00007fe119b00151 in QQuickAbstractButtonPrivate::handleRelease (this=0x55f29c9ce760, point=...) at qquickabstractbutton.cpp:182
#52 0x00007fe119b1a485 in QQuickControl::mouseReleaseEvent (this=<optimized out>, event=0x7ffdb09b4670) at qquickcontrol.cpp:2151
#53 0x00007fe11eab08d8 in QQuickItem::event (this=0x55f29c9ce6a0, ev=0x7ffdb09b4670) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/quick/items/qquickitem.cpp:8189
#54 0x00007fe12030250f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55f29c9ce6a0, e=0x7ffdb09b4670) at kernel/qapplication.cpp:3632
#55 0x00007fe11f66428a in QCoreApplication::notifyInternal2 (receiver=0x55f29c9ce6a0, event=0x7ffdb09b4670) at kernel/qcoreapplication.cpp:1063
#56 0x00007fe11eacc864 in QQuickWindowPrivate::deliverMouseEvent (this=this@entry=0x55f29b65b6b0, pointerEvent=0x7fe114006550) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/quick/items/qquickwindow.cpp:2020
#57 0x00007fe11eacdb9b in QQuickWindowPrivate::deliverPointerEvent (this=0x55f29b65b6b0, event=0x7fe114006550) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/quick/items/qquickwindow.cpp:2612
#58 0x00007fe11fbcadd5 in QWindow::event (this=0x55f29b7c7670, ev=<optimized out>) at kernel/qwindow.cpp:2438
#59 0x00007fe12030250f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55f29b7c7670, e=0x7ffdb09b4670) at kernel/qapplication.cpp:3632
#60 0x00007fe11f66428a in QCoreApplication::notifyInternal2 (receiver=0x55f29b7c7670, event=0x7ffdb09b4670) at kernel/qcoreapplication.cpp:1063
#61 0x00007fe11fbbeb73 in QGuiApplicationPrivate::processMouseEvent (e=0x55f29b5b0dc0) at kernel/qguiapplication.cpp:2282
#62 0x00007fe11fb94c5c in QWindowSystemInterface::sendWindowSystemEvents (flags=flags@entry=...) at kernel/qwindowsysteminterface.cpp:1169
#63 0x00007fe11a8defaa in xcbSourceDispatch (source=<optimized out>) at qxcbeventdispatcher.cpp:105
#64 0x00007fe11d278cf7 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#65 0x00007fe11d279078 in ?? () from /usr/lib64/libglib-2.0.so.0
#66 0x00007fe11d27912f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#67 0x00007fe11f6bb7df in QEventDispatcherGlib::processEvents (this=0x55f299c52150, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#68 0x00007fe11f662c4b in QEventLoop::exec (this=this@entry=0x7ffdb09b49a0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#69 0x00007fe11f66aec0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#70 0x00007fe11fbb21bc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#71 0x00007fe120302485 in QApplication::exec () at kernel/qapplication.cpp:2824
#72 0x000055f298542003 in main (argc=<optimized out>, argv=0x7ffdb09b4ac0) at /usr/src/debug/systemsettings5-5.20.4-1.1.x86_64/app/main.cpp:209
[Inferior 1 (process 20099) detached]

Possible duplicates by query: bug 429886, bug 404056.

Reported using DrKonqi
Comment 1 Nate Graham 2020-12-16 21:42:28 UTC

*** This bug has been marked as a duplicate of bug 429442 ***