Bug 430266 - No thumbnails for video files since 20.12.0
Summary: No thumbnails for video files since 20.12.0
Status: RESOLVED FIXED
Alias: None
Product: kio-extras
Classification: Frameworks and Libraries
Component: Thumbnails and previews (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: HI normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 431397 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-11 16:13 UTC by Philippe ROUBACH
Modified: 2021-05-13 21:35 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2020-12-11 16:13:33 UTC
SUMMARY


STEPS TO REPRODUCE
1. with dolphin go to a folder containing mp4 added after updating to 20.12.0
2. 
3. 

OBSERVED RESULT


thumbnail preview for mp4 movies are not created

EXPECTED RESULT

thumbnail preview for mp4 movies are created

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

jde apps 20.12.0
Comment 1 Nate Graham 2020-12-11 16:14:53 UTC
Do you have the ffmpegthumbs package installed?
Comment 2 Philippe ROUBACH 2020-12-11 16:21:43 UTC
For many years i used this feature. So all necessary packages are installed. Just before updating to 20.12.0 there was no problem.
Comment 3 Nate Graham 2020-12-11 16:24:14 UTC
I'm asking because there is a chance it might have gotten uninstalled. Can you verify that it is still installed?
Comment 4 Philippe ROUBACH 2020-12-11 16:25:18 UTC
(In reply to Nate Graham from comment #3)
> I'm asking because there is a chance it might have gotten uninstalled. Can
> you verify that it is still installed?

yes i check this
Comment 5 Philippe ROUBACH 2020-12-11 16:26:03 UTC
yes i checked this
Comment 6 Nate Graham 2020-12-11 16:43:18 UTC
Hmm.

In Dolphin Settings > General > Previews, is there a list item with the text "Video Files (ffmpegthumbs)"> If so, it is checked?

Also, what is the value of the spinbox for "Skip previews for local files above:" on that same page?
Comment 7 Philippe ROUBACH 2020-12-11 17:07:07 UTC
(In reply to Nate Graham from comment #6)
> Hmm.
> 
> In Dolphin Settings > General > Previews, is there a list item with the text
> "Video Files (ffmpegthumbs)"> If so, it is checked?
> 
yes

> Also, what is the value of the spinbox for "Skip previews for local files
> above:" on that same page?

"no limit"
Comment 8 Philippe ROUBACH 2020-12-11 17:12:11 UTC
I made an error.

There is no more thumbnail for any mp4, ts files old or new.

There is an icon with movie thumbnails for each folder icon.
Comment 9 Nate Graham 2020-12-11 19:37:56 UTC
How odd. Thanks for the information.
Comment 10 Philippe ROUBACH 2020-12-12 18:17:50 UTC
i found someone added a new feature about video file preview thumbnail.

see 

https://bugs.kde.org/show_bug.cgi?id=408956


sam. 14 nov. 2020 13:00:00 CET
Christophe Giboudeaux <christophe@krop.fr>
- Update to 20.11.80
  * New feature release
- Changes since 20.08.3:
  * Remove explicit ECM_KDE_MODULE_DIR
  * remove deprecated/unnecessary call
  * register our own log handler for ffmpeg using QLoggingCategory
  * Add missing REQUIRED keyword for Taglib
  * Use embedded cover in MP4 video files (kde#408956)
Comment 11 Philippe ROUBACH 2020-12-13 07:01:51 UTC
Today a new fact. 
No more thumbnail preview for folder icon for folder containing movies.

KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77
Qt Version: 5.15.2
kde apps 20.12.0
Comment 12 Ilya Bizyaev 2020-12-16 17:32:34 UTC
Same here, no more MP4 thumbnails with 20.12.
Comment 13 Philippe ROUBACH 2021-01-07 16:51:45 UTC
kde apps 20.12.1 << new
plasma 5.20.5 << new
kde frameworks 5.77.0 << new
qt 5.15.2

problem still there
Comment 14 Philippe ROUBACH 2021-01-10 14:39:11 UTC
problem also with ts, mov, flv movie file
Comment 15 Ilya Bizyaev 2021-01-10 14:45:31 UTC
And I noticed MKV files are also affected.
Comment 16 Nate Graham 2021-01-12 01:01:17 UTC
*** Bug 431397 has been marked as a duplicate of this bug. ***
Comment 17 Philippe ROUBACH 2021-02-18 07:51:09 UTC
Hello 

Problem still there with :

kde apps 2012.2
kde plasma 5.21.0
kde frameworks 5.79.0
qt 5.15.2

I manage many videos. I discovered with this bug that viewing a thumbnail preview is an important help when searching a video. It's very difficult to find any video.
Comment 18 Philippe ROUBACH 2021-04-22 15:45:59 UTC
kde gear 21.04.0
plasma 5.21.4
frameworks 5.81.0
qt 5.15.2

Problem still there
Comment 19 Weng Xuetian 2021-04-24 01:41:07 UTC
I just checked this on Archlinux.

The necessary package for me to get it working is ffmpegthumbs-21.04.0-1, and I also need to manually enable it in doplhin. After that it just works.

Since the report is about opensuse and the only release provides 20.12 in opensuse is tumbleweed, so I just go ahead and try that in the VM and downloaded some random mp4 file. And here's what I found.

The error reported in dolphin is "Could not find video stream", so indeed there some error happens. After further investigation, I installed ffmpeg command line to and try to decode mp4 file manually and ffmpeg gives me error for not having h264 decoder. So I think your problem is the ffmpeg build doesn't have relevant codec support.

I browsed opensuse repo on pkgs.org and older version of opensuse (15.2) does have libx264 but it's removed in tumbleweed.

I also tried ffmpeg in Packman repository which is built with libx264 support. After installing that, dolphin thumbnail just starts to work in opensuse tumbleweed.

So I think it's just a packaging issue. 
I think libx264 is removed from opensuse due to patent, FYI: https://en.opensuse.org/SDB:Firefox_MP4/H.264_Video_Support
Comment 20 Philippe ROUBACH 2021-04-24 07:11:21 UTC
Hello thanks for your work.

I have no problem with Chrome 90.0 or VLC 3.12 to play mp4 videos.

I get no problem with firefox 88.0 from mozilla.org.

I can play .mp4 file with the player in the data panel.

I get no problem with digikam movie preview.

I get the problem with Firefox 87.x and 88.0 from download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/


I checked that all packages from Packman replace system packages.

I checked that ffmpegthumbs is enabled with no limit in dolphin preview settings.

Problem still there.

How do you explain I get this problem with .flv, .mkv, .mov, .ts files ? Are they just containers with mp4 video part ?

Thanks
Comment 21 Ilya Bizyaev 2021-04-24 07:30:22 UTC
> not having h264 decoder. So I think your problem is the ffmpeg build doesn't have relevant codec support.
Happens for any video files, not just h264-encoded.

>older version of opensuse (15.2) does have libx264 but it's removed in tumbleweed
I have the same bug on 15.2.

> ffmpeg in Packman repository which is built with libx264 support
With Packman enabled.

This is not a packaging change in openSUSE, but a 20.12 regression. The offending commit, as noted above, is most likely https://invent.kde.org/multimedia/ffmpegthumbs/commit/d2ab28b9a4bcc8270ae0e0995710384eec4d46dc
Comment 22 Philippe ROUBACH 2021-04-24 07:37:13 UTC
thus, my hypothesis in comment #10 would be good.
Comment 23 Weng Xuetian 2021-04-24 07:46:02 UTC
Since can be made to work on some system with given version, it is less likely to be a bug in the package but more likely to be either your system has some misconfiguration or packaging issue. 

Here's the things I suggest to be checked :
1. Check if dolphin has the video thumbnailer enabled
2. I'm not sure what's your repo setup, leap 15.2 doesn't have 20.12 so are you using mixed packages or additional 3rd party repo?
you may want to check carefully if everything matches expectation, and also list all the relevant packages version installed on your system, including libx264, all relevant libav* packages and ffmpegthumbs.

3. While I think it's unlikely to get broken linkage on rpm based system, what is your output of
ldd /usr/lib64/qt5/plugins/ffmpegthumbs.so 
does it show anything "not found"?

When you run dolphin from the command line, does it give any error that seems related to "video" or "stream"?
Comment 24 Philippe ROUBACH 2021-04-24 08:00:56 UTC
1.

in my comment #20 i said

I checked that all packages from Packman replace system packages.

I checked that ffmpegthumbs is enabled with no limit in dolphin preview settings.

2.

i use openSuse 15.2 Argon (an openSuse with latest kde as Kde Neon but with openSuse)

https://en.opensuse.org/SDB:Argon_and_Krypton

3. 

ldd /usr/lib64/qt5/plugins/ffmpegthumbs.so 
        linux-vdso.so.1 (0x00007fffcb48b000)
        libKF5KIOWidgets.so.5 => /usr/lib64/libKF5KIOWidgets.so.5 (0x00007fed8c82c000)
        libavutil.so.55 => /usr/lib64/libavutil.so.55 (0x00007fed8c5b0000)
        libavfilter.so.6 => /usr/lib64/libavfilter.so.6 (0x00007fed8c143000)
        libavformat.so.57 => /usr/lib64/libavformat.so.57 (0x00007fed8bd36000)
        libavcodec.so.57 => /usr/lib64/libavcodec.so.57 (0x00007fed8a82f000)
        libswscale.so.4 => /usr/lib64/libswscale.so.4 (0x00007fed8a5aa000)
        libtag.so.1 => /usr/lib64/libtag.so.1 (0x00007fed8a2b9000)
        libKF5I18n.so.5 => /usr/lib64/libKF5I18n.so.5 (0x00007fed8a068000)
        libKF5ConfigGui.so.5 => /usr/lib64/libKF5ConfigGui.so.5 (0x00007fed89e47000)
        libKF5ConfigCore.so.5 => /usr/lib64/libKF5ConfigCore.so.5 (0x00007fed89bde000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007fed89323000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007fed88a0d000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007fed88248000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fed87e6e000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fed87b36000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fed8777b000)
        libKF5KIOGui.so.5 => /usr/lib64/libKF5KIOGui.so.5 (0x00007fed87541000)
        libKF5KIOCore.so.5 => /usr/lib64/libKF5KIOCore.so.5 (0x00007fed871a9000)
        libKF5JobWidgets.so.5 => /usr/lib64/libKF5JobWidgets.so.5 (0x00007fed86f72000)
        libKF5Service.so.5 => /usr/lib64/libKF5Service.so.5 (0x00007fed86cc7000)
        libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5 (0x00007fed8690d000)
        libKF5Completion.so.5 => /usr/lib64/libKF5Completion.so.5 (0x00007fed866d2000)
        libKF5IconThemes.so.5 => /usr/lib64/libKF5IconThemes.so.5 (0x00007fed86492000)
        libKF5ConfigWidgets.so.5 => /usr/lib64/libKF5ConfigWidgets.so.5 (0x00007fed8622c000)
        libattr.so.1 => /lib64/libattr.so.1 (0x00007fed86027000)
        libKF5WidgetsAddons.so.5 => /usr/lib64/libKF5WidgetsAddons.so.5 (0x00007fed85cc5000)
        libQt5DBus.so.5 => /usr/lib64/libQt5DBus.so.5 (0x00007fed85a32000)
        libKF5CoreAddons.so.5 => /usr/lib64/libKF5CoreAddons.so.5 (0x00007fed8578a000)
        libvdpau.so.1 => /usr/lib64/libvdpau.so.1 (0x00007fed85586000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fed85245000)
        libva.so.2 => /usr/lib64/libva.so.2 (0x00007fed85021000)
        libva-x11.so.2 => /usr/lib64/libva-x11.so.2 (0x00007fed84e1b000)
        libva-drm.so.2 => /usr/lib64/libva-drm.so.2 (0x00007fed84c18000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fed84a10000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fed8480c000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fed845ed000)
        libavresample.so.3 => /usr/lib64/libavresample.so.3 (0x00007fed843ce000)
        libpostproc.so.54 => /usr/lib64/libpostproc.so.54 (0x00007fed841b6000)
        libswresample.so.2 => /usr/lib64/libswresample.so.2 (0x00007fed83f9a000)
        libass.so.9 => /usr/lib64/libass.so.9 (0x00007fed83d67000)
        libzimg.so.2 => /usr/lib64/libzimg.so.2 (0x00007fed83aa6000)
        libvidstab.so.1.1 => /usr/lib64/libvidstab.so.1.1 (0x00007fed83892000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fed835d8000)
        libbluray.so.2 => /usr/lib64/libbluray.so.2 (0x00007fed83387000)
        libgnutls.so.30 => /usr/lib64/libgnutls.so.30 (0x00007fed82fcf000)
        libbz2.so.1 => /usr/lib64/libbz2.so.1 (0x00007fed82db2000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fed82b9b000)
        libwebp.so.7 => /usr/lib64/libwebp.so.7 (0x00007fed8292c000)
        libzvbi.so.0 => /usr/lib64/libzvbi.so.0 (0x00007fed8269d000)
        libxvidcore.so.4 => /usr/lib64/libxvidcore.so.4 (0x00007fed8238a000)
        libx265.so.192 => /usr/lib64/libx265.so.192 (0x00007fed81204000)
        libx264.so.161 => /usr/lib64/libx264.so.161 (0x00007fed80d5f000)
        libwebpmux.so.3 => /usr/lib64/libwebpmux.so.3 (0x00007fed80b55000)
        libvpx.so.4 => /usr/lib64/libvpx.so.4 (0x00007fed807ce000)
        libvorbisenc.so.2 => /usr/lib64/libvorbisenc.so.2 (0x00007fed80525000)
        libvorbis.so.0 => /usr/lib64/libvorbis.so.0 (0x00007fed802f8000)
        libtwolame.so.0 => /usr/lib64/libtwolame.so.0 (0x00007fed800d4000)
        libtheoraenc.so.1 => /usr/lib64/libtheoraenc.so.1 (0x00007fed7fe95000)
        libtheoradec.so.1 => /usr/lib64/libtheoradec.so.1 (0x00007fed7fc7b000)
        libspeex.so.1 => /usr/lib64/libspeex.so.1 (0x00007fed7fa60000)
        libopus.so.0 => /usr/lib64/libopus.so.0 (0x00007fed7f801000)
        libopenjp2.so.7 => /usr/lib64/libopenjp2.so.7 (0x00007fed7f5af000)
        libopencore-amrwb.so.0 => /usr/lib64/libopencore-amrwb.so.0 (0x00007fed7f39c000)
        libopencore-amrnb.so.0 => /usr/lib64/libopencore-amrnb.so.0 (0x00007fed7f173000)
        libmp3lame.so.0 => /usr/lib64/libmp3lame.so.0 (0x00007fed7eefb000)
        libgsm.so.1 => /usr/lib64/libgsm.so.1 (0x00007fed7ecef000)
        libcelt0.so.2 => /usr/lib64/libcelt0.so.2 (0x00007fed7ead7000)
        liblzma.so.5 => /usr/lib64/liblzma.so.5 (0x00007fed7e89d000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fed7e684000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007fed7e3ec000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007fed7e1a9000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007fed7dea0000)
        libsystemd.so.0 => /usr/lib64/libsystemd.so.0 (0x00007fed7dc0a000)
        libdouble-conversion.so.3 => /usr/lib64/libdouble-conversion.so.3 (0x00007fed7d9fc000)
        libicui18n.so.suse65.1 => /usr/lib64/libicui18n.so.suse65.1 (0x00007fed7d50a000)
        libicuuc.so.suse65.1 => /usr/lib64/libicuuc.so.suse65.1 (0x00007fed7d12b000)
        libpcre2-16.so.0 => /usr/lib64/libpcre2-16.so.0 (0x00007fed7ceb4000)
        libzstd.so.1 => /usr/lib64/libzstd.so.1 (0x00007fed7cc12000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007fed7c8ed000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fed8cd97000)
        libKF5WindowSystem.so.5 => /usr/lib64/libKF5WindowSystem.so.5 (0x00007fed7c69a000)
        libQt5Xml.so.5 => /usr/lib64/libQt5Xml.so.5 (0x00007fed7c458000)
        libKF5Crash.so.5 => /usr/lib64/libKF5Crash.so.5 (0x00007fed7c250000)
        libKF5DBusAddons.so.5 => /usr/lib64/libKF5DBusAddons.so.5 (0x00007fed7c03a000)
        libKF5AuthCore.so.5 => /usr/lib64/libKF5AuthCore.so.5 (0x00007fed7be1f000)
        libacl.so.1 => /lib64/libacl.so.1 (0x00007fed7bc16000)
        libQt5X11Extras.so.5 => /usr/lib64/libQt5X11Extras.so.5 (0x00007fed7ba11000)
        libproxy.so.1 => /usr/lib64/libproxy.so.1 (0x00007fed7b7f4000)
        libssl.so.1.1 => /usr/lib64/libssl.so.1.1 (0x00007fed7b565000)
        libcrypto.so.1.1 => /usr/lib64/libcrypto.so.1.1 (0x00007fed7b07f000)
        libQt5Svg.so.5 => /usr/lib64/libQt5Svg.so.5 (0x00007fed7ae23000)
        libKF5Archive.so.5 => /usr/lib64/libKF5Archive.so.5 (0x00007fed7abe6000)
        libKF5ItemViews.so.5 => /usr/lib64/libKF5ItemViews.so.5 (0x00007fed7a9ad000)
        libKF5Codecs.so.5 => /usr/lib64/libKF5Codecs.so.5 (0x00007fed7a773000)
        libKF5GuiAddons.so.5 => /usr/lib64/libKF5GuiAddons.so.5 (0x00007fed7a552000)
        libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007fed7a300000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fed7a0ee000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fed79ec5000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007fed79cbf000)
        libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007fed79aad000)
        libfribidi.so.0 => /usr/lib64/libfribidi.so.0 (0x00007fed79891000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007fed7964c000)
        libgomp.so.1 => /usr/lib64/libgomp.so.1 (0x00007fed7940b000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fed790a2000)
        libp11-kit.so.0 => /usr/lib64/libp11-kit.so.0 (0x00007fed78e3f000)
        libidn2.so.0 => /usr/lib64/libidn2.so.0 (0x00007fed78c22000)
        libunistring.so.2 => /usr/lib64/libunistring.so.2 (0x00007fed788a0000)
        libtasn1.so.6 => /usr/lib64/libtasn1.so.6 (0x00007fed7868d000)
        libnettle.so.6 => /usr/lib64/libnettle.so.6 (0x00007fed78454000)
        libhogweed.so.4 => /usr/lib64/libhogweed.so.4 (0x00007fed7821c000)
        libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007fed77f86000)
        libnuma.so.1 => /usr/lib64/libnuma.so.1 (0x00007fed77d7a000)
        libogg.so.0 => /usr/lib64/libogg.so.0 (0x00007fed77b73000)
        libGLX.so.0 => /usr/lib64/libGLX.so.0 (0x00007fed77941000)
        libGLdispatch.so.0 => /usr/lib64/libGLdispatch.so.0 (0x00007fed77685000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007fed7745f000)
        libselinux.so.1 => /lib64/libselinux.so.1 (0x00007fed77236000)
        libcap.so.2 => /usr/lib64/libcap.so.2 (0x00007fed77031000)
        liblz4.so.1 => /usr/lib64/liblz4.so.1 (0x00007fed76e1c000)
        libgcrypt.so.20 => /usr/lib64/libgcrypt.so.20 (0x00007fed76afe000)
        libicudata.so.suse65.1 => /usr/lib64/libicudata.so.suse65.1 (0x00007fed768fd000)
        libpcre.so.1 => /usr/lib64/libpcre.so.1 (0x00007fed76672000)
        libxcb-keysyms.so.1 => /usr/lib64/libxcb-keysyms.so.1 (0x00007fed7646f000)
        libmodman.so.1 => /usr/lib64/libmodman.so.1 (0x00007fed76267000)
        libQt5WaylandClient.so.5 => /usr/lib64/libQt5WaylandClient.so.5 (0x00007fed75f0a000)
        libwayland-client.so.0 => /usr/lib64/libwayland-client.so.0 (0x00007fed75cfa000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fed75af6000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007fed758c4000)
        libffi.so.7 => /usr/lib64/libffi.so.7 (0x00007fed756ba000)
        libgpg-error.so.0 => /usr/lib64/libgpg-error.so.0 (0x00007fed7549a000)
        libwayland-cursor.so.0 => /usr/lib64/libwayland-cursor.so.0 (0x00007fed75292000)
        libxkbcommon.so.0 => /usr/lib64/libxkbcommon.so.0 (0x00007fed75052000)
4.

I tired to disable/enable preview

:~> dolphin
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Comment 25 Ilya Bizyaev 2021-04-24 08:04:27 UTC
> 1. Check if dolphin has the video thumbnailer enabled
Yes, the update does not seem to have influenced my configuration.

> 2. I'm not sure what's your repo setup, leap 15.2 doesn't have 20.12 so are
> you using mixed packages or additional 3rd party repo?
I use KDE stable repositories for openSUSE: https://en.opensuse.org/SDB:KDE_repositories

> you may want to check carefully if everything matches expectation, and also
> list all the relevant packages version installed on your system, including
> libx264, all relevant libav* packages and ffmpegthumbs.
ffmpegthumbs 21.03.90
libx264-160 0.160+git20200702 (Packman)
libx264-161 0.160+git20200912 (Packman)
libavcodec57, libavdevice57, libavfilter6, libavformat57, libavresample3, libavutil55 3.4.8 (Packman)
libavcodec58, libavdevice58, libavfilter7, libavformat58, libavresample4, libavutil56 4.2.1 (Packman)


> 3. While I think it's unlikely to get broken linkage on rpm based system,
> what is your output of
> ldd /usr/lib64/qt5/plugins/ffmpegthumbs.so 
> does it show anything "not found"?
Nope, all the libraries are there.

> When you run dolphin from the command line, does it give any error that
> seems related to "video" or "stream"?
No, it is silent.
Comment 26 Philippe ROUBACH 2021-04-24 09:15:21 UTC
1. Here is all [Peviewsettings] I found in ~/.config/ folder

1.1. dolphinrc

[PreviewSettings]
Plugins=kraorathumbnail,opendocumentthumbnail,marble_thumbnail_gpx,directorythumbnail,textthumbnail,ffmpegthumbs,mobithumbnail,gsthumbnail,rawthumbnail,imagethumbnail,jpegthumbnail,svgthumbnail,ebookthumbnail


1.2. kdeglobals

[PreviewSettings]
MaximumRemoteSize=0


1.3. khotkeysrc

[PreviewSettings]
camera[$d]
file[$d]
fonts[$d]

1.4. kwinrules

[PreviewSettings]
camera[$d]
file[$d]
fonts[$d]

2. I found another kdeglobals in ~/.kde4/share/config/ folder

3. I found another kdeglobals in ~/.kde/share/config/ folder

Is all of this normal ?
Comment 27 Philippe ROUBACH 2021-04-24 09:46:25 UTC
I extract with no problem an icon from a mp4 video

ffmpeg -i file.mp4 -vf  "thumbnail,scale=640:360" -frames:v 1 thumb.png 
   
ffmpeg version 3.4.8 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 7 (SUSE Linux)
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --incdir=/usr/include/ffmpeg --extra-cflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g' --optflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g' --disable-htmlpages --enable-pic --disable-stripping --enable-shared --disable-static --enable-gpl --disable-openssl --enable-avresample --enable-libcdio --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libcelt --enable-libcdio --enable-libdc1394 --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libzimg --enable-libzvbi --enable-vaapi --enable-vdpau --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-libx264 --enable-libx265 --enable-libxvid
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libavresample   3.  7.  0 /  3.  7.  0
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'file.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    title           : CLIP PHARAMOND 1957
    encoder         : Lavf58.20.100
  Duration: 00:01:40.15, start: 0.000000, bitrate: 669 kb/s
    Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 640x480 [SAR 1:1 DAR 4:3], 533 kb/s, 30 fps, 30 tbr, 15360 tbn, 60 tbc (default)
    Metadata:
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 128 kb/s (default)
    Metadata:
      handler_name    : SoundHandler
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> png (native))
Press [q] to stop, [?] for help
Output #0, image2, to 'thumb.png':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    title           : CLIP PHARAMOND 1957
    encoder         : Lavf57.83.100
    Stream #0:0(und): Video: png, rgb24, 640x360 [SAR 3:4 DAR 4:3], q=2-31, 200 kb/s, 30 fps, 30 tbn, 30 tbc (default)
    Metadata:
      handler_name    : VideoHandler
      encoder         : Lavc57.107.100 png
[Parsed_thumbnail_0 @ 0x561bac0fbe20] frame id #52 (pts_time=1.733333) selected from a set of 100 images
frame=    1 fps=0.0 q=-0.0 Lsize=N/A time=00:00:00.03 bitrate=N/A dup=1 drop=1 speed=0.135x    
video:263kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
Comment 28 Philippe ROUBACH 2021-04-24 11:38:35 UTC
There were never any problem till the update from kde gear 20.08 to 20.12.0.
Comment 29 Philippe ROUBACH 2021-04-24 12:57:03 UTC
I get also the same problem with all my mpeg-2-ts video files
Comment 30 Weng Xuetian 2021-04-25 21:13:23 UTC
Git commit 26c1d3b790d621f89cf1cbf56bdc0b8c97a95151 by Weng Xuetian.
Committed on 25/04/2021 at 21:12.
Pushed by xuetianweng into branch 'release/21.04'.

Restore the compatiblity with ffmpeg 3.

M  +4    -0    ffmpegthumbnailer/moviedecoder.cpp

https://invent.kde.org/multimedia/ffmpegthumbs/commit/26c1d3b790d621f89cf1cbf56bdc0b8c97a95151
Comment 31 Weng Xuetian 2021-04-25 21:19:10 UTC
Thanks for the information.

I installed leap 15.2 for testing. The issue is removing a call to API deprecated in ffmpeg 4, while the call is necessary for ffmpeg 3 used by 15.2's ffmpegthumbs.

I restored the call when compiling ffmpegthumbs with ffmpeg 3. The fix should be picked by the next release 21.04.1.
Comment 32 Philippe ROUBACH 2021-04-25 21:22:41 UTC
(In reply to Weng Xuetian from comment #31)


Thanks. I am impatient to test it.
Comment 33 Ilya Bizyaev 2021-04-25 21:40:29 UTC
Thank you for investigating this! :)
Comment 34 Ilya Bizyaev 2021-05-13 16:00:07 UTC
This fix is now in the repositories, I can confirm that it works for me :)
Comment 35 Philippe ROUBACH 2021-05-13 21:35:20 UTC
no more problem