Bug 430135 - KDE Partition manager creates unusable external drives (accessible only by root account)
Summary: KDE Partition manager creates unusable external drives (accessible only by ro...
Status: RESOLVED DUPLICATE of bug 407192
Alias: None
Product: partitionmanager
Classification: Unclassified
Component: general (show other bugs)
Version: 4.1.0
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Andrius Štikonas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-08 02:07 UTC by leftcrane
Modified: 2020-12-08 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description leftcrane 2020-12-08 02:07:01 UTC
SUMMARY


STEPS TO REPRODUCE
1. open it
2. create a partition table and partition ext4
3. open drive in file manager
4. try to move a file to the drive, it's impossible.

OBSERVED RESULT

can't write to drive via file manager (unless you're using using acient software that allows opening gui as root)


EXPECTED RESULT

should be able to write to drive without root access, or at least have a gui option to create a writable drive. Otherwise, what is even the point of the GUI if you have to drop to the CLI to change permissions?

no root as default makes more sense, since root access for a removable drive makes absolutely no sense. I think Gnome Disks has sane behavior in this regard.
Comment 1 Nate Graham 2020-12-08 16:11:49 UTC

*** This bug has been marked as a duplicate of bug 407192 ***