Bug 429790 - Brush outline renders in a discrete "snapped" manner
Summary: Brush outline renders in a discrete "snapped" manner
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 4.4.1
Platform: Debian unstable Linux
: NOR minor
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-29 03:52 UTC by Nabil Maghfur usman
Modified: 2020-12-02 08:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nabil Maghfur usman 2020-11-29 03:52:12 UTC
SUMMARY
Appears similar to https://krita-artists.org/t/brush-is-lagging-glitching/14895 but I'm unsure if it's the same bug.

My bug seems to only be reproducible with the following very specific steps and conditions, so it's easy to avoid this bug. These instructions assume you have a clean default krita installation.

STEPS TO REPRODUCE
1. Start Krita
2. Press Ctrl+N for a new document, any document size will do.
3. Press "1" to set zoom to 100% of the current document
4. Move your cursor around and observe where/how the brush outline renders
5. Press Ctrl+N for a new document again. This time make it significantly larger than the viewport's size (eg A3 300ppi, maybe A3 600ppi if you have an outlandishly large monitor)
6. Ctrl+Tab to switch back to the previous document
7. Move your cursor around and observe where/how the brush outline renders

OBSERVED RESULT
The brush outline gets rendered only at discrete locations aligned with some unknown invisible grid, as if Snap to Grid was enabled for the brush outline.

EXPECTED RESULT
Brush outline should render as smoothly as in step 3.

WORKAROUND

Ctrl+Drag to change the zoom of the current document, even by a couple percent. This will fix the way the brush outline renders and the expected result is observed.

If you Ctrl+Tab to the big document, then Ctrl+Tab again to the first document, the incorrect result is again observed.

SOFTWARE/OS VERSIONS
Krita

 Version: 4.4.1
 Languages: id_ID, id
 Hidpi: true

Qt

  Version (compiled): 5.12.9
  Version (loaded): 5.12.9

OS Information

  Build ABI: x86_64-little_endian-lp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: linux
  Kernel Version: 5.8.0-2-amd64
  Pretty Productname: Debian GNU/Linux bullseye/sid
  Product Type: debian
  Product Version: unknown
  Desktop: GNOME-Classic:GNOME

OpenGL Info
 
  Vendor:  "Intel Open Source Technology Center" 
  Renderer:  "Mesa DRI Intel(R) HD Graphics 4600 (HSW GT2)" 
  Version:  "3.0 Mesa 20.1.9" 
  Shading language:  "1.30" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:    QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions true 
     is OpenGL ES: false 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsOpenGLES: true 
  isQtPreferOpenGLES: false 

Hardware Information

  GPU Acceleration: auto
  Memory: 7843 Mb
  Number of Cores: 8
  Swap Location: /tmp

Current Settings

  Current Swap Location: /tmp
  Current Swap Location writable: true
  Undo Enabled: true
  Undo Stack Limit: 30
  Use OpenGL: true
  Use OpenGL Texture Buffer: true
  Use AMD Vectorization Workaround: false
  Canvas State: OPENGL_SUCCESS
  Autosave Interval: 900
  Use Backup Files: true
  Number of Backups Kept: 1
  Backup File Suffix: ~
  Backup Location: Same Folder as the File
  Backup Location writable: false
  Use Win8 Pointer Input: false
  Use RightMiddleTabletButton Workaround: false
  Levels of Detail Enabled: false
  Use Zip64: false


Display Information
Number of screens: 1
	Screen: 0
		Name: eDP-1
		Depth: 24
		Scale: 1
		Resolution in pixels: 1920x1080
		Manufacturer: 
		Model: 
		Refresh Rate: 59


ADDITIONAL INFORMATION
Comment 1 Ahab Greybeard 2020-11-29 20:24:33 UTC
This is very similar to https://bugs.kde.org/show_bug.cgi?id=427094
which was marked as fixed on 29th Sept 2020.

This needs further testing and investigation.
Comment 2 Ahab Greybeard 2020-11-30 11:29:22 UTC
I see this happening on Debian 10 with the 4.4.1 appimage but it doesn't happen with the Nov 29 4.4.2 alpha (git f8e7b7) appimage.
Can you test that to see what you find?
Comment 3 Nabil Maghfur usman 2020-12-02 05:44:34 UTC
(In reply to Ahab Greybeard from comment #2)
> I see this happening on Debian 10 with the 4.4.1 appimage but it doesn't
> happen with the Nov 29 4.4.2 alpha (git f8e7b7) appimage.
> Can you test that to see what you find?

Can't reproduce on the latest Krita Next appimage as of today, so I suppose there has been a fix for this but it's only on master.
Comment 4 Ahab Greybeard 2020-12-02 08:19:41 UTC
The 4.4.2 alpha has the fix and that will soon go to beta.

Setting to Resolved Fixed