Bug 429750 - Wayland window thumbnail covers right click menu
Summary: Wayland window thumbnail covers right click menu
Status: RESOLVED DUPLICATE of bug 417939
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.20.90
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-28 02:55 UTC by Brian
Modified: 2021-04-24 15:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen_video (514.75 KB, video/x-matroska)
2021-01-30 19:24 UTC, s1994928
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian 2020-11-28 02:55:38 UTC
SUMMARY

Right clicking on a icon-only task manager button so that you can pin an app or do some other action does not work in Wayland because the window thumbnail preview covers the right-click menu. Observed in Arch Linux and KDE Neon User Stable on Wayland.

STEPS TO REPRODUCE
1. Right click a icons-only task manager button
2. Observe the window thumbnail popups covers the right click menu

EXPECTED RESULT
The window thumbnails should not popup if you've right clicked on the window button to access the app pinning and new instance options.


SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.9.10-zen1-1-zen
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-10110U CPU @ 2.10GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
Comment 1 s1994928 2021-01-30 19:24:23 UTC
Created attachment 135309 [details]
screen_video

Can confirm on KDE Plasma 5.20.90
Comment 2 s1994928 2021-01-31 03:52:33 UTC
Since there is no problem in X11, I think component should be kwin (wayland-generic).
Comment 3 Maugre 2021-04-24 15:02:31 UTC
I'll save Nate some work as this is another duplicate of #417939. :)

*** This bug has been marked as a duplicate of bug 417939 ***