Bug 429504 - unable to collect/sync gmail account
Summary: unable to collect/sync gmail account
Status: RESOLVED DOWNSTREAM
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-11-22 14:04 UTC by chris fudge
Modified: 2020-11-23 17:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris fudge 2020-11-22 14:04:49 UTC
Application: akonadi_imap_resource (5.15.3 (20.08.3))

Qt Version: 5.15.1
Frameworks Version: 5.76.0
Operating System: Linux 4.12.14-lp151.28.79-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.1"

-- Information about the crash:
- What I was doing when the application crashed:
started Kontact, opens Kmail and checks for mail at gmail
ok

The crash can be reproduced every time.

-- Backtrace:
Application: Google Mail (c.g.fudge) (akonadi_imap_resource), signal: Aborted

[New LWP 2809]
[New LWP 2832]
[New LWP 2838]
[New LWP 2857]
[New LWP 3438]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
0x00007f199980c6db in poll () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f199f71ae40 (LWP 2792))]

Thread 6 (Thread 0x7f197299f700 (LWP 3438)):
#0  0x00007f19998081d8 in read () at /lib64/libc.so.6
#1  0x00007f1992a23c80 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f19929decb8 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f19929df150 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f19929df2bc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007f199a3fedbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f1960000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f199a39ae9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f197299ec30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#7  0x00007f199a1a4f87 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:547
#8  0x00007f199a1a649c in QThreadPrivate::start(void*) (arg=0x55d50566b780) at thread/qthread_unix.cpp:329
#9  0x00007f19961db4f9 in start_thread () at /lib64/libpthread.so.0
#10 0x00007f1999816fbf in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f19735ef700 (LWP 2857)):
#0  0x00007f199980c6db in poll () at /lib64/libc.so.6
#1  0x00007f19929df1a9 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f19929df2bc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f199a3fedbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f1968000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f199a39ae9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f19735eec30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#5  0x00007f199a1a4f87 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:547
#6  0x00007f199a1a649c in QThreadPrivate::start(void*) (arg=0x55d505641ec0) at thread/qthread_unix.cpp:329
#7  0x00007f19961db4f9 in start_thread () at /lib64/libpthread.so.0
#8  0x00007f1999816fbf in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f1978b49700 (LWP 2838)):
#0  0x00007f199980c6db in poll () at /lib64/libc.so.6
#1  0x00007f19929df1a9 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f19929df2bc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f199a3fedbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f196c000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f199a39ae9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f1978b48c30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#5  0x00007f199a1a4f87 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:547
#6  0x00007f199a1a649c in QThreadPrivate::start(void*) (arg=0x55d5055d4e00) at thread/qthread_unix.cpp:329
#7  0x00007f19961db4f9 in start_thread () at /lib64/libpthread.so.0
#8  0x00007f1999816fbf in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f197976f700 (LWP 2832)):
#0  0x00007f1992a24fd4 in g_mutex_unlock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f19929de6fc in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f19929df0db in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f19929df2bc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f199a3fedbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f1974000b10, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f199a39ae9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f197976ec00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#6  0x00007f199a1a4f87 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:547
#7  0x00007f199c081335 in  () at /usr/lib64/libQt5DBus.so.5
#8  0x00007f199a1a649c in QThreadPrivate::start(void*) (arg=0x7f199c2fa440) at thread/qthread_unix.cpp:329
#9  0x00007f19961db4f9 in start_thread () at /lib64/libpthread.so.0
#10 0x00007f1999816fbf in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f1987576700 (LWP 2809)):
#0  0x00007f199980c6db in poll () at /lib64/libc.so.6
#1  0x00007f199581f307 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f1995820f3a in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f1989f52bc0 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f199a1a649c in QThreadPrivate::start(void*) (arg=0x55d5055160a0) at thread/qthread_unix.cpp:329
#5  0x00007f19961db4f9 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f1999816fbf in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f199f71ae40 (LWP 2792)):
[KCrash Handler]
#4  0x00007f1999754520 in raise () at /lib64/libc.so.6
#5  0x00007f1999755b01 in abort () at /lib64/libc.so.6
#6  0x00007f1999797957 in __libc_message () at /lib64/libc.so.6
#7  0x00007f199982854e in __fortify_fail_abort () at /lib64/libc.so.6
#8  0x00007f1999828512 in  () at /lib64/libc.so.6
#9  0x000055d50403f340 in BatchFetcher::onMessagesAvailable(QMap<long long, KIMAP::Message> const&) (this=0x7f1960038fb0, messages=...) at /usr/src/debug/kdepim-runtime-20.08.3-lp151.238.2.x86_64/resources/imap/batchfetcher.cpp:196
#10 0x00007f199a3d9d27 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7ffd5d0729f0, r=0x7f1960038fb0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#11 0x00007f199a3d9d27 in doActivate<false>(QObject*, int, void**) (sender=0x7f196001c450, signal_index=26, argv=0x7ffd5d0729f0) at kernel/qobject.cpp:3886
#12 0x00007f199a3d31e2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7f199ecb3f60 <KIMAP::FetchJob::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffd5d0729f0) at kernel/qobject.cpp:3946
#13 0x00007f199ea2d2b5 in KIMAP::FetchJob::messagesAvailable(QMap<long long, KIMAP::Message> const&) (this=<optimized out>, _t1=...) at /usr/src/debug/kimap-20.11.80-lp151.182.1.x86_64/build/src/KF5IMAP_autogen/include/moc_fetchjob.cpp:289
#14 0x00007f199ea35ca9 in KIMAP::FetchJobPrivate::emitPendings() (this=0x7f196c0095c0) at /usr/src/debug/kimap-20.11.80-lp151.182.1.x86_64/src/fetchjob.cpp:43
#15 0x00007f199ea30167 in KIMAP::FetchJob::handleResponse(KIMAP::Response const&) (this=0x7f196001c450, response=...) at /usr/src/debug/kimap-20.11.80-lp151.182.1.x86_64/src/fetchjob.cpp:257
#16 0x00007f199ea82ed9 in KIMAP::SessionPrivate::responseReceived(KIMAP::Response const&) (this=0x7f197401e400, response=...) at /usr/src/debug/kimap-20.11.80-lp151.182.1.x86_64/src/session.cpp:289
#17 0x00007f199a3d080b in QObject::event(QEvent*) (this=0x7f197401e400, e=0x7f196001a260) at kernel/qobject.cpp:1314
#18 0x00007f199b6fa30c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x55d50550c7a0, receiver=receiver@entry=0x7f197401e400, e=e@entry=0x7f196001a260) at kernel/qapplication.cpp:3630
#19 0x00007f199b701100 in QApplication::notify(QObject*, QEvent*) (this=0x7ffd5d0732e0, receiver=0x7f197401e400, e=0x7f196001a260) at kernel/qapplication.cpp:3154
#20 0x00007f199a39c613 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x7f197401e400, event=0x7f196001a260) at kernel/qcoreapplication.cpp:1063
#21 0x00007f199a39c7ee in QCoreApplication::sendEvent(QObject*, QEvent*) (receiver=receiver@entry=0x7f197401e400, event=event@entry=0x7f196001a260) at kernel/qcoreapplication.cpp:1458
#22 0x00007f199a39f031 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x55d5054ef1e0) at kernel/qcoreapplication.cpp:1817
#23 0x00007f199a39f5b8 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1676
#24 0x00007f199a3ff6f3 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x55d505588a70) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007f19929dee87 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#26 0x00007f19929df230 in  () at /usr/lib64/libglib-2.0.so.0
#27 0x00007f19929df2bc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#28 0x00007f199a3fed9c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x55d50559a360, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#29 0x00007f199a39ae9a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffd5d073230, flags=..., flags@entry=...) at kernel/qeventloop.cpp:232
#30 0x00007f199a3a4697 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1371
#31 0x00007f199dea38ad in Akonadi::ResourceBase::init(Akonadi::ResourceBase&) (r=...) at /usr/src/debug/akonadi-server-20.08.3-lp151.251.1.x86_64/src/agentbase/resourcebase.cpp:561
#32 0x000055d503fca22f in Akonadi::ResourceBase::init<ImapResource>(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/include/KF5/AkonadiAgentBase/resourcebase.h:186
#33 0x00007f199973f34a in __libc_start_main () at /lib64/libc.so.6
#34 0x000055d503fca0ba in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 2792) detached]

Possible duplicates by query: bug 429420, bug 429344, bug 429243, bug 428714, bug 428691.

Reported using DrKonqi
Comment 1 Wolfgang Bauer 2020-11-23 11:15:48 UTC
I can see in your backtrace that you use kdepim-runtime 20.08.3 and kimap 20.11.80.
This mix of versions is not supported and likely the reason for the crash.

You are also using openSUSE Leap 15.1 with the additional KDE repos where akonadi-server fails to build currently, and that's probably leading to your problem.

Closing as DOWNSTREAM therefore.

As I am an openSUSE packager, I'll look into this though.
Comment 2 Wolfgang Bauer 2020-11-23 17:43:22 UTC
Meanwhile everything has been rebuilt successfully in the openSUSE repos.

So please uodate your system, and the crash should hopefully be gone.
If not, feel free to reopen this bug report, or file a new one.
Thanks.

Btw, the build failure was due to the cmake version (akonadi failed to compile with older versions), and actually fixed in akonadi upstream meanwhile:
https://invent.kde.org/pim/akonadi/-/commit/35c64fc2244821297d512fb5ff15cd342d5150f7
https://invent.kde.org/pim/akonadi/-/commit/0586ae9d4f4fc5ef27b11e6c397f049bbd405e19