Bug 429399 - Colorized buttons mis-color monochrome icons inside of them
Summary: Colorized buttons mis-color monochrome icons inside of them
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Unclassified
Component: general (show other bugs)
Version: 5.76.0
Platform: Other Other
: VHI normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: regression
: 428599 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-20 15:38 UTC by postix
Modified: 2020-12-15 20:53 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (3.10 KB, image/png)
2020-11-20 15:38 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2020-11-20 15:38:27 UTC
Created attachment 133501 [details]
Screenshot

SUMMARY


Please see the screenshot. Can you spot the icon? ;-)


SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Comment 1 Nate Graham 2020-11-20 19:06:14 UTC
Same issue with the Install button, in fact. Seems like a regression in Kirigami's colored button icon coloration.
Comment 2 Marco Martin 2020-11-30 11:16:28 UTC
this is just in qml/kirigami apps?
Comment 3 Nate Graham 2020-11-30 15:47:21 UTC
Yes.
Comment 4 Nate Graham 2020-12-04 14:44:37 UTC
Possibly related to Bug 429972?
Comment 5 Marco Martin 2020-12-09 14:12:54 UTC
the attached screenshot is not really a monochrome icon being mis-colored, but is about the button being colored in a color that conflicts with the delete icon color, which is red (and at the moment we just recolor the black parts of the icons)
Comment 6 Marco Martin 2020-12-09 14:13:56 UTC
to me this suggests that we shouldn't really color the button in this case, but the icon when possible, or have just some kind of decoration of the given color when this is not possible
Comment 7 Bug Janitor Service 2020-12-09 14:31:00 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/184
Comment 8 Marco Martin 2020-12-09 15:08:26 UTC
Git commit fe101efd201255a61e47f387b2aa6d59da829f7c by Marco Martin.
Committed on 09/12/2020 at 15:07.
Pushed by mart into branch 'master'.

Color icons, not buttons

when an icon color is set, it tried to color the button and the icon
causing often ureadable results. now color just the icon but not
the button, giving a less magic behavior. it won't be possible
to color non monochrome icons, but that's kinda expected and should
be an acceptable compromise
Related: bug 429972

M  +2    -2    src/controls/ActionToolBar.qml
M  +0    -6    src/controls/private/PrivateActionToolButton.qml

https://invent.kde.org/frameworks/kirigami/commit/fe101efd201255a61e47f387b2aa6d59da829f7c
Comment 9 Claudius Ellsel 2020-12-15 20:13:17 UTC
Also there is https://bugs.kde.org/show_bug.cgi?id=428599 of which this might be a duplicate? At least it is related.
Comment 10 postix 2020-12-15 20:53:02 UTC
*** Bug 428599 has been marked as a duplicate of this bug. ***