Bug 429264 - kdenlive writes "garbage" to kdenliverc when resizing
Summary: kdenlive writes "garbage" to kdenliverc when resizing
Status: RESOLVED DUPLICATE of bug 429943
Alias: None
Product: kdenlive
Classification: Applications
Component: User Interface (show other bugs)
Version: 20.08.2
Platform: Microsoft Windows Microsoft Windows
: NOR task
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-17 21:20 UTC by microlan101
Modified: 2020-12-07 18:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:
fritzibaby: Brainstorm+


Attachments
copy of my kdenliverc (5.85 KB, text/plain)
2020-11-17 21:20 UTC, microlan101
Details
dbgview logfile (46.49 KB, text/plain)
2020-11-17 21:23 UTC, microlan101
Details

Note You need to log in before you can comment on or make changes to this bug.
Description microlan101 2020-11-17 21:20:33 UTC
Created attachment 133410 [details]
copy of my kdenliverc

SUMMARY
when resizing the window or panels, kdenliverc is filled with "garbage" lines like these:

\\LAY1 \\LAY2 Height 1440=480
\\LAY1 \\LAY2 Width 2560=648

the size and position of the window aren't saved, unless I manually add "Height" and "Width" lines in the rc file.

I rolled back to 20.08.1 and the problem doesn't happen.


STEPS TO REPRODUCE
1. install kdenlive 20.08.2 for windows
2. open it, move the window around, resize some panels
3. open "kdenliverc"

OBSERVED RESULT
"garbage" lines are present, size and position aren't saved.

EXPECTED RESULT
same behavior as 20.08.1
Comment 1 microlan101 2020-11-17 21:23:54 UTC
Created attachment 133411 [details]
dbgview logfile
Comment 2 microlan101 2020-11-29 14:54:55 UTC
issue topic @ https://invent.kde.org/multimedia/kdenlive/-/issues/813
Comment 3 emohr 2020-11-29 18:57:55 UTC
Thanks for reporting. Your statement in issue #813 is very helpful.
Comment 4 Jean-Baptiste Mardelle 2020-12-02 10:17:06 UTC
This seems to be a KDE frameworks issue. Similar issue was reported for Kate:
https://bugs.kde.org/show_bug.cgi?id=429734
Comment 5 Nate Graham 2020-12-07 18:34:41 UTC

*** This bug has been marked as a duplicate of bug 429943 ***