Bug 429263 - Filelight shows wrong amount of free space
Summary: Filelight shows wrong amount of free space
Status: RESOLVED FIXED
Alias: None
Product: filelight
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Martin Sandsmark
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-17 20:52 UTC by Jakob Erzar
Modified: 2021-01-05 18:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Erzar 2020-11-17 20:52:40 UTC
The amount of available space for a partition does not match the amount of space that is shown by the command df. This is mostly because df accounts for the reserved blocks, whereas Filelight does not. 
Since the reserved blocks usually cannot be used by the user running the program, I think the behavior of Filelight should be changed. This would also make Filelight more consistent with Dolphin, which shows the same amount of free space as df.

STEPS TO REPRODUCE
1. Run df -h and observe the amount of available space on an EXT4 filesystem partition
2. Open Filelight and hover the same partition to see the amount of free space

OBSERVED RESULT
The amount of free space is different between the two programs.

EXPECTED RESULT
The amount of free space should be roughly the same between the two programs.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Linux 5.9.8
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Comment 1 Nate Graham 2021-01-05 18:59:36 UTC
Fixed by you with https://invent.kde.org/utilities/filelight/-/commit/f133de56682412692a9a28103417e4d26083e5aa in Filelight 21.04!