Bug 429235 - Discover sidebar's items get covered up by the header after resizing window to be narrow and then wide again
Summary: Discover sidebar's items get covered up by the header after resizing window t...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: Master
Platform: Other Linux
: VHI normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: regression
: 429533 430528 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-17 10:26 UTC by Bruno Guedes
Modified: 2021-01-12 18:22 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.79


Attachments
Discover just opened (119.12 KB, image/png)
2020-11-17 10:27 UTC, Bruno Guedes
Details
2-discover changed to the mobile interface (57.17 KB, image/png)
2020-11-17 10:27 UTC, Bruno Guedes
Details
3-discover going back to the desktop layout (114.04 KB, image/png)
2020-11-17 10:27 UTC, Bruno Guedes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Guedes 2020-11-17 10:26:18 UTC
SUMMARY

When the discover window is resized horizontally and changes it's layout to the mobile version, and then changed back to the desktop version, some buttons from the side bar get covered by the header (the place where the search bar sits).
It looks like it is caused by the search bar moving when the layout is changed. 

STEPS TO REPRODUCE
1. open discover
2. resize the window horizontally until it changes to the mobile layout
3. resize the window back horizontally to the desktop layout
4. look at the side panel

SOFTWARE/OS VERSIONS

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.1
Kernel Version: 5.4.0-52-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6200U CPU @ 2.30GHz
Memory: 7,2 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520

DISCOVER VERSION: 5.20.3+p20.04+git20201116.1938-0
Comment 1 Bruno Guedes 2020-11-17 10:27:11 UTC
Created attachment 133400 [details]
Discover just opened
Comment 2 Bruno Guedes 2020-11-17 10:27:37 UTC
Created attachment 133401 [details]
2-discover changed to the mobile interface
Comment 3 Bruno Guedes 2020-11-17 10:27:55 UTC
Created attachment 133402 [details]
3-discover going back to the desktop layout
Comment 4 Nate Graham 2020-11-17 16:15:40 UTC
Yikes, can confirm. This didn't used to happen.
Comment 5 Nate Graham 2020-11-17 18:43:39 UTC
This seems related to the drawer.widescreen property being separately defined and tracked compared to drawer.drawerOpen but I haven't figured out how yet.
Comment 6 Nate Graham 2020-11-23 18:50:13 UTC
*** Bug 429533 has been marked as a duplicate of this bug. ***
Comment 7 Mufeed Ali 2020-11-26 00:16:39 UTC
Like I said in 429533, I have the same issue, but additionally, the text labels also seem to disappear occasionally. It's not as easily reproducible as the bug here, but I'm guessing it's related.
Comment 8 Nate Graham 2020-12-18 19:31:17 UTC
*** Bug 430528 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2020-12-18 19:32:19 UTC
Carl says he can reproduce in multiple Kirigami apps; moving to Kirigami.
Comment 10 Marco Martin 2021-01-12 14:35:21 UTC
Git commit 5877afe195f5e873c03d4a29f6251155dd614e5d by Marco Martin.
Committed on 12/01/2021 at 14:17.
Pushed by mart into branch 'master'.

correctly update header size

workaround for https://bugreports.qt.io/browse/QTBUG-90034
the headerParent item wasn't correctly updating its height when
its contents switched from visible to invisible.
setting preferredheight to invalid (-1) when implicitHeight * opacity
is zero, works around the problem

M  +2    -1    src/controls/GlobalDrawer.qml

https://invent.kde.org/frameworks/kirigami/commit/5877afe195f5e873c03d4a29f6251155dd614e5d