Bug 429187 - Text field's clear button overlaps text
Summary: Text field's clear button overlaps text
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.76.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-16 12:11 UTC by medin
Modified: 2020-11-24 17:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.77


Attachments
RTL language and clear icon (15.96 KB, image/png)
2020-11-16 12:11 UTC, medin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description medin 2020-11-16 12:11:45 UTC
Created attachment 133376 [details]
RTL language and clear icon

When I use right to left language the clear icon is shown on top of searched text. See attached image for more info.
Comment 1 Nate Graham 2020-11-16 20:47:07 UTC
Looks like the PlasmaComponents3.TextField does not reverse its clear button properly in RTL mode.
Comment 2 Nate Graham 2020-11-16 21:01:34 UTC
Actually it does reverse itself properly when running plasmashell in RTL mode (plasmashell --reverse) so part of the problem is that you're using an RTL language, but not putting Plasmashell into RTL mode. That will likely end up as another but or a local configuration problem.

The icon overlapping the text is a real issue though. I'll fix that.
Comment 3 Bug Janitor Service 2020-11-16 21:04:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/145
Comment 4 medin 2020-11-17 09:34:50 UTC
(In reply to Nate Graham from comment #2)
> Actually it does reverse itself properly when running plasmashell in RTL
> mode (plasmashell --reverse) so part of the problem is that you're using an
> RTL language, but not putting Plasmashell into RTL mode. That will likely
> end up as another but or a local configuration problem.
> 
> The icon overlapping the text is a real issue though. I'll fix that.

Thanks, I didn't know I can put whole Plasma in RTL mode, is there any GUI settings where I can set it ? because I use french and arabic keyboard layouts (unfortunately Tifinagh is not available on KDE Plasma) at the same time and use only Alt+Shift or Ctrl+Alt+K to switch between them.
Comment 5 Nate Graham 2020-11-17 15:33:56 UTC
I'm afraid I don't know the answer to that question, sorry. :(
Comment 6 Nate Graham 2020-11-24 17:01:44 UTC
Git commit c5fa23f8582b2397295906ed57e3ec9002432700 by Nate Graham.
Committed on 24/11/2020 at 17:01.
Pushed by ngraham into branch 'master'.

[textfield] Fix clear button overlapping text

This change mirrors what the Kirigami ActionTextField does to solve the
same problem.
FIXED-IN: 5.77

M  +4    -3    src/declarativeimports/plasmacomponents3/TextField.qml

https://invent.kde.org/frameworks/plasma-framework/commit/c5fa23f8582b2397295906ed57e3ec9002432700