Bug 429036 - Track ordering in Album view is messed up
Summary: Track ordering in Album view is messed up
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: VHI normal
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords: regression
: 449885 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-12 22:51 UTC by Nate Graham
Modified: 2022-04-05 02:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 22.08


Attachments
Tracks out of order (448.77 KB, image/jpeg)
2020-11-12 22:51 UTC, Nate Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2020-11-12 22:51:59 UTC
Created attachment 133277 [details]
Tracks out of order

Seems like a recent regression. Tracks are listed out of order in the Album view (not Artist view > Album, just Album view).

Will bisect shortly.
Comment 1 Nate Graham 2020-11-12 23:15:42 UTC
Git bisect says this was caused by 645550dfafbfb14da250baa5f92c91a833cf33d9.

Sorry for not noticing until now.
Comment 2 Matthieu Gallien 2020-11-17 15:19:29 UTC
I do not reproduce the bug in itself but I am getting lots of warnings in the console.

qrc:/qml/ListBrowserView.qml:170: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:170: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:170: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:0: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:0: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:0: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:0: ReferenceError: viewModeView is not defined
qrc:/qml/ListBrowserView.qml:0: ReferenceError: viewModeView is not defined


Do you also see them ?
Comment 3 Nate Graham 2021-05-19 19:35:59 UTC
That should be fixed now, but the originally-reported problem remains.
Comment 4 Nate Graham 2022-02-11 17:26:06 UTC
*** Bug 449885 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-04-05 02:18:16 UTC
Git commit c99481d94fd5d67a85227cf4c74f49f254d2771b by Nate Graham.
Committed on 05/04/2022 at 02:07.
Pushed by ngraham into branch 'master'.

Collapse ListBrowserView into DataListView

Just like the prior commit, this does the same thing to ListBrowserView
to reduce code duplication and simplify the control flow, which will make
it harder for subtle bugs to creep in, such as 429036 which seems to be
fixed with this refactor.
FIXED-IN: 22.08

M  +0    -1    src/CMakeLists.txt
M  +181  -53   src/qml/DataListView.qml
D  +0    -187  src/qml/ListBrowserView.qml
M  +0    -1    src/resources.qrc

https://invent.kde.org/multimedia/elisa/commit/c99481d94fd5d67a85227cf4c74f49f254d2771b