Bug 428968 - Show audio activity like pavucontrol
Summary: Show audio activity like pavucontrol
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_pulseaudio (show other bugs)
Version: 5.20.2
Platform: Archlinux Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-11 12:25 UTC by Manuel C
Modified: 2021-01-05 20:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel C 2020-11-11 12:25:03 UTC
I sometimes need to redirect some audio streams to a different output devices, and in particular with firefox it's difficult to tell which device corresponds to which playback without having a monitor bar like in pavucontrol.
I am currently using pavucontrol for this, but with > 8 playback streams the interface becomes difficult to use, as pavucontrol's volume bars react to scrolling, causing accidental mayhem way too often.
I would prefer to use the SystemSettings Audio panel for this, mainly since it does not react badly to scrolling, but also because it is just better integrated (tray > Configure audio)

Linux: 5.9.4-arch1-1
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Comment 1 Nate Graham 2020-11-11 21:34:35 UTC
Related to, but not 100% a duplicate of Bug 411563.

Either way, it will be implemented with https://invent.kde.org/plasma/plasma-pa/-/merge_requests/21!
Comment 2 David Redondo 2021-01-05 20:43:47 UTC
Git commit 3e80ee13687a4db8f45c8aa63d741e688209bd48 by David Redondo.
Committed on 05/01/2021 at 20:41.
Pushed by davidre into branch 'master'.

Show current Volume in Plasmoid sliders

We draw the background of slider now manually. The length of the highlight
shows the current volume. Minimum is the minimal width of the element,
maximum is highlight up to the handle position and when nothing is playing
no highlight is shown. An animation makes the transitions a bit smoother.
Related: bug 411563

M  +30   -0    applet/contents/ui/ListItemBase.qml

https://invent.kde.org/plasma/plasma-pa/commit/3e80ee13687a4db8f45c8aa63d741e688209bd48