Bug 428955 - Progressbar indicator may overshoot while running back and forth
Summary: Progressbar indicator may overshoot while running back and forth
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.75.0
Platform: Other Other
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
: 428310 446676 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-11 09:27 UTC by postix
Modified: 2021-12-16 02:06 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.77


Attachments
Screenrecording (234.83 KB, video/mp4)
2020-11-11 09:27 UTC, postix
Details
Frame by frame (248.10 KB, image/png)
2020-11-11 09:30 UTC, postix
Details
[5.88.0] Screenrecording of the issue (774.33 KB, video/x-matroska)
2021-12-14 17:11 UTC, postix
Details
Can't reproduce (13.44 KB, image/gif)
2021-12-15 15:17 UTC, Noah Davis
Details
Can't reproduce with actual notification UI either (35.09 KB, video/webm)
2021-12-15 15:24 UTC, Noah Davis
Details
progressbar3.qml (93.58 KB, video/mp4)
2021-12-15 16:39 UTC, David Redondo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2020-11-11 09:27:52 UTC
Created attachment 133217 [details]
Screenrecording

SUMMARY

When the "small blue bar" runs back and forth until the progressbar actually starts filling up, it may happen that the "small blue bar" overshoots the progressbar on the right end by a few pixels. You can see in the screen recording at frame 39-43. 


STEPS TO REPRODUCE

1. Start your FireFox 82
2. Open https://de.leica-camera.com/Fotografie/Leica-Q/Leica-Q2-Monochrom/Technische-Einblicke
3. Download one of those b/w tiff images


SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1

ADDITIONAL INFORMATION
Scaling: 2.0
X11
Comment 1 postix 2020-11-11 09:30:44 UTC
Created attachment 133218 [details]
Frame by frame

It's easier to see here than in the recording.
Comment 2 Bug Janitor Service 2020-11-11 11:21:05 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/140
Comment 3 Nate Graham 2020-11-24 17:05:19 UTC
*** Bug 428310 has been marked as a duplicate of this bug. ***
Comment 4 David Redondo 2020-11-25 09:37:55 UTC
Git commit 472f4212a9496c6bc3aea347b66bbb9ab6f0c630 by David Redondo.
Committed on 25/11/2020 at 07:55.
Pushed by davidre into branch 'master'.

Finish the animation before changing the length of the progressbar highlight

This messes with the running animation and can lead to it overshooting the track.

M  +4    -1    src/declarativeimports/plasmacomponents3/ProgressBar.qml

https://invent.kde.org/frameworks/plasma-framework/commit/472f4212a9496c6bc3aea347b66bbb9ab6f0c630
Comment 5 postix 2021-12-14 17:11:42 UTC
Created attachment 144545 [details]
[5.88.0] Screenrecording of the issue

As far as I can remember, it had been indeed fixed, but today it happened again on

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.6-200.fc35.x86_64 (64-bit)
Graphics Platform: X11

when I downloaded the KERNEL or EVA file from [1]. Please  see the screen recording.

[1] https://firmware-selector.openwrt.org/?version=21.02.1&target=ipq40xx%2Fgeneric&id=avm_fritzbox-4040
Comment 6 Nate Graham 2021-12-14 21:40:21 UTC
*** Bug 446676 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-12-14 21:40:58 UTC
Can also reproduce on Fedora 35, albeit with all KDE stuff built from source.
Comment 8 David Redondo 2021-12-15 08:47:01 UTC
Broken by https://invent.kde.org/frameworks/plasma-framework/-/commit/416e6853442bd08e6ef25ae040951f56c26455b3

This commit removed the fix for the bug, and can be observed in tests/progressbar3.qml....
Comment 9 Nate Graham 2021-12-15 15:02:41 UTC
Yeah, that's what happens with total rewrites. They always accidentally remove hidden bugfixes that weren't commented well or at all. :( 

This is why I strongly prefer lots of inline comments when fixing bugs, and and targeted fixes rather than total rewrites.
Comment 10 Noah Davis 2021-12-15 15:16:33 UTC
(In reply to David Redondo from comment #8)
> Broken by
> https://invent.kde.org/frameworks/plasma-framework/-/commit/
> 416e6853442bd08e6ef25ae040951f56c26455b3
> 
> This commit removed the fix for the bug, and can be observed in
> tests/progressbar3.qml....

I can't reproduce any bugs with tests/progressbar3.qml
Comment 11 Noah Davis 2021-12-15 15:17:13 UTC
Created attachment 144571 [details]
Can't reproduce
Comment 12 Noah Davis 2021-12-15 15:18:21 UTC
Eh, GIF is a bit low FPS. It's actually smooth in the UI.
Comment 13 Noah Davis 2021-12-15 15:24:09 UTC
Created attachment 144572 [details]
Can't reproduce with actual notification UI either
Comment 14 Nate Graham 2021-12-15 15:56:38 UTC
The test works for me too, but I saw this in an actual notification recently.
Comment 15 David Redondo 2021-12-15 16:35:44 UTC
(In reply to Noah Davis from comment #11)
> Created attachment 144571 [details]
> Can't reproduce

Untoggle the checkbox as the label describes :)
Comment 16 David Redondo 2021-12-15 16:39:26 UTC
Created attachment 144579 [details]
progressbar3.qml

Bug happens when the width of the indicator changes during the animation
Comment 17 Bug Janitor Service 2021-12-15 18:46:08 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/414
Comment 18 Noah Davis 2021-12-16 02:06:15 UTC
Git commit aa9097ef77320df8d523ba86b1afad1ea0d531b3 by Noah Davis.
Committed on 16/12/2021 at 01:53.
Pushed by ndavis into branch 'master'.

PC3 ProgressBar: fix fill going OOB when indeterminate state ends

M  +13   -5    src/declarativeimports/plasmacomponents3/ProgressBar.qml

https://invent.kde.org/frameworks/plasma-framework/commit/aa9097ef77320df8d523ba86b1afad1ea0d531b3