Bug 428885 - Open dolphin in current activity folder by default
Summary: Open dolphin in current activity folder by default
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2020-11-09 13:05 UTC by Aldoo
Modified: 2020-12-22 22:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aldoo 2020-11-09 13:05:52 UTC
In dolphin (and in the KIO ecosystem) the URL "activities:/current" points to a virtual folder where you can find all stuff tagged for current activity.

This is typically the files I want to quickly access to when I open dolphin, so I wanted to set up the startup URL as "activities:/current". Alas, the configuration dialog won't let me do this. It pops up an error dialog instead: "The location of personal folder is invalid or does not exist. It will not be applied." (not sure about the exact message: my UI is in French).

Could this be fixed so that dolphin accepts that sort of URL?

(same for any other KIO compatible URL, by the way, as it seems the problem is more general: so far, according to what I tried, only local file system locations seem to work)
Comment 1 Nate Graham 2020-11-09 14:04:50 UTC
Seems reasonable. Right now the text field in the settings window for the initial view to open only accepts real locations, but it could easily be altered to accept abstract URIs like this one as well.
Comment 2 Bug Janitor Service 2020-11-14 17:17:23 UTC
A possibly relevant merge request was started @ https://invent.kde.org/system/dolphin/-/merge_requests/109
Comment 3 Elvis Angelaccio 2020-12-21 21:56:59 UTC
Git commit 87bb0ca10b9a486d982ceadf9be3d0dad68cf437 by Elvis Angelaccio, on behalf of Derek Christ.
Committed on 21/12/2020 at 21:28.
Pushed by elvisangelaccio into branch 'master'.

Allow non-local startup location

Only local directories were supported to be set as the starting location
of Dolphin. This commit fixes this by using an KIO::StatJob to determine
if the path is actually pointing to a directory or a file regardless if
it is a local or a remote path.

Additionaly a hard-coded exception for urls with the scheme "timeline"
was removed because with the new fix it is now obsolete.

M  +16   -4    src/settings/startup/startupsettingspage.cpp
M  +1    -0    src/settings/startup/startupsettingspage.h

https://invent.kde.org/system/dolphin/commit/87bb0ca10b9a486d982ceadf9be3d0dad68cf437