Bug 428881 - About this System page: make the text mouse-selectable
Summary: About this System page: make the text mouse-selectable
Status: RESOLVED FIXED
Alias: None
Product: kinfocenter
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: usability
: 435958 451464 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-09 11:02 UTC by dezifit
Modified: 2022-10-09 14:23 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dezifit 2020-11-09 11:02:42 UTC
SUMMARY
It's not possible to copy text from the system information panel.

STEPS TO REPRODUCE
1. Open the system information panel
2. Try to copy a version number to the clipboard

OBSERVED RESULT
Text and version numbers aren't selectable: it's not possible to copy version numbers to the clipboard.

EXPECTED RESULT
The system information panel should provide selectable text/version numbers, for example to paste them in bug reports.

SOFTWARE/OS VERSIONS
Linux Kernel: 5.18_1 (x86_64)
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2020-11-09 18:23:44 UTC
Yeah.
Comment 2 Harald Sitter 2021-04-20 16:27:42 UTC
*** Bug 435958 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-03-25 15:14:20 UTC
*** Bug 451464 has been marked as a duplicate of this bug. ***
Comment 4 Bug Janitor Service 2022-10-01 09:07:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kinfocenter/-/merge_requests/114
Comment 5 xunilhcra 2022-10-02 08:40:41 UTC
Hello, I was about to submit a report about this but see it already exists. The text in the info center should be capable of being selected to copy/paste the information to another location. Please add this feature. Thank you.
Comment 6 Nate Graham 2022-10-09 14:23:28 UTC
Git commit 01b3c73ff2fdb73e492abd7f1b87c8960ceb20f4 by Nate Graham, on behalf of Bharadwaj Raju.
Committed on 09/10/2022 at 14:23.
Pushed by ngraham into branch 'master'.

Make value labels in form layouts individually selectable and copyable

If text in a value label is selected, Ctrl+C will copy that. Otherwise it will
copy the whole thing as usual.
FIXED-IN: 5.27

M  +11   -2    Modules/about-distro/src/package/contents/ui/main.qml
M  +8    -2    Modules/energy/package/contents/ui/main.qml

https://invent.kde.org/plasma/kinfocenter/commit/01b3c73ff2fdb73e492abd7f1b87c8960ceb20f4