Bug 428113 - -o/--output option not respected
Summary: -o/--output option not respected
Status: RESOLVED DUPLICATE of bug 425573
Alias: None
Product: Spectacle
Classification: Applications
Component: General (show other bugs)
Version: 20.08.2
Platform: Archlinux Linux
: NOR major
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-22 21:26 UTC by Janek
Modified: 2020-11-10 20:40 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek 2020-10-22 21:26:09 UTC
Specifying a file path for the background mode doesn't work:

spectacle -b --output "/tmp/test.png"

Regardless of the path (I tried many different ones) it saves the file to the pictures folder...
Comment 1 Justin Zobel 2020-10-23 03:17:49 UTC
Confirmed, also effects 20.08.1

Even though it's saying it's going to the Pictures folder in the popup it's just sitting in my home directory.

No matter what directory I'm running spectacle from it always ends up in my home directory, filename is also not respected, it just names it as default.
Comment 2 Justin Zobel 2020-10-23 03:23:51 UTC
Please disregard paragraphs 2 and 3, that was a configuration issue on my end.
Comment 3 Méven Car 2020-10-24 06:11:36 UTC
I don't reproduce with spectacle 20.04, it must be dependent on a setting.
Comment 4 Justin Zobel 2020-10-24 06:35:16 UTC
(In reply to Méven Car from comment #3)
> I don't reproduce with spectacle 20.04, it must be dependent on a setting.

Might have been a regression in 20.08 onwards.
Comment 5 Justin Zobel 2020-10-25 02:17:36 UTC
Tested:
20.04.3 works
20.08.0 doesn't work

So the regression was between 20.04.3 and 20.08.0.
Comment 6 Méven Car 2020-10-25 06:50:00 UTC
(In reply to Justin from comment #5)
> Tested:
> 20.04.3 works
> 20.08.0 doesn't work
> 
> So the regression was between 20.04.3 and 20.08.0.

Thanks for confirming the regression, master is concerned as well.
Comment 7 Méven Car 2020-10-25 06:58:44 UTC
This has already reported a couple of times and fixed in spectacle 20.08.3 (november minor release).

*** This bug has been marked as a duplicate of bug 425573 ***
Comment 8 Magnus Boman 2020-11-10 16:03:33 UTC
This is getting outrageous, this bug was fixed THREE months ago https://invent.kde.org/graphics/spectacle/-/merge_requests/11 and has yet to be included in a release. I am still forced to use spectacle-git so be able to set an output path. For the love of.. *please* do something.

It is NOT fixed in spectacle 20.08.3, --output is still completely ignored!
Comment 9 Christoph Feck 2020-11-10 20:40:27 UTC
Commits to "master" branch will be available with version 20.12.0.