Bug 428075 - [Wayland] Unable to paste to some GTK apps when selecting an entry in klipper
Summary: [Wayland] Unable to paste to some GTK apps when selecting an entry in klipper
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: 5.20.5
Platform: Other Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: wayland
: 428521 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-21 21:12 UTC by Till Schäfer
Modified: 2021-03-18 15:39 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21.4


Attachments
backported patch from pull requst 365 to 5.20.1 (3.99 KB, patch)
2020-10-26 22:13 UTC, Till Schäfer
Details
backported patch from pull requst 365 to 5.20.2 (4.39 KB, patch)
2020-10-31 23:03 UTC, Till Schäfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2020-10-21 21:12:25 UTC
When I select a klipper entry I am unable to paste the content to GTK apps (tested: firefox, gimp), while it is working for QT apps (tested: kate, kmail (unter xwayland)). Pasting the the GTK apps is possible whenever I directly copy some text with control+c. This selection is also visible in klipper. 

So i guess it is related to GTK vs QT. 

SOFTWARE/OS VERSIONS
Operating System: Gentoo Linux
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.8.16-gentoo
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 1 Till Schäfer 2020-10-21 21:17:51 UTC
forgot to mention, that this is only observable on wayland.
Comment 2 Patrick Silva 2020-10-22 09:57:22 UTC
Possibly duplicate of bug 424754
Comment 3 Till Schäfer 2020-10-22 11:25:17 UTC
(In reply to Patrick Silva from comment #2)
> Possibly duplicate of bug 424754

They might be different: 
* This bug is 100% reproducible (no randomness involved for me)
* I have no problem doing a copy paste from xwayland apps (e.g. KMail).
* This problem is only related to Klipper.
* Paste is possible to a subset of applications
Comment 4 Nate Graham 2020-10-26 19:26:20 UTC
yeah not quite the same, but possibly related. Once the fix for Bug 424754 is merged and released, it would be good if you can re-test.
Comment 5 Till Schäfer 2020-10-26 22:10:14 UTC
I have done a quick and dirty rebase of https://invent.kde.org/plasma/kwin/-/merge_requests/365 on 5.20.1 and applied the patch here on my gentoo box. It seems indeed to fix the issue :)
Comment 6 Till Schäfer 2020-10-26 22:13:07 UTC
Created attachment 132773 [details]
backported patch from pull requst 365 to 5.20.1
Comment 7 Nate Graham 2020-10-27 01:10:46 UTC
Great, then let's mark it as a duplicate of Bug 424754, since fixing that will fix this too. Thanks for testing!

*** This bug has been marked as a duplicate of bug 424754 ***
Comment 8 Till Schäfer 2020-10-27 13:52:16 UTC
Sry for the noise. After using the patch some time, the issue reappeared. Thus, the patch is not fixing the issue. The original issue seems to be involve some randomness (race condition?) I have not observed before.
Comment 9 Nate Graham 2020-10-27 17:16:02 UTC
Boooooooo!
Comment 10 David Edmundson 2020-10-30 21:13:30 UTC
>After using the patch some time

This comment is written before the version that was approved and merged.

Please re-test and reopen if needed.
Comment 11 Till Schäfer 2020-10-31 23:03:29 UTC
Created attachment 132926 [details]
backported patch from pull requst 365 to 5.20.2
Comment 12 Till Schäfer 2020-10-31 23:04:23 UTC
still not working with current state of merge request 365 rebased on 5.20.2
Comment 13 Patrick Silva 2020-11-13 10:29:53 UTC
bug 424754 is fixed on neon unstable, but this problem persists.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.20.80
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Comment 14 Patrick Silva 2020-11-13 12:13:35 UTC
*** Bug 428521 has been marked as a duplicate of this bug. ***
Comment 15 Till Schäfer 2021-01-07 13:30:56 UTC
still an issue with this updated software stack 

Operating System: Gentoo Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.5-gentoo
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 16 Fabio 2021-02-08 11:24:49 UTC
I can reproduce this problem every single time; it is a mayor annoyance.
Is there a way I can help in debugging this issue and getting it fixed?
Thank you

SOFTWARE/OS VERSIONS
Operating System: Slackware Linux -current
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.14
OS Type: 64-bit
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15,0 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 17 Fabio 2021-02-26 17:41:04 UTC
Just submitted a proposal fix: https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/676
Comment 18 Nate Graham 2021-03-17 19:59:23 UTC
Fixed by Fabio Bas with https://invent.kde.org/plasma/plasma-workspace/-/commit/65c6955148d8d975fe1f7352f6249be9ac584027 in Plasma 5.21.4!
Comment 19 Till Schäfer 2021-03-18 12:03:45 UTC
(In reply to Nate Graham from comment #18)
> Fixed by Fabio Bas with
> https://invent.kde.org/plasma/plasma-workspace/-/commit/
> 65c6955148d8d975fe1f7352f6249be9ac584027 in Plasma 5.21.4!

I can confirm, that the patch works as expected on top of 5.21.3. 

Thank you very much! This was the last showstopper for me to actually use wayland on my laptop.
Comment 20 Nate Graham 2021-03-18 15:39:46 UTC
Awesome.