Bug 427976 - Network Speed desktop widget displays wrong values
Summary: Network Speed desktop widget displays wrong values
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.20.0
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-19 13:28 UTC by JC Francois
Modified: 2020-10-20 08:32 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JC Francois 2020-10-19 13:28:39 UTC
SUMMARY
Network Speed desktop widget displays values that appear ~2x the values reported by other means (e.g. KSysGuard, scp, rsync, etc.).


STEPS TO REPRODUCE
1. Right click on Desktop and select "Add Widgets..."
2. Drag and drop "Network Speed" widget on the desktop
3. open KSysGuard next to it
4. perform a network tranfert or a speed test (speedtest.net)

OBSERVED RESULT
Values displayed by the widget lag behind and are ~2x the values reported by KSysGuard.


EXPECTED RESULT
Same values.

SOFTWARE/OS VERSIONS
Linux: 5.9-MANJARO
KDE Plasma Version: 5.20
KDE Frameworks Version: 5.75
Qt Version: 5.15.1

ADDITIONAL INFORMATION
Related discussion on Manjaro forum with the confirmation of other users:
https://forum.manjaro.org/t/testing-plasma-5-20-network-speed-applet-displays-incorrect-values/31958
Comment 1 Patrick Silva 2020-10-19 17:08:23 UTC
I confirm on Arch Linux running Plasma 5.20. Here is my screenshot
https://bugsfiles.kde.org/attachment.cgi?id=132384
Comment 2 Marco Martin 2020-10-20 08:32:29 UTC
fixed by this merge
https://invent.kde.org/plasma/ksysguard/-/merge_requests/49