Bug 427702 - Some of the search folders in this query are still being indexed or are excluded from indexing completely. The results below may be incomplete.
Summary: Some of the search folders in this query are still being indexed or are exclu...
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: search (show other bugs)
Version: 5.15.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-14 15:51 UTC by grannie
Modified: 2021-04-21 05:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grannie 2020-10-14 15:51:49 UTC
SUMMARY
If I search something in specific folders I get the message:
"Some of the search folders in this query are still being indexed or are excluded from indexing completely. The results below may be incomplete."

I can click "reindex".

After doing so I can search again, however the message occurs again.

The only Logging messages in akonadi console above "info" are:
Fetched an item which is already in the model
Comment 1 grannie 2020-10-14 15:54:31 UTC
E.g. my filter is:
message status is not read.

in approx 10 specific folders.

2 folders are allegedly not indexed.

After forceful reindex the search contains a lot of read messages (which is clearly against the filter rule)
Comment 2 grannie 2020-10-14 15:59:48 UTC
please excuse my inaccuracy:

The message "Some of the search folders in this query are still being indexed or are excluded from indexing completely. The results below may be incomplete."
occurs after the click on the search folder (above the results)

After searching again (press 's')

I get: "Some of the folders you want to search in are not fully indexed yet or have been excluded from indexing. All the folders checked below will be scheduled for priority reindexing. If you uncheck a folder it may still be indexed later, unless it was manually excluded from indexing."
Here I can click "Reindex"
Comment 3 grannie 2020-11-02 16:57:37 UTC
Is kmail dead since no one seems to care about bug reports?!
Comment 4 Christoph Feck 2020-11-03 20:10:47 UTC
Are you experience search is not working because of this message? It is unclear from your description if the message is wrong or actually true.
Comment 5 grannie 2020-11-05 08:28:09 UTC
Well, it's difficult to say since I'm not experiencing a normal search at all (see: https://bugs.kde.org/show_bug.cgi?id=426472 or https://bugs.kde.org/show_bug.cgi?id=428718)

But I guess it is not working.
Comment 6 Bug Janitor Service 2020-11-20 04:33:49 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Christoph Feck 2020-11-20 11:08:19 UTC
Thanks for the update; changing status for inspection.
Comment 8 grannie 2021-04-21 05:40:41 UTC
any update on this issue?