Bug 427687 - Show additional options for application doesn't expand anymore
Summary: Show additional options for application doesn't expand anymore
Status: RESOLVED FIXED
Alias: None
Product: plasma-pa
Classification: Plasma
Component: applet (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: VHI normal
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords: regression
: 427734 427769 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-14 12:06 UTC by Nils
Modified: 2020-10-16 13:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.20.1


Attachments
Menu doesn't show up (16.53 KB, image/png)
2020-10-14 12:06 UTC, Nils
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nils 2020-10-14 12:06:52 UTC
Created attachment 132346 [details]
Menu doesn't show up

SUMMARY

When clicking on the "show additional options for XXX" in the applications part, nothing shows out. 

STEPS TO REPRODUCE
1. Launch a session and play some sound on some application
2. Try to switch for this specific application the device output
3. Can't do it

OBSERVED RESULT

Nothing shows off

EXPECTED RESULT

The select allowing us to choose a device output should appear

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.8.14-arch1-1
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1

ADDITIONAL INFORMATION

See capture
Comment 1 David Redondo 2020-10-15 07:56:16 UTC
*** Bug 427734 has been marked as a duplicate of this bug. ***
Comment 2 Bug Janitor Service 2020-10-15 07:57:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-pa/-/merge_requests/15
Comment 3 Patrick Silva 2020-10-15 20:08:20 UTC
*** Bug 427769 has been marked as a duplicate of this bug. ***
Comment 4 David Redondo 2020-10-16 13:12:23 UTC
Git commit 9e002e019f01098401cbadddbb83b135f3fba1d7 by David Redondo.
Committed on 16/10/2020 at 13:12.
Pushed by davidre into branch 'master'.

Correctly look up data in the model

Commit fbd66cdc9d89262ed32cbf0c9c6263615e3b2ff5 exposed this preexisting bug.
Before sModel was always a PlasmaCore.SortFilterModel but now that we can hit the
!showHiddenDevices.visible condition in main.qml:546/573 it can also just be
a normal SourceModel or SinkModel that do not have a get() method like the
SortFilterModel. So we have to access the data properly.
FIXED-IN:5.20.1

M  +5    -5    applet/contents/ui/ListItemBase.qml

https://invent.kde.org/plasma/plasma-pa/commit/9e002e019f01098401cbadddbb83b135f3fba1d7
Comment 5 David Redondo 2020-10-16 13:13:28 UTC
Git commit 463544c76af4f4574653da79a8072a9cb6a4e28b by David Redondo.
Committed on 16/10/2020 at 13:13.
Pushed by davidre into branch 'Plasma/5.20'.

Correctly look up data in the model

Commit fbd66cdc9d89262ed32cbf0c9c6263615e3b2ff5 exposed this preexisting bug.
Before sModel was always a PlasmaCore.SortFilterModel but now that we can hit the
!showHiddenDevices.visible condition in main.qml:546/573 it can also just be
a normal SourceModel or SinkModel that do not have a get() method like the
SortFilterModel. So we have to access the data properly.
FIXED-IN:5.20.1


(cherry picked from commit 9e002e019f01098401cbadddbb83b135f3fba1d7)

M  +5    -5    applet/contents/ui/ListItemBase.qml

https://invent.kde.org/plasma/plasma-pa/commit/463544c76af4f4574653da79a8072a9cb6a4e28b